summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2010-07-18 06:50:55 +0000
committerChristian Faulhammer <fauli@gentoo.org>2010-07-18 06:50:55 +0000
commit7158478e58dc036652bb3d6cdcbbf0282e263912 (patch)
treeda7f769716bb8f752f823633c38ab77b75b3c714 /dev-python/subunit
parentVersion bump. (diff)
downloadgentoo-2-7158478e58dc036652bb3d6cdcbbf0282e263912.tar.gz
gentoo-2-7158478e58dc036652bb3d6cdcbbf0282e263912.tar.bz2
gentoo-2-7158478e58dc036652bb3d6cdcbbf0282e263912.zip
version bump for bug 327185 by LiuCougar <liucougar AT gmail DOT com>
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'dev-python/subunit')
-rw-r--r--dev-python/subunit/ChangeLog8
-rw-r--r--dev-python/subunit/subunit-0.0.6.ebuild35
2 files changed, 42 insertions, 1 deletions
diff --git a/dev-python/subunit/ChangeLog b/dev-python/subunit/ChangeLog
index 535659e98ace..5769378459d5 100644
--- a/dev-python/subunit/ChangeLog
+++ b/dev-python/subunit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/subunit
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/subunit/ChangeLog,v 1.2 2010/04/08 17:57:19 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/subunit/ChangeLog,v 1.3 2010/07/18 06:50:55 fauli Exp $
+
+*subunit-0.0.6 (18 Jul 2010)
+
+ 18 Jul 2010; Christian Faulhammer <fauli@gentoo.org>
+ +subunit-0.0.6.ebuild:
+ version bump for bug 327185 by LiuCougar <liucougar AT gmail DOT com>
08 Apr 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
subunit-0.0.5.ebuild:
diff --git a/dev-python/subunit/subunit-0.0.6.ebuild b/dev-python/subunit/subunit-0.0.6.ebuild
new file mode 100644
index 000000000000..eb6b4c9f2711
--- /dev/null
+++ b/dev-python/subunit/subunit-0.0.6.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/subunit/subunit-0.0.6.ebuild,v 1.1 2010/07/18 06:50:55 fauli Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+PYTHON_EXPORT_PHASE_FUNCTIONS="1"
+
+inherit python
+
+DESCRIPTION="A streaming protocol for test results"
+HOMEPAGE="https://launchpad.net/subunit"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=dev-python/testtools-0.9.4"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ dev-libs/check
+ dev-util/cppunit
+ dev-util/pkgconfig"
+RESTRICT_PYTHON_ABIS="3.*"
+
+pkg_postinst() {
+ python_mod_optimize subunit
+}
+
+pkg_postrm() {
+ python_mod_cleanup subunit
+}