summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-07-08 05:08:14 +0000
committerIan Delaney <idella4@gentoo.org>2015-07-08 05:08:14 +0000
commit47986d0d6ac0149a5789f88a90cb851f0e6645ed (patch)
treee5d6ddc14d43d962e8c20f482e854b7b2f4f92cf /dev-python/stevedore
parentStable for PPC64 (bug #554104). (diff)
downloadgentoo-2-47986d0d6ac0149a5789f88a90cb851f0e6645ed.tar.gz
gentoo-2-47986d0d6ac0149a5789f88a90cb851f0e6645ed.tar.bz2
gentoo-2-47986d0d6ac0149a5789f88a90cb851f0e6645ed.zip
bump; drop use if patch substitute with sed, re-add dep dev-python/six, update deps, replace test phase, rm old
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/stevedore')
-rw-r--r--dev-python/stevedore/ChangeLog9
-rw-r--r--dev-python/stevedore/stevedore-0.15-r1.ebuild45
-rw-r--r--dev-python/stevedore/stevedore-0.15.ebuild45
-rw-r--r--dev-python/stevedore/stevedore-1.0.0.ebuild47
-rw-r--r--dev-python/stevedore/stevedore-1.6.0.ebuild59
5 files changed, 67 insertions, 138 deletions
diff --git a/dev-python/stevedore/ChangeLog b/dev-python/stevedore/ChangeLog
index 48948b729338..173d06726db1 100644
--- a/dev-python/stevedore/ChangeLog
+++ b/dev-python/stevedore/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/stevedore
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/stevedore/ChangeLog,v 1.34 2015/07/07 16:38:28 zlogene Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/stevedore/ChangeLog,v 1.35 2015/07/08 05:08:14 idella4 Exp $
+
+*stevedore-1.6.0 (08 Jul 2015)
+
+ 08 Jul 2015; Ian Delaney <idella4@gentoo.org> +stevedore-1.6.0.ebuild,
+ -stevedore-0.15-r1.ebuild, -stevedore-0.15.ebuild, -stevedore-1.0.0.ebuild:
+ bump; drop use if patch substitute with sed, re-add dep dev-python/six, update
+ deps, replace test phase, rm old
07 Jul 2015; Mikle Kolyada <zlogene@gentoo.org> stevedore-1.3.0.ebuild:
amd64 stable wrt bug #554114
diff --git a/dev-python/stevedore/stevedore-0.15-r1.ebuild b/dev-python/stevedore/stevedore-0.15-r1.ebuild
deleted file mode 100644
index 819dd65f7c74..000000000000
--- a/dev-python/stevedore/stevedore-0.15-r1.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/stevedore/stevedore-0.15-r1.ebuild,v 1.2 2014/07/06 12:50:02 mgorny Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
-
-inherit distutils-r1
-
-DESCRIPTION="Manage dynamic plugins for Python applications"
-HOMEPAGE="https://github.com/dreamhost/stevedore"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/pbr-0.5.21[${PYTHON_USEDEP}]
- <dev-python/pbr-1.0[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/coverage[${PYTHON_USEDEP}]
- dev-python/flake8[${PYTHON_USEDEP}] )
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP}] )"
-
-python_compile_all() {
- if use doc; then
- mkdir docs/source/_build || die
- sphinx-build -b html -c docs/source docs/source/ docs/source/_build
- fi
-}
-
-python_test() {
- nosetests -d --with-coverage --cover-inclusive --cover-package stevedore \
- || die "Tests failed under ${EPYTHON}"
- flake8 stevedore setup.py || die
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/source/_build/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/stevedore/stevedore-0.15.ebuild b/dev-python/stevedore/stevedore-0.15.ebuild
deleted file mode 100644
index 172b99e70b9e..000000000000
--- a/dev-python/stevedore/stevedore-0.15.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/stevedore/stevedore-0.15.ebuild,v 1.5 2015/04/08 08:05:06 mgorny Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3} )
-
-inherit distutils-r1
-
-DESCRIPTION="Manage dynamic plugins for Python applications"
-HOMEPAGE="https://github.com/dreamhost/stevedore"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/pbr-0.5.21[${PYTHON_USEDEP}]
- <dev-python/pbr-1.0[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/coverage[${PYTHON_USEDEP}]
- dev-python/flake8[${PYTHON_USEDEP}] )
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP}] )"
-
-python_compile_all() {
- if use doc; then
- mkdir docs/source/_build || die
- sphinx-build -b html -c docs/source docs/source/ docs/source/_build
- fi
-}
-
-python_test() {
- nosetests -d --with-coverage --cover-inclusive --cover-package stevedore \
- || die "Tests failed under ${EPYTHON}"
- flake8 stevedore setup.py || die
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/source/_build/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/stevedore/stevedore-1.0.0.ebuild b/dev-python/stevedore/stevedore-1.0.0.ebuild
deleted file mode 100644
index 8d5cd63e9d56..000000000000
--- a/dev-python/stevedore/stevedore-1.0.0.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/stevedore/stevedore-1.0.0.ebuild,v 1.2 2014/10/26 03:05:49 floppym Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
-
-inherit distutils-r1
-
-DESCRIPTION="Manage dynamic plugins for Python applications"
-HOMEPAGE="https://github.com/dreamhost/stevedore"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/pbr[${PYTHON_USEDEP}]
- test? (
- >=dev-python/mock-1.0[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- )
- doc? (
- >=dev-python/pillow-2.4.0[${PYTHON_USEDEP}]
- >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
- !~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
- <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
- )
-"
-RDEPEND=">=dev-python/six-1.7.0[${PYTHON_USEDEP}]"
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- nosetests stevedore || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/build/. )
-
- distutils-r1_python_install_all
-}
diff --git a/dev-python/stevedore/stevedore-1.6.0.ebuild b/dev-python/stevedore/stevedore-1.6.0.ebuild
new file mode 100644
index 000000000000..00d2fbce8436
--- /dev/null
+++ b/dev-python/stevedore/stevedore-1.6.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/stevedore/stevedore-1.6.0.ebuild,v 1.1 2015/07/08 05:08:14 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="Manage dynamic plugins for Python applications"
+HOMEPAGE="https://github.com/openstack/stevedore https://pypi.python.org/pypi/stevedore"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pbr-0.8.0[${PYTHON_USEDEP}]
+ <dev-python/pbr-1.0.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/mock-1.0[${PYTHON_USEDEP}]
+ >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-1.5.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-sphinx-2.5.0[${PYTHON_USEDEP}]
+ )
+ doc? (
+ >=dev-python/pillow-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-sphinx-2.2.0[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND=">=dev-python/six-1.9.0[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ # Delete spurious data in requirements.txt
+ sed -e '/pbr<2.0,/d' -e '/argparse/d' \
+ -i requirements.txt || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx
+}
+
+python_test() {
+ esetup.py testr
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+
+ distutils-r1_python_install_all
+}