summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2012-03-01 14:56:22 +0000
committerDirkjan Ochtman <djc@gentoo.org>2012-03-01 14:56:22 +0000
commit378f27f48b039a986a55b99861ea6824389ec5a9 (patch)
tree6dd09c3d106786b469e43321e4d0c05e8cf198cd /dev-python/ssh/ssh-1.7.13.ebuild
parentManifest fix (diff)
downloadgentoo-2-378f27f48b039a986a55b99861ea6824389ec5a9.tar.gz
gentoo-2-378f27f48b039a986a55b99861ea6824389ec5a9.tar.bz2
gentoo-2-378f27f48b039a986a55b99861ea6824389ec5a9.zip
Initial version of ssh, a paramiko fork used in fabric (for bug 389107).
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/ssh/ssh-1.7.13.ebuild')
-rw-r--r--dev-python/ssh/ssh-1.7.13.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/ssh/ssh-1.7.13.ebuild b/dev-python/ssh/ssh-1.7.13.ebuild
new file mode 100644
index 000000000000..00d2d61ac427
--- /dev/null
+++ b/dev-python/ssh/ssh-1.7.13.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ssh/ssh-1.7.13.ebuild,v 1.1 2012/03/01 14:56:22 djc Exp $
+
+EAPI="4"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython *-pypy-*"
+
+inherit distutils
+
+DESCRIPTION="SSH2 protocol library"
+HOMEPAGE="http://pypi.python.org/pypi/ssh"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris"
+IUSE="doc examples"
+
+RDEPEND=">=dev-python/pycrypto-2.1"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+
+src_test() {
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" test.py --verbose
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dohtml docs/*
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r demos
+ fi
+}