summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2013-01-14 15:19:48 +0000
committerAndrey Grozin <grozin@gentoo.org>2013-01-14 15:19:48 +0000
commita6394d983422ecc0350597b612d1bbda274ce280 (patch)
tree879c9fd0dcc3bdae1abcd00f452ade7d879d431b /dev-python/spyder
parentversion bump; internal restructuring, minor bugfixes, documentation updates (diff)
downloadgentoo-2-a6394d983422ecc0350597b612d1bbda274ce280.tar.gz
gentoo-2-a6394d983422ecc0350597b612d1bbda274ce280.tar.bz2
gentoo-2-a6394d983422ecc0350597b612d1bbda274ce280.zip
Version bump, closing #451220
(Portage version: 2.2.0_alpha151/cvs/Linux i686, unsigned Manifest commit)
Diffstat (limited to 'dev-python/spyder')
-rw-r--r--dev-python/spyder/ChangeLog10
-rw-r--r--dev-python/spyder/files/spyder-2.1.13-disable_sphinx_dependency.patch48
-rw-r--r--dev-python/spyder/spyder-2.1.13.ebuild61
3 files changed, 117 insertions, 2 deletions
diff --git a/dev-python/spyder/ChangeLog b/dev-python/spyder/ChangeLog
index ce7767e080bc..2926f9ecc33a 100644
--- a/dev-python/spyder/ChangeLog
+++ b/dev-python/spyder/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/spyder
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/spyder/ChangeLog,v 1.28 2012/08/02 17:50:03 bicatali Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/spyder/ChangeLog,v 1.29 2013/01/14 15:19:48 grozin Exp $
+
+*spyder-2.1.13 (14 Jan 2013)
+
+ 14 Jan 2013; Andrey Grozin <grozin@gentoo.org> +spyder-2.1.13.ebuild,
+ +files/spyder-2.1.13-disable_sphinx_dependency.patch:
+ Version bump, closing #451220
*spyder-2.1.11 (02 Aug 2012)
diff --git a/dev-python/spyder/files/spyder-2.1.13-disable_sphinx_dependency.patch b/dev-python/spyder/files/spyder-2.1.13-disable_sphinx_dependency.patch
new file mode 100644
index 000000000000..71b02ee91256
--- /dev/null
+++ b/dev-python/spyder/files/spyder-2.1.13-disable_sphinx_dependency.patch
@@ -0,0 +1,48 @@
+diff -r -U1 spyder-2.1.13.orig/setup.py spyder-2.1.13/setup.py
+--- spyder-2.1.13.orig/setup.py 2013-01-04 20:05:24.000000000 +0700
++++ spyder-2.1.13/setup.py 2013-01-15 02:10:31.085350157 +0700
+@@ -15,3 +15,2 @@
+ from distutils.command.build import build
+-from sphinx import setup_command
+ import os
+@@ -42,30 +41,2 @@
+
+-# Sphinx build (documentation)
+-class MyBuild(build):
+- def has_doc(self):
+- setup_dir = os.path.dirname(os.path.abspath(__file__))
+- return os.path.isdir(os.path.join(setup_dir, 'doc'))
+- sub_commands = build.sub_commands + [('build_doc', has_doc)]
+-
+-
+-class MyBuildDoc(setup_command.BuildDoc):
+- def run(self):
+- build = self.get_finalized_command('build')
+- sys.path.insert(0, os.path.abspath(build.build_lib))
+- dirname = self.distribution.get_command_obj('build').build_purelib
+- self.builder_target_dir = osp.join(dirname, 'spyderlib', 'doc')
+- try:
+- setup_command.BuildDoc.run(self)
+- except UnicodeDecodeError:
+- print >>sys.stderr, "ERROR: unable to build documentation "\
+- "because Sphinx do not handle source path "\
+- "with non-ASCII characters. Please try to "\
+- "move the source package to another location "\
+- "(path with *only* ASCII characters)."
+- sys.path.pop(0)
+-
+-
+-cmdclass = {'build': MyBuild, 'build_doc': MyBuildDoc}
+-
+-
+ NAME = 'spyder'
+@@ -118,3 +89,3 @@
+ ('.mo', '.svg', '.png'))},
+- requires=["rope (>=0.9.2)", "sphinx (>=0.6.0)", "PyQt4 (>=4.4)"],
++ requires=["rope (>=0.9.2)", "PyQt4 (>=4.4)"],
+ scripts=[osp.join('scripts', fname) for fname in SCRIPTS],
+@@ -137,3 +108,2 @@
+ 'Topic :: Scientific/Engineering',
+- 'Topic :: Software Development :: Widget Sets'],
+- cmdclass=cmdclass)
++ 'Topic :: Software Development :: Widget Sets'])
diff --git a/dev-python/spyder/spyder-2.1.13.ebuild b/dev-python/spyder/spyder-2.1.13.ebuild
new file mode 100644
index 000000000000..71351f66aba9
--- /dev/null
+++ b/dev-python/spyder/spyder-2.1.13.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/spyder/spyder-2.1.13.ebuild,v 1.1 2013/01/14 15:19:48 grozin Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.* *-jython 2.7-pypy-*"
+
+inherit distutils eutils
+
+DESCRIPTION="Python IDE with matlab-like features"
+HOMEPAGE="http://code.google.com/p/spyderlib/ http://pypi.python.org/pypi/spyder"
+SRC_URI="http://spyderlib.googlecode.com/files/${P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc ipython matplotlib numpy pep8 +pyflakes pylint +rope scipy sphinx"
+
+RDEPEND=">=dev-python/PyQt4-4.4[webkit]
+ ipython? ( dev-python/ipython )
+ matplotlib? ( dev-python/matplotlib )
+ numpy? ( dev-python/numpy )
+ pep8? ( dev-python/pep8 )
+ pyflakes? ( >=dev-python/pyflakes-0.3 )
+ pylint? ( dev-python/pylint )
+ rope? ( >=dev-python/rope-0.9.3 )
+ scipy? ( sci-libs/scipy )
+ sphinx? ( dev-python/sphinx )"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ doc? ( dev-python/sphinx )"
+
+PYTHON_MODNAME="spyderlib spyderplugins"
+
+src_prepare() {
+ distutils_src_prepare
+ epatch "${FILESDIR}"/${PN}-2.1.13-disable_sphinx_dependency.patch
+}
+
+src_compile() {
+ distutils_src_compile
+ if use doc; then
+ einfo "Generation of documentation"
+ PYTHONPATH="build-$(PYTHON -f --ABI)" \
+ sphinx-build doc doc_output || die "Generation of documentation failed"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+ doicon spyderlib/images/spyder.svg
+ make_desktop_entry spyder Spyder spyder "Development;IDE"
+ if use doc; then
+ pushd doc_output > /dev/null
+ insinto /usr/share/doc/${PF}/html
+ doins -r [a-z]* _images _static
+ popd > /dev/null
+ fi
+}