summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-13 20:39:30 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-13 20:39:30 +0000
commit75401c8357b5d5d19547b1c7036963cfe590c1fd (patch)
tree05de8f67e1cf1dc3146990292993fa7e04161a8f /dev-python/spyder
parentDelete older ebuilds. (diff)
downloadgentoo-2-75401c8357b5d5d19547b1c7036963cfe590c1fd.tar.gz
gentoo-2-75401c8357b5d5d19547b1c7036963cfe590c1fd.tar.bz2
gentoo-2-75401c8357b5d5d19547b1c7036963cfe590c1fd.zip
Version bump.
(Portage version: 2.2.0_alpha8/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/spyder')
-rw-r--r--dev-python/spyder/ChangeLog10
-rw-r--r--dev-python/spyder/files/spyder-2.0.4-disable_sphinx_dependency.patch54
-rw-r--r--dev-python/spyder/spyder-2.0.4.ebuild57
3 files changed, 120 insertions, 1 deletions
diff --git a/dev-python/spyder/ChangeLog b/dev-python/spyder/ChangeLog
index c1765a77113a..0b3fbd894cac 100644
--- a/dev-python/spyder/ChangeLog
+++ b/dev-python/spyder/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-python/spyder
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/spyder/ChangeLog,v 1.12 2010/12/05 18:13:26 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/spyder/ChangeLog,v 1.13 2010/12/13 20:39:30 arfrever Exp $
+
+*spyder-2.0.4 (13 Dec 2010)
+
+ 13 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -spyder-1.1.8.ebuild, -spyder-2.0.3.ebuild,
+ -files/spyder-2.0.3-disable_sphinx_dependency.patch, +spyder-2.0.4.ebuild,
+ +files/spyder-2.0.4-disable_sphinx_dependency.patch:
+ Version bump.
*spyder-2.0.3 (05 Dec 2010)
diff --git a/dev-python/spyder/files/spyder-2.0.4-disable_sphinx_dependency.patch b/dev-python/spyder/files/spyder-2.0.4-disable_sphinx_dependency.patch
new file mode 100644
index 000000000000..f87b405faa37
--- /dev/null
+++ b/dev-python/spyder/files/spyder-2.0.4-disable_sphinx_dependency.patch
@@ -0,0 +1,54 @@
+--- setup.py
++++ setup.py
+@@ -13,7 +13,6 @@
+
+ from distutils.core import setup
+ from distutils.command.build import build
+-from sphinx import setup_command
+ import os, os.path as osp, sys
+
+
+@@ -36,27 +35,6 @@
+ splist.append(".".join(dirpath.split(os.sep)))
+ return splist
+
+-# Sphinx build (documentation)
+-class MyBuild(build):
+- def has_doc(self):
+- setup_dir = os.path.dirname(os.path.abspath(__file__))
+- return os.path.isdir(os.path.join(setup_dir, 'doc'))
+- sub_commands = build.sub_commands + [('build_doc', has_doc)]
+-
+-class MyBuildDoc(setup_command.BuildDoc):
+- def run(self):
+- build = self.get_finalized_command('build')
+- sys.path.insert(0, os.path.abspath(build.build_lib))
+- dirname = self.distribution.get_command_obj('build').build_purelib
+- self.builder_target_dir = osp.join(dirname, 'spyderlib', 'doc')
+- try:
+- setup_command.BuildDoc.run(self)
+- except UnicodeDecodeError:
+- print >>sys.stderr, "ERROR: unable to build documentation because Sphinx do not handle source path with non-ASCII characters. Please try to move the source package to another location (path with *only* ASCII characters)."
+- sys.path.pop(0)
+-
+-cmdclass = {'build': MyBuild, 'build_doc': MyBuildDoc}
+-
+
+ NAME = 'spyder'
+ LIBNAME = 'spyderlib'
+@@ -83,7 +61,7 @@
+ get_package_data(LIBNAME, ('.qm', '.svg', '.png', '.css')),
+ 'spyderplugins':
+ get_package_data('spyderplugins', ('.qm', '.svg', '.png'))},
+- requires=["pyflakes (>0.3.0)", "rope (>0.9.0)", "sphinx (>0.6.0)",
++ requires=["pyflakes (>0.3.0)", "rope (>0.9.0)",
+ "PyQt4 (>4.3)"],
+ scripts=['spyder', 'spyder.bat'] if os.name == 'nt' else ['spyder'],
+ classifiers=['License :: OSI Approved :: MIT License',
+@@ -97,5 +75,4 @@
+ 'Programming Language :: Python :: 2.7',
+ 'Development Status :: 5 - Production/Stable',
+ 'Topic :: Scientific/Engineering',
+- 'Topic :: Software Development :: Widget Sets'],
+- cmdclass=cmdclass)
++ 'Topic :: Software Development :: Widget Sets'])
diff --git a/dev-python/spyder/spyder-2.0.4.ebuild b/dev-python/spyder/spyder-2.0.4.ebuild
new file mode 100644
index 000000000000..c15f7da72c27
--- /dev/null
+++ b/dev-python/spyder/spyder-2.0.4.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/spyder/spyder-2.0.4.ebuild,v 1.1 2010/12/13 20:39:30 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.* *-jython"
+
+inherit distutils eutils
+
+DESCRIPTION="Python IDE with matlab-like features"
+HOMEPAGE="http://code.google.com/p/spyderlib/ http://pypi.python.org/pypi/spyder"
+SRC_URI="http://spyderlib.googlecode.com/files/${P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc ipython matplotlib numpy +pyflakes pylint +rope scipy"
+
+RDEPEND=">=dev-python/PyQt4-4.4[webkit]
+ ipython? ( dev-python/ipython )
+ matplotlib? ( dev-python/matplotlib )
+ numpy? ( dev-python/numpy )
+ pyflakes? ( >=dev-python/pyflakes-0.3 )
+ pylint? ( dev-python/pylint )
+ rope? ( >=dev-python/rope-0.9.0 )
+ scipy? ( sci-libs/scipy )"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx )"
+
+PYTHON_MODNAME="spyderlib spyderplugins"
+
+src_prepare() {
+ distutils_src_prepare
+ epatch "${FILESDIR}/${P}-disable_sphinx_dependency.patch"
+}
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ einfo "Generation of documentation"
+ PYTHONPATH="build-$(PYTHON -f --ABI)" sphinx-build doc doc_output || die "Generation of documentation failed"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ pushd doc_output > /dev/null
+ insinto /usr/share/doc/${PF}/html
+ doins -r [a-z]* _images _static || die "Installation of documentation failed"
+ popd > /dev/null
+ fi
+}