summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-05-13 13:02:57 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-05-13 13:02:57 +0000
commit199107792f2224b36aa28e5348d040ff8ed7ec2b (patch)
tree9b0a12043fa126726c4d4e5dadab262abc9be203 /dev-python/sphinx
parentDelete older ebuild. (diff)
downloadgentoo-2-199107792f2224b36aa28e5348d040ff8ed7ec2b.tar.gz
gentoo-2-199107792f2224b36aa28e5348d040ff8ed7ec2b.tar.bz2
gentoo-2-199107792f2224b36aa28e5348d040ff8ed7ec2b.zip
Delete older ebuilds.
Diffstat (limited to 'dev-python/sphinx')
-rw-r--r--dev-python/sphinx/Manifest4
-rw-r--r--dev-python/sphinx/sphinx-0.6.3.ebuild76
-rw-r--r--dev-python/sphinx/sphinx-0.6.4.ebuild76
3 files changed, 0 insertions, 156 deletions
diff --git a/dev-python/sphinx/Manifest b/dev-python/sphinx/Manifest
index c052ae9c516b..53d188ddfd6e 100644
--- a/dev-python/sphinx/Manifest
+++ b/dev-python/sphinx/Manifest
@@ -1,8 +1,4 @@
-DIST Sphinx-0.6.3.tar.gz 965109 RMD160 5662954aa3f9da6f2da273fb0098697e8ab13184 SHA1 5f3d56f9a50f19d747d04592500956d8ef5a681f SHA256 7da3fb1fec3fc61073e1432a5c2698a02bf8a8370963725816afc429d7d468ba
-DIST Sphinx-0.6.4.tar.gz 970249 RMD160 8b6f06a6e13b0af8104a232f34aeabc866c1123f SHA1 8a1a9720c24e05615257525e07744ea715a372b2 SHA256 bf756f543ecfed0f46a79cc83c2536417bbec226e1598d3157a6ac143f3ce2ca
DIST Sphinx-0.6.5.tar.gz 972168 RMD160 6a06bbaccbd86a55443be7350642a03ae3ae748d SHA1 f91ba2ec0165492c5992cba610fb898ab16ca8c4 SHA256 500d749251ff4d311a81714e2f8f184168e10262a3a0d55f04f22f89164329b7
-EBUILD sphinx-0.6.3.ebuild 2158 RMD160 fdd2a05ae451dd8d40fa0312852cfada0870d806 SHA1 11f47c168f87fefaa90db45cc37b0fb729b3c9f2 SHA256 272b41ac1dd4c0b7f9a1905a6550d5471ab0ceabe7029e43431e4e8ce939be93
-EBUILD sphinx-0.6.4.ebuild 2216 RMD160 ac0a4b9a01ad6379f850fdda9f76b25eb4f74cc6 SHA1 d99052dba4b08a5068f4432d8f942cd6b611ce64 SHA256 cf122248a3ac13fa6cc1d9d38b61aae23e08caabf497620cb9cc13681b802b2c
EBUILD sphinx-0.6.5.ebuild 2239 RMD160 06816590284f2a732451c34997e121f4b064ae79 SHA1 9e629eae94833ba3bf5d85ae73683e06f8c8a268 SHA256 d108b55272b0257ebc90d7ca8f3624f462bab13dbbd89b0b705cfca674ed377d
MISC ChangeLog 6364 RMD160 76141da3d26c942dc6665f3d0e6cb8f6b5b0df36 SHA1 85b6277007b84a38e62f5020aeb850cc2fbdb796 SHA256 544e3e3fa52e87d36e61a4331a70da131cef55d3a0d97c50c57799f1824fe706
MISC metadata.xml 351 RMD160 a039846d5551a68ce6babb384726d5f2aed7ed48 SHA1 4827404c8a432524f89c5c6882c8f723d9ceee23 SHA256 c3304c774eac6a8ed5a1dbfd42c2e52540cfd76aa441ac4be4b94240410bd4dd
diff --git a/dev-python/sphinx/sphinx-0.6.3.ebuild b/dev-python/sphinx/sphinx-0.6.3.ebuild
deleted file mode 100644
index 0c8209dcb771..000000000000
--- a/dev-python/sphinx/sphinx-0.6.3.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sphinx/sphinx-0.6.3.ebuild,v 1.13 2010/02/28 10:51:15 arfrever Exp $
-
-EAPI="2"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit distutils
-
-MY_PN="Sphinx"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Tool to create documentation for Python projects"
-HOMEPAGE="http://sphinx.pocoo.org/ http://pypi.python.org/pypi/Sphinx"
-SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos"
-IUSE="doc test"
-
-RDEPEND=">=dev-python/pygments-0.8
- >=dev-python/jinja2-2.1
- >=dev-python/docutils-0.4"
-
-DEPEND="${RDEPEND}
- dev-python/setuptools
- test? ( dev-python/nose )"
-RESTRICT_PYTHON_ABIS="3.*"
-
-S="${WORKDIR}/${MY_P}"
-
-DOCS="CHANGES"
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- cd doc
- PYTHONPATH="../" emake SPHINXBUILD="$(PYTHON -f) ../sphinx-build.py" html || die "Generation of documentation failed"
- fi
-}
-
-src_test() {
- testing() {
- PYTHONPATH="build-${PYTHON_ABI}/lib" nosetests
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- dohtml -A txt -r doc/_build/html/* || die "dohtml failed"
- fi
-}
-
-pkg_postinst() {
- distutils_pkg_postinst
-
- # Generating the Grammar pickle to avoid on the fly generation causing sandbox violations (bug #266015)
- generation_of_grammar_pickle() {
- "$(PYTHON)" -c "from sphinx.pycode.pgen2.driver import load_grammar; load_grammar('${ROOT%/}${EPREFIX}$(python_get_sitedir)/sphinx/pycode/Grammar.txt')" \
- || die "Generation of grammar pickle failed"
- }
- python_execute_function --action-message 'Generation of Grammar pickle with Python ${PYTHON_ABI}...' generation_of_grammar_pickle
-}
-
-pkg_postrm() {
- distutils_pkg_postrm
-
- deletion_of_grammar_pickle() {
- rm "${ROOT%/}${EPREFIX}$(python_get_sitedir)/sphinx/pycode"/Grammar*.pickle
- }
- python_execute_function --action-message 'Deletion of Grammar pickle with Python ${PYTHON_ABI}...' deletion_of_grammar_pickle
-}
diff --git a/dev-python/sphinx/sphinx-0.6.4.ebuild b/dev-python/sphinx/sphinx-0.6.4.ebuild
deleted file mode 100644
index e11c5d946a20..000000000000
--- a/dev-python/sphinx/sphinx-0.6.4.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sphinx/sphinx-0.6.4.ebuild,v 1.7 2010/03/16 10:42:11 djc Exp $
-
-EAPI="2"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit distutils
-
-MY_PN="Sphinx"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Tool to create documentation for Python projects"
-HOMEPAGE="http://sphinx.pocoo.org/ http://pypi.python.org/pypi/Sphinx"
-SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~ppc ~ppc64 s390 sh sparc x86 ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos"
-IUSE="doc test latex"
-
-RDEPEND=">=dev-python/pygments-0.8
- >=dev-python/jinja2-2.1
- >=dev-python/docutils-0.4
- latex? ( dev-texlive/texlive-latexextra )"
-DEPEND="${RDEPEND}
- dev-python/setuptools
- test? ( dev-python/nose )"
-RESTRICT_PYTHON_ABIS="3.*"
-
-S="${WORKDIR}/${MY_P}"
-
-DOCS="CHANGES"
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- cd doc
- PYTHONPATH="../" emake SPHINXBUILD="$(PYTHON -f) ../sphinx-build.py" html || die "Generation of documentation failed"
- fi
-}
-
-src_test() {
- testing() {
- PYTHONPATH="build-${PYTHON_ABI}/lib" nosetests-${PYTHON_ABI}
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- dohtml -A txt -r doc/_build/html/* || die "dohtml failed"
- fi
-}
-
-pkg_postinst() {
- distutils_pkg_postinst
-
- # Generating the Grammar pickle to avoid on the fly generation causing sandbox violations (bug #266015)
- generation_of_grammar_pickle() {
- "$(PYTHON)" -c "from sphinx.pycode.pgen2.driver import load_grammar; load_grammar('${ROOT%/}${EPREFIX}$(python_get_sitedir)/sphinx/pycode/Grammar.txt')" \
- || die "Generation of grammar pickle failed"
- }
- python_execute_function --action-message 'Generation of Grammar pickle with Python ${PYTHON_ABI}...' generation_of_grammar_pickle
-}
-
-pkg_postrm() {
- distutils_pkg_postrm
-
- deletion_of_grammar_pickle() {
- rm "${ROOT%/}${EPREFIX}$(python_get_sitedir)/sphinx/pycode"/Grammar*.pickle
- }
- python_execute_function --action-message 'Deletion of Grammar pickle with Python ${PYTHON_ABI}...' deletion_of_grammar_pickle
-}