summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJesus Rivero <neurogeek@gentoo.org>2008-08-01 06:51:29 +0000
committerJesus Rivero <neurogeek@gentoo.org>2008-08-01 06:51:29 +0000
commitb0f0c83a7f5f9cb6a569c8bb2ea198ae887fbf1a (patch)
treeb91c31aa9013244188bde90082bebc7937e2f861 /dev-python/sphinx/sphinx-0.3.ebuild
parentRemoved vulnerable horde-kronolith-2.1.7 wrt sec issue #219304. (diff)
downloadgentoo-2-b0f0c83a7f5f9cb6a569c8bb2ea198ae887fbf1a.tar.gz
gentoo-2-b0f0c83a7f5f9cb6a569c8bb2ea198ae887fbf1a.tar.bz2
gentoo-2-b0f0c83a7f5f9cb6a569c8bb2ea198ae887fbf1a.zip
Version bump. Added tests and DEPEND on nose. Fixes bugs #230599 and #231365. Removed older version
(Portage version: 2.2_rc3/cvs/Linux 2.6.18-gentoo-r3 i686)
Diffstat (limited to 'dev-python/sphinx/sphinx-0.3.ebuild')
-rw-r--r--dev-python/sphinx/sphinx-0.3.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/dev-python/sphinx/sphinx-0.3.ebuild b/dev-python/sphinx/sphinx-0.3.ebuild
deleted file mode 100644
index 627f2bb77af0..000000000000
--- a/dev-python/sphinx/sphinx-0.3.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sphinx/sphinx-0.3.ebuild,v 1.4 2008/06/29 09:42:36 armin76 Exp $
-
-inherit distutils
-
-MY_PN="Sphinx"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="A tool that makes it easy to create intelligent and beautiful documentation for Python projects."
-HOMEPAGE="http://sphinx.pocoo.org/"
-SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
-IUSE="doc"
-
-DEPEND=">=dev-python/pygments-0.8
- >=dev-python/jinja-1.1
- >=dev-python/docutils-0.4
- dev-python/setuptools"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-src_compile() {
- DOCS="CHANGES"
- distutils_src_compile
-
- if use doc ; then
- cd doc
- PYTHONPATH="../" emake SPHINXBUILD="${python} ../sphinx-build.py" html || die "making docs failed"
- fi
-}
-
-src_install() {
- distutils_src_install
- if use doc ; then
- dohtml -A txt -r doc/_build/html/*
- fi
-}