summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-06-09 06:18:38 +0000
committerIan Delaney <idella4@gentoo.org>2013-06-09 06:18:38 +0000
commit0474cd5d72eb6211b4c2dbef07b514c57e51bc55 (patch)
tree669ee6dbbbc8d35d6b4e6ee5bc66041b997be812 /dev-python/speaklater
parentVersion bump. (diff)
downloadgentoo-2-0474cd5d72eb6211b4c2dbef07b514c57e51bc55.tar.gz
gentoo-2-0474cd5d72eb6211b4c2dbef07b514c57e51bc55.tar.bz2
gentoo-2-0474cd5d72eb6211b4c2dbef07b514c57e51bc55.zip
revbump, migrate -> distutils-r1
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/speaklater')
-rw-r--r--dev-python/speaklater/ChangeLog9
-rw-r--r--dev-python/speaklater/speaklater-1.3-r1.ebuild25
2 files changed, 32 insertions, 2 deletions
diff --git a/dev-python/speaklater/ChangeLog b/dev-python/speaklater/ChangeLog
index 0076719e2700..2e108704e252 100644
--- a/dev-python/speaklater/ChangeLog
+++ b/dev-python/speaklater/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/speaklater
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/speaklater/ChangeLog,v 1.2 2012/07/30 07:05:49 patrick Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/speaklater/ChangeLog,v 1.3 2013/06/09 06:18:38 idella4 Exp $
+
+*speaklater-1.3-r1 (09 Jun 2013)
+
+ 09 Jun 2013; Ian Delaney <idella4@gentoo.org> +speaklater-1.3-r1.ebuild:
+ revbump, migrate -> distutils-r1
*speaklater-1.3 (30 Jul 2012)
diff --git a/dev-python/speaklater/speaklater-1.3-r1.ebuild b/dev-python/speaklater/speaklater-1.3-r1.ebuild
new file mode 100644
index 000000000000..986e1ec34a63
--- /dev/null
+++ b/dev-python/speaklater/speaklater-1.3-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/speaklater/speaklater-1.3-r1.ebuild,v 1.1 2013/06/09 06:18:38 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_5,2_6,2_7} pypy2_0 )
+inherit distutils-r1
+
+DESCRIPTION="Lazy strings for Python"
+HOMEPAGE="https://github.com/mitsuhiko/speaklater"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_test() {
+ "${PYTHON}" speaklater.py || die "Tests failed under ${EPYTHON}"
+}