summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Østergaard <kloeri@gentoo.org>2007-01-07 19:59:29 +0000
committerBryan Østergaard <kloeri@gentoo.org>2007-01-07 19:59:29 +0000
commit558db1c4e9e6b27eb11a182f801ca0c2e9f27002 (patch)
tree25b09d0333e09e712d062718e427e32d3e8d134c /dev-python/soappy/files
parentMarking sparc stable (diff)
downloadgentoo-2-558db1c4e9e6b27eb11a182f801ca0c2e9f27002.tar.gz
gentoo-2-558db1c4e9e6b27eb11a182f801ca0c2e9f27002.tar.bz2
gentoo-2-558db1c4e9e6b27eb11a182f801ca0c2e9f27002.zip
Dog ate my paper..
(Portage version: 2.1.2_rc4-r6)
Diffstat (limited to 'dev-python/soappy/files')
-rw-r--r--dev-python/soappy/files/soappy-0.12.0.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/soappy/files/soappy-0.12.0.ebuild b/dev-python/soappy/files/soappy-0.12.0.ebuild
new file mode 100644
index 000000000000..348bad782c55
--- /dev/null
+++ b/dev-python/soappy/files/soappy-0.12.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/soappy/soappy-0.12.0.ebuild,v 1.1 2007/01/06 23:16:01 dev-zero Exp $
+
+inherit distutils
+
+MY_PN="SOAPpy"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="SOAP implementation for Python"
+HOMEPAGE="http://pywebsvcs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pywebsvcs/${MY_P}.tar.gz"
+
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc-macos ~sparc ~x86 ~x86-fbsd"
+SLOT="0"
+LICENSE="BSD"
+IUSE="examples ssl"
+
+DEPEND=">=dev-python/fpconst-0.7.1
+ dev-python/pyxml"
+RDEPEND="${DEPEND}
+ ssl? ( dev-python/m2crypto )"
+
+S=${WORKDIR}/${MY_P}
+PYTHON_MODNAME=${MY_PN}
+DOCS="RELEASE_INFO"
+
+pkg_setup() {
+ if use ssl && ! built_with_use dev-lang/python ssl ; then
+ ewarn "The 'ssl' USE-flag is enabled, but dev-lang/python is"
+ ewarn "not compiled with it. You'll only get server-side SSL support."
+ ewarn "Just emerge dev-lang/python afterwards with the ssl USE-flag to"
+ ewarn "get client-side encryption."
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-python-2.5-compat.patch"
+}
+
+
+src_install() {
+ distutils_src_install
+ dodoc docs/*
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r contrib bid tools validate
+ fi
+}