summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2008-11-14 23:24:20 +0000
committerPatrick Lauer <patrick@gentoo.org>2008-11-14 23:24:20 +0000
commit5fd4d96b1a8a0aabd213ff28b590d0a0155ebb43 (patch)
treebba595f2afd88cb9df5993e19bd2682cbffb6925 /dev-python/snakeoil
parentBug #222279 - add undocumented support for selection of default charset and c... (diff)
downloadgentoo-2-5fd4d96b1a8a0aabd213ff28b590d0a0155ebb43.tar.gz
gentoo-2-5fd4d96b1a8a0aabd213ff28b590d0a0155ebb43.tar.bz2
gentoo-2-5fd4d96b1a8a0aabd213ff28b590d0a0155ebb43.zip
Bump to 0.3.1
(Portage version: 2.2_rc14/cvs/Linux 2.6.26.5 x86_64)
Diffstat (limited to 'dev-python/snakeoil')
-rw-r--r--dev-python/snakeoil/ChangeLog7
-rw-r--r--dev-python/snakeoil/snakeoil-0.3.1.ebuild52
2 files changed, 58 insertions, 1 deletions
diff --git a/dev-python/snakeoil/ChangeLog b/dev-python/snakeoil/ChangeLog
index be2fa3269edb..da857310a868 100644
--- a/dev-python/snakeoil/ChangeLog
+++ b/dev-python/snakeoil/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/snakeoil
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/snakeoil/ChangeLog,v 1.12 2008/09/03 20:51:27 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/snakeoil/ChangeLog,v 1.13 2008/11/14 23:24:20 patrick Exp $
+
+*snakeoil-0.3.1 (15 Nov 2008)
+
+ 15 Nov 2008; Patrick Lauer <patrick@gentoo.org> +snakeoil-0.3.1.ebuild:
+ Bump to 0.3.1
*snakeoil-0.3 (03 Sep 2008)
diff --git a/dev-python/snakeoil/snakeoil-0.3.1.ebuild b/dev-python/snakeoil/snakeoil-0.3.1.ebuild
new file mode 100644
index 000000000000..6e26a280347a
--- /dev/null
+++ b/dev-python/snakeoil/snakeoil-0.3.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/snakeoil/snakeoil-0.3.1.ebuild,v 1.1 2008/11/14 23:24:20 patrick Exp $
+
+NEED_PYTHON=2.4
+
+inherit distutils
+
+DESCRIPTION="Miscellaneous python utility code."
+HOMEPAGE="http://www.pkgcore.org/"
+SRC_URI="http://www.pkgcore.org/releases/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DOCS="AUTHORS NEWS"
+DEPEND="!<sys-apps/pkgcore-0.4.7.8"
+RDEPEND=${DEPEND}
+
+# Uses an ugly hack to install for all versions of python on the
+# system. This should be supported through the eclass at some point.
+# pkgcore needs it now to support upgrading to a different python slot.
+
+src_compile() {
+ local opython=${python}
+ for python in /usr/bin/python2.[4-9]; do
+ distutils_src_compile
+ done
+ python=${opython}
+}
+
+src_test() {
+ local opython=${python} tempdir
+ for python in /usr/bin/python2.[4-9]; do
+ tempdir="${T}/tests/$(basename ${python})"
+ mkdir -p "${tempdir}" || die "tempdir creation failed"
+ cp -r "${S}" "${tempdir}" || die "test copy failed"
+ cd "${tempdir}/${P}"
+ "${python}" setup.py test || die "testing returned non zero"
+ done
+ python=${opython}
+ rm -rf "${T}/tests"
+}
+
+src_install() {
+ local opython=${python}
+ for python in /usr/bin/python2.[4-9]; do
+ distutils_src_install
+ done
+}