summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-05-24 18:40:34 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-05-24 18:40:34 +0000
commit52522a403ec68f9f46084b77ce340277d0ee0d94 (patch)
tree2e8adfff323773afe6193f3b2c21be597100b875 /dev-python/snakeoil
parentCall python_pkg_setup() instead of validate_PYTHON_ABIS(). (diff)
downloadgentoo-2-52522a403ec68f9f46084b77ce340277d0ee0d94.tar.gz
gentoo-2-52522a403ec68f9f46084b77ce340277d0ee0d94.tar.bz2
gentoo-2-52522a403ec68f9f46084b77ce340277d0ee0d94.zip
Delete older ebuild.
Diffstat (limited to 'dev-python/snakeoil')
-rw-r--r--dev-python/snakeoil/snakeoil-0.3.6.3.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/dev-python/snakeoil/snakeoil-0.3.6.3.ebuild b/dev-python/snakeoil/snakeoil-0.3.6.3.ebuild
deleted file mode 100644
index 9d3f5b9f7948..000000000000
--- a/dev-python/snakeoil/snakeoil-0.3.6.3.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/snakeoil/snakeoil-0.3.6.3.ebuild,v 1.1 2010/03/15 00:05:23 robbat2 Exp $
-
-EAPI="2"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit distutils
-
-DESCRIPTION="Miscellaneous python utility code."
-HOMEPAGE="http://www.pkgcore.org/"
-SRC_URI="http://www.pkgcore.org/releases/${PN}/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE=""
-
-DEPEND="!<sys-apps/pkgcore-0.4.7.8"
-RDEPEND=${DEPEND}
-
-DOCS="AUTHORS NEWS"
-
-pkg_setup() {
- validate_PYTHON_ABIS
-
- # A hack to install for all versions of Python in the system.
- # pkgcore needs it to support upgrading to a different Python slot.
- PYTHON_ABIS=""
- local python_interpreter
- for python_interpreter in /usr/bin/python{2.[4-9],3.[1-9]}; do
- if [[ -x "${python_interpreter}" ]]; then
- PYTHON_ABIS+=" ${python_interpreter#/usr/bin/python}"
- fi
- done
- export PYTHON_ABIS="${PYTHON_ABIS# }"
-}
-
-src_test() {
- testing() {
- local tempdir
- tempdir="${T}/tests/python-${PYTHON_ABI}"
- mkdir -p "${tempdir}" || die "tempdir creation failed"
- cp -r "${S}" "${tempdir}" || die "test copy failed"
- cd "${tempdir}/${P}"
- PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib*)" "$(PYTHON)" setup.py build -b "build-${PYTHON_ABI}" test
- }
- python_execute_function testing
-}