summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Cakebread <pythonhead@gentoo.org>2008-09-06 23:43:35 +0000
committerRob Cakebread <pythonhead@gentoo.org>2008-09-06 23:43:35 +0000
commitf77a020251b294bc52df28d138f6b6dbb9d09579 (patch)
tree37df33e55fa432e7485ac006d30b66129ffc30fc /dev-python/sip
parentVersion bump - fixes Ctrl+Up/Down/PgUp/PgDn shortcuts when NumLock is on. Rem... (diff)
downloadgentoo-2-f77a020251b294bc52df28d138f6b6dbb9d09579.tar.gz
gentoo-2-f77a020251b294bc52df28d138f6b6dbb9d09579.tar.bz2
gentoo-2-f77a020251b294bc52df28d138f6b6dbb9d09579.zip
Fix python_mod_compile, misc. unquoted variables. bug #236894
(Portage version: 2.2_rc8/cvs/Linux 2.6.26-gentoo-r1 i686)
Diffstat (limited to 'dev-python/sip')
-rw-r--r--dev-python/sip/sip-4.2.1-r1.ebuild8
-rw-r--r--dev-python/sip/sip-4.2.1.ebuild6
-rw-r--r--dev-python/sip/sip-4.6.ebuild4
-rw-r--r--dev-python/sip/sip-4.7.1.ebuild4
-rw-r--r--dev-python/sip/sip-4.7.3.ebuild4
-rw-r--r--dev-python/sip/sip-4.7.5.ebuild4
-rw-r--r--dev-python/sip/sip-4.7.6.ebuild4
-rw-r--r--dev-python/sip/sip-4.7.7.ebuild4
8 files changed, 19 insertions, 19 deletions
diff --git a/dev-python/sip/sip-4.2.1-r1.ebuild b/dev-python/sip/sip-4.2.1-r1.ebuild
index 2a7d2f662cb4..cd976396ef8b 100644
--- a/dev-python/sip/sip-4.2.1-r1.ebuild
+++ b/dev-python/sip/sip-4.2.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.2.1-r1.ebuild,v 1.5 2008/08/11 19:08:06 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.2.1-r1.ebuild,v 1.6 2008/09/06 23:43:35 pythonhead Exp $
inherit distutils
@@ -26,7 +26,7 @@ RDEPEND="${DEPEND}"
src_unpack(){
unpack ${A}
- cd ${S}
+ cd "${S}"
epatch "${FILESDIR}/sip-4.2.1-python-2.5-compat.diff"
}
src_compile(){
@@ -40,8 +40,8 @@ src_compile(){
}
src_install() {
- make DESTDIR=${D} install || die "install failed"
- dodoc ChangeLog LICENSE NEWS README THANKS TODO
+ make DESTDIR="${D}" install || die "install failed"
+ dodoc ChangeLog NEWS README THANKS TODO
if use doc ; then dohtml doc/* ; fi
}
diff --git a/dev-python/sip/sip-4.2.1.ebuild b/dev-python/sip/sip-4.2.1.ebuild
index 8125deba77b8..78fe1c2b416c 100644
--- a/dev-python/sip/sip-4.2.1.ebuild
+++ b/dev-python/sip/sip-4.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.2.1.ebuild,v 1.13 2008/08/11 19:08:06 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.2.1.ebuild,v 1.14 2008/09/06 23:43:35 pythonhead Exp $
inherit distutils
@@ -34,8 +34,8 @@ src_compile(){
}
src_install() {
- make DESTDIR=${D} install || die "install failed"
- dodoc ChangeLog LICENSE NEWS README THANKS TODO
+ make DESTDIR="${D}" install || die "install failed"
+ dodoc ChangeLog NEWS README THANKS TODO
if use doc ; then dohtml doc/* ; fi
}
diff --git a/dev-python/sip/sip-4.6.ebuild b/dev-python/sip/sip-4.6.ebuild
index 9840f3a466ce..682cc3da362e 100644
--- a/dev-python/sip/sip-4.6.ebuild
+++ b/dev-python/sip/sip-4.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.6.ebuild,v 1.6 2008/05/29 16:37:12 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.6.ebuild,v 1.7 2008/09/06 23:43:35 pythonhead Exp $
NEED_PYTHON=2.3
@@ -50,7 +50,7 @@ src_install() {
pkg_postinst() {
python_version
- python_mod_compile /usr/$(get_libdir)/python${pyver}/sip*.py
+ python_mod_compile "$(python_get_sitedir)"/sip*.py
}
pkg_postrm() {
diff --git a/dev-python/sip/sip-4.7.1.ebuild b/dev-python/sip/sip-4.7.1.ebuild
index 1b3680264ead..12389879e111 100644
--- a/dev-python/sip/sip-4.7.1.ebuild
+++ b/dev-python/sip/sip-4.7.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.7.1.ebuild,v 1.9 2008/05/29 16:37:12 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.7.1.ebuild,v 1.10 2008/09/06 23:43:35 pythonhead Exp $
NEED_PYTHON=2.3
@@ -50,7 +50,7 @@ src_install() {
pkg_postinst() {
python_version
- python_mod_compile /usr/$(get_libdir)/python${PYVER}/sip*.py
+ python_mod_compile "$(python_get_sitedir)"/sip*.py
}
pkg_postrm() {
diff --git a/dev-python/sip/sip-4.7.3.ebuild b/dev-python/sip/sip-4.7.3.ebuild
index 0dfdeaee1c9b..4d444569c6d1 100644
--- a/dev-python/sip/sip-4.7.3.ebuild
+++ b/dev-python/sip/sip-4.7.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.7.3.ebuild,v 1.10 2008/05/29 16:37:12 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.7.3.ebuild,v 1.11 2008/09/06 23:43:35 pythonhead Exp $
NEED_PYTHON=2.3
@@ -50,7 +50,7 @@ src_install() {
pkg_postinst() {
python_version
- python_mod_compile /usr/$(get_libdir)/python${PYVER}/sip*.py
+ python_mod_compile "$(python_get_sitedir)"/sip*.py
}
pkg_postrm() {
diff --git a/dev-python/sip/sip-4.7.5.ebuild b/dev-python/sip/sip-4.7.5.ebuild
index 31bb6582b009..838941d3c428 100644
--- a/dev-python/sip/sip-4.7.5.ebuild
+++ b/dev-python/sip/sip-4.7.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.7.5.ebuild,v 1.2 2008/05/29 16:37:12 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.7.5.ebuild,v 1.3 2008/09/06 23:43:35 pythonhead Exp $
NEED_PYTHON=2.3
@@ -50,7 +50,7 @@ src_install() {
pkg_postinst() {
python_version
- python_mod_compile /usr/$(get_libdir)/python${PYVER}/sip*.py
+ python_mod_compile "$(python_get_sitedir)"/sip*.py
}
pkg_postrm() {
diff --git a/dev-python/sip/sip-4.7.6.ebuild b/dev-python/sip/sip-4.7.6.ebuild
index 638dffcaecaa..23668e4bb52d 100644
--- a/dev-python/sip/sip-4.7.6.ebuild
+++ b/dev-python/sip/sip-4.7.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.7.6.ebuild,v 1.3 2008/07/19 13:01:36 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.7.6.ebuild,v 1.4 2008/09/06 23:43:35 pythonhead Exp $
NEED_PYTHON=2.3
@@ -50,7 +50,7 @@ src_install() {
pkg_postinst() {
python_version
- python_mod_compile /usr/$(get_libdir)/python${pyver}/sip*.py
+ python_mod_compile "$(python_get_sitedir)"/sip*.py
}
pkg_postrm() {
diff --git a/dev-python/sip/sip-4.7.7.ebuild b/dev-python/sip/sip-4.7.7.ebuild
index fe088914ea45..bf32843b6462 100644
--- a/dev-python/sip/sip-4.7.7.ebuild
+++ b/dev-python/sip/sip-4.7.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.7.7.ebuild,v 1.1 2008/09/06 14:16:53 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.7.7.ebuild,v 1.2 2008/09/06 23:43:35 pythonhead Exp $
NEED_PYTHON=2.3
@@ -50,7 +50,7 @@ src_install() {
pkg_postinst() {
python_version
- python_mod_compile /usr/$(get_libdir)/python${pyver}/sip*.py
+ python_mod_compile "$(python_get_sitedir)"/sip*.py
}
pkg_postrm() {