summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-24 22:04:06 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-24 22:04:06 +0000
commitc762524b83cd23f000a6e0c74be26c159d8cbedf (patch)
treea4f8e478760c570152f80ffaded8c1417b92d615 /dev-python/sip
parentDrop empty DEPEND, unused eutils inherit, and convert to emake. (diff)
downloadgentoo-2-c762524b83cd23f000a6e0c74be26c159d8cbedf.tar.gz
gentoo-2-c762524b83cd23f000a6e0c74be26c159d8cbedf.tar.bz2
gentoo-2-c762524b83cd23f000a6e0c74be26c159d8cbedf.zip
Version bump.
(Portage version: 2.2.0_alpha19_p1/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/sip')
-rw-r--r--dev-python/sip/ChangeLog8
-rw-r--r--dev-python/sip/sip-4.12.1.ebuild77
2 files changed, 84 insertions, 1 deletions
diff --git a/dev-python/sip/ChangeLog b/dev-python/sip/ChangeLog
index 8b971f9d473e..6a6a4e9c757e 100644
--- a/dev-python/sip/ChangeLog
+++ b/dev-python/sip/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/sip
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/ChangeLog,v 1.184 2011/01/21 15:18:25 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/ChangeLog,v 1.185 2011/01/24 22:04:06 arfrever Exp $
+
+*sip-4.12.1 (24 Jan 2011)
+
+ 24 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +sip-4.12.1.ebuild:
+ Version bump.
21 Jan 2011; Jeroen Roovers <jer@gentoo.org> sip-4.11.2.ebuild:
Stable for HPPA (bug #349607).
diff --git a/dev-python/sip/sip-4.12.1.ebuild b/dev-python/sip/sip-4.12.1.ebuild
new file mode 100644
index 000000000000..94432dbc8bfb
--- /dev/null
+++ b/dev-python/sip/sip-4.12.1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.12.1.ebuild,v 1.1 2011/01/24 22:04:06 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="*"
+PYTHON_EXPORT_PHASE_FUNCTIONS="1"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="*-jython"
+
+inherit eutils python toolchain-funcs
+
+MY_P="${P/_pre/-snapshot-}"
+
+DESCRIPTION="Python extension module generator for C and C++ libraries"
+HOMEPAGE="http://www.riverbankcomputing.co.uk/software/sip/intro http://pypi.python.org/pypi/SIP"
+SRC_URI="http://www.riverbankcomputing.com/static/Downloads/${PN}${PV%%.*}/${MY_P}.tar.gz"
+
+LICENSE="|| ( GPL-2 GPL-3 sip )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="debug doc"
+
+S="${WORKDIR}/${MY_P}"
+
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-4.9.3-darwin.patch"
+ python_copy_sources
+}
+
+src_configure() {
+ configuration() {
+ local myconf=("$(PYTHON)"
+ configure.py
+ --bindir="${EPREFIX}/usr/bin"
+ --incdir="${EPREFIX}$(python_get_includedir)"
+ --destdir="${EPREFIX}$(python_get_sitedir)"
+ --sipdir="${EPREFIX}/usr/share/sip"
+ $(use debug && echo --debug)
+ CC="$(tc-getCC)"
+ CXX="$(tc-getCXX)"
+ LINK="$(tc-getCXX)"
+ LINK_SHLIB="$(tc-getCXX)"
+ CFLAGS="${CFLAGS}"
+ CXXFLAGS="${CXXFLAGS}"
+ LFLAGS="${LDFLAGS}"
+ STRIP=":")
+ echo "${myconf[@]}"
+ "${myconf[@]}"
+ }
+ python_execute_function -s configuration
+}
+
+src_install() {
+ python_src_install
+
+ dodoc NEWS || die "dodoc failed"
+
+ if use doc; then
+ dohtml -r doc/html/* || die "dohtml failed"
+ fi
+}
+
+pkg_postinst() {
+ python_mod_optimize sipconfig.py sipdistutils.py
+
+ ewarn "When updating dev-python/sip, you usually need to rebuild packages, which depend on dev-python/sip,"
+ ewarn "such as dev-python/PyQt4 and dev-python/qscintilla-python. If you have app-portage/gentoolkit"
+ ewarn "installed, you can find these packages with \`equery d dev-python/sip dev-python/PyQt4\`."
+}
+
+pkg_postrm() {
+ python_mod_cleanup sipconfig.py sipdistutils.py
+}