summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-11-11 19:33:35 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-11-11 19:33:35 +0000
commitc749e7fe4bf6ffc5960ee0aa04bf77d37945b903 (patch)
tree96fc88ae896e5ee24ee8e16fb3524de20afee600 /dev-python/sip
parentVersion bump. Drop older. (diff)
downloadgentoo-2-c749e7fe4bf6ffc5960ee0aa04bf77d37945b903.tar.gz
gentoo-2-c749e7fe4bf6ffc5960ee0aa04bf77d37945b903.tar.bz2
gentoo-2-c749e7fe4bf6ffc5960ee0aa04bf77d37945b903.zip
Version bump
(Portage version: 2.2.0_alpha71/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/sip')
-rw-r--r--dev-python/sip/ChangeLog7
-rw-r--r--dev-python/sip/sip-4.13.ebuild77
2 files changed, 83 insertions, 1 deletions
diff --git a/dev-python/sip/ChangeLog b/dev-python/sip/ChangeLog
index 7fe379ab5d9c..dbf5d5df681d 100644
--- a/dev-python/sip/ChangeLog
+++ b/dev-python/sip/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/sip
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/ChangeLog,v 1.202 2011/11/03 18:42:52 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/ChangeLog,v 1.203 2011/11/11 19:33:35 hwoarang Exp $
+
+*sip-4.13 (11 Nov 2011)
+
+ 11 Nov 2011; Markos Chandras <hwoarang@gentoo.org> +sip-4.13.ebuild:
+ Version bump
03 Nov 2011; Jeroen Roovers <jer@gentoo.org> sip-4.12.3-r2.ebuild:
Stable for HPPA (bug #374591).
diff --git a/dev-python/sip/sip-4.13.ebuild b/dev-python/sip/sip-4.13.ebuild
new file mode 100644
index 000000000000..3813bb4af4ee
--- /dev/null
+++ b/dev-python/sip/sip-4.13.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.13.ebuild,v 1.1 2011/11/11 19:33:35 hwoarang Exp $
+
+EAPI="3"
+PYTHON_DEPEND="*"
+PYTHON_EXPORT_PHASE_FUNCTIONS="1"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="*-jython"
+
+inherit eutils python toolchain-funcs
+
+MY_P="${P/_pre/-snapshot-}"
+
+DESCRIPTION="Python extension module generator for C and C++ libraries"
+HOMEPAGE="http://www.riverbankcomputing.co.uk/software/sip/intro http://pypi.python.org/pypi/SIP"
+SRC_URI="http://www.riverbankcomputing.com/static/Downloads/${PN}${PV%%.*}/${MY_P}.tar.gz"
+
+LICENSE="|| ( GPL-2 GPL-3 sip )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="debug doc"
+
+S="${WORKDIR}/${MY_P}"
+
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-4.9.3-darwin.patch"
+ python_copy_sources
+}
+
+src_configure() {
+ configuration() {
+ local myconf=("$(PYTHON)"
+ configure.py
+ --bindir="${EPREFIX}/usr/bin"
+ --incdir="${EPREFIX}$(python_get_includedir)"
+ --destdir="${EPREFIX}$(python_get_sitedir)"
+ --sipdir="${EPREFIX}/usr/share/sip"
+ $(use debug && echo --debug)
+ CC="$(tc-getCC)"
+ CXX="$(tc-getCXX)"
+ LINK="$(tc-getCXX)"
+ LINK_SHLIB="$(tc-getCXX)"
+ CFLAGS="${CFLAGS}"
+ CXXFLAGS="${CXXFLAGS}"
+ LFLAGS="${LDFLAGS}"
+ STRIP=":")
+ echo "${myconf[@]}"
+ "${myconf[@]}"
+ }
+ python_execute_function -s configuration
+}
+
+src_install() {
+ python_src_install
+
+ dodoc NEWS || die "dodoc failed"
+
+ if use doc; then
+ dohtml -r doc/html/* || die "dohtml failed"
+ fi
+}
+
+pkg_postinst() {
+ python_mod_optimize sipconfig.py sipdistutils.py
+
+ ewarn "When updating dev-python/sip, you usually need to rebuild packages, which depend on dev-python/sip,"
+ ewarn "such as dev-python/PyQt4 and dev-python/qscintilla-python. If you have app-portage/gentoolkit"
+ ewarn "installed, you can find these packages with \`equery d dev-python/sip dev-python/PyQt4\`."
+}
+
+pkg_postrm() {
+ python_mod_cleanup sipconfig.py sipdistutils.py
+}