summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2008-02-23 16:50:12 +0000
committerTiziano Müller <dev-zero@gentoo.org>2008-02-23 16:50:12 +0000
commitaa52dde2ea9ce9f4d4e5d48a8a35f9223e419324 (patch)
treee0244ad92863db3f6f6bcd326aa848d9777f11f2 /dev-python/sip
parentStable for HPPA too. (diff)
downloadgentoo-2-aa52dde2ea9ce9f4d4e5d48a8a35f9223e419324.tar.gz
gentoo-2-aa52dde2ea9ce9f4d4e5d48a8a35f9223e419324.tar.bz2
gentoo-2-aa52dde2ea9ce9f4d4e5d48a8a35f9223e419324.zip
Made sip respect our LDFLAGS (bug #209738). Dropped old & unused versions.
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-python/sip')
-rw-r--r--dev-python/sip/ChangeLog6
-rw-r--r--dev-python/sip/sip-4.3.2.ebuild46
-rw-r--r--dev-python/sip/sip-4.5.2-r1.ebuild57
-rw-r--r--dev-python/sip/sip-4.7.3.ebuild8
-rw-r--r--dev-python/sip/sip-4.7.ebuild57
5 files changed, 9 insertions, 165 deletions
diff --git a/dev-python/sip/ChangeLog b/dev-python/sip/ChangeLog
index 3b61a328d5f6..1196743e8ab7 100644
--- a/dev-python/sip/ChangeLog
+++ b/dev-python/sip/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/sip
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/ChangeLog,v 1.111 2008/02/21 14:27:41 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/ChangeLog,v 1.112 2008/02/23 16:50:12 dev-zero Exp $
+
+ 23 Feb 2008; Tiziano Müller <dev-zero@gentoo.org> -sip-4.3.2.ebuild,
+ -sip-4.5.2-r1.ebuild, -sip-4.7.ebuild, sip-4.7.3.ebuild:
+ Made sip respect our LDFLAGS (bug #209738). Dropped old & unused versions.
21 Feb 2008; Raúl Porcel <armin76@gentoo.org> sip-4.7.3.ebuild:
alpha/ia64/sparc stable
diff --git a/dev-python/sip/sip-4.3.2.ebuild b/dev-python/sip/sip-4.3.2.ebuild
deleted file mode 100644
index 0928d65ff7f4..000000000000
--- a/dev-python/sip/sip-4.3.2.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.3.2.ebuild,v 1.4 2007/06/24 21:48:17 dev-zero Exp $
-
-inherit distutils multilib
-
-MY_P=${P/"?.?.?_pre"/"snapshot-"}
-MY_P=${MY_P/_/}
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="SIP is a tool for generating bindings for C++ classes so that they can be used by Python."
-HOMEPAGE="http://www.riverbankcomputing.co.uk/sip/"
-SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
-#SRC_URI="http://www.river-bank.demon.co.uk/download/sip/${MY_P}.tar.gz"
-#SRC_URI="http://www.river-bank.demon.co.uk/download/snapshots/sip/${MY_P}.tar.gz"
-
-SLOT="0"
-LICENSE="sip"
-KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="debug doc"
-
-DEPEND="virtual/libc
- x11-libs/qt
- >=dev-lang/python-2.3"
-
-src_compile(){
- distutils_python_version
-
- local myconf="-l qt-mt -b /usr/bin -d /usr/$(get_libdir)/python${PYVER}/site-packages -e /usr/include/python${PYVER}"
- use debug && myconf="${myconf} -u"
-
- python configure.py ${myconf} "CFLAGS+=${CFLAGS}" "CXXFLAGS+=${CXXFLAGS}"
- emake || die "emake failed"
-}
-
-src_install() {
- make DESTDIR=${D} install || die "install failed"
- dodoc ChangeLog LICENSE NEWS README THANKS TODO
- if use doc ; then dohtml doc/* ; fi
-}
-
-pkg_postinst() {
- echo ""
- elog "Please note, that you have to emerge PyQt again, when upgrading from sip-3.x."
- echo ""
-}
diff --git a/dev-python/sip/sip-4.5.2-r1.ebuild b/dev-python/sip/sip-4.5.2-r1.ebuild
deleted file mode 100644
index 62ed95004412..000000000000
--- a/dev-python/sip/sip-4.5.2-r1.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.5.2-r1.ebuild,v 1.8 2007/06/24 21:48:17 dev-zero Exp $
-
-NEED_PYTHON=2.3
-
-inherit python toolchain-funcs versionator multilib
-
-MY_P=${P/_}
-
-DESCRIPTION="SIP is a tool for generating bindings for C++ classes so that they can be used by Python."
-HOMEPAGE="http://www.riverbankcomputing.co.uk/sip/"
-SRC_URI="http://www.riverbankcomputing.com/Downloads/sip$(get_major_version)/${MY_P}.tar.gz"
-
-LICENSE="sip"
-SLOT="0"
-KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86"
-IUSE="debug"
-
-S=${WORKDIR}/${MY_P}
-
-DEPEND=""
-RDEPEND=""
-
-src_compile(){
- python_version
-
- local myconf
- use debug && myconf="${myconf} -u"
-
- python configure.py \
- -b "/usr/bin" \
- -d "/usr/$(get_libdir)/python${PYVER}/site-packages" \
- -e "/usr/include/python${PYVER}" \
- -v "/usr/share/sip" \
- ${myconf} \
- CXXFLAGS_RELEASE="" CFLAGS_RELEASE="" \
- CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" \
- CC=$(tc-getCC) CXX=$(tc-getCXX) \
- LINK=$(tc-getCXX) LINK_SHLIB=$(tc-getCXX) \
- STRIP="/bin/true" || die "configure failed"
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc ChangeLog NEWS README THANKS TODO doc/sipref.txt
- dohtml doc/*
-}
-
-pkg_postinst() {
- python_mod_optimize
-}
-
-pkg_postrm() {
- python_mod_cleanup
-}
diff --git a/dev-python/sip/sip-4.7.3.ebuild b/dev-python/sip/sip-4.7.3.ebuild
index 925082b84bf0..786a388acabe 100644
--- a/dev-python/sip/sip-4.7.3.ebuild
+++ b/dev-python/sip/sip-4.7.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.7.3.ebuild,v 1.3 2008/02/21 14:27:41 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.7.3.ebuild,v 1.4 2008/02/23 16:50:12 dev-zero Exp $
NEED_PYTHON=2.3
@@ -28,14 +28,14 @@ src_compile(){
local myconf
use debug && myconf="${myconf} -u"
- python configure.py \
+ "${python}" configure.py \
-b "/usr/bin" \
-d "/usr/$(get_libdir)/python${PYVER}/site-packages" \
-e "/usr/include/python${PYVER}" \
-v "/usr/share/sip" \
${myconf} \
- CXXFLAGS_RELEASE="" CFLAGS_RELEASE="" \
- CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" \
+ CXXFLAGS_RELEASE="" CFLAGS_RELEASE="" LFLAGS="${LDFLAGS}" \
+ CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" LFLAGS="${LDFLAGS}" \
CC=$(tc-getCC) CXX=$(tc-getCXX) \
LINK=$(tc-getCXX) LINK_SHLIB=$(tc-getCXX) \
STRIP="/bin/true" || die "configure failed"
diff --git a/dev-python/sip/sip-4.7.ebuild b/dev-python/sip/sip-4.7.ebuild
deleted file mode 100644
index c31078fac729..000000000000
--- a/dev-python/sip/sip-4.7.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.7.ebuild,v 1.3 2007/10/08 08:39:14 tgall Exp $
-
-NEED_PYTHON=2.3
-
-inherit python toolchain-funcs versionator multilib
-
-MY_P=${P/_}
-
-DESCRIPTION="SIP is a tool for generating bindings for C++ classes so that they can be used by Python."
-HOMEPAGE="http://www.riverbankcomputing.co.uk/sip/"
-SRC_URI="http://www.riverbankcomputing.com/Downloads/sip$(get_major_version)/${MY_P}.tar.gz"
-
-LICENSE="sip"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~ia64 ~ppc ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="debug"
-
-S=${WORKDIR}/${MY_P}
-
-DEPEND=""
-RDEPEND=""
-
-src_compile(){
- python_version
-
- local myconf
- use debug && myconf="${myconf} -u"
-
- python configure.py \
- -b "/usr/bin" \
- -d "/usr/$(get_libdir)/python${PYVER}/site-packages" \
- -e "/usr/include/python${PYVER}" \
- -v "/usr/share/sip" \
- ${myconf} \
- CXXFLAGS_RELEASE="" CFLAGS_RELEASE="" \
- CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" \
- CC=$(tc-getCC) CXX=$(tc-getCXX) \
- LINK=$(tc-getCXX) LINK_SHLIB=$(tc-getCXX) \
- STRIP="/bin/true" || die "configure failed"
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc ChangeLog NEWS README THANKS TODO doc/sipref.txt
- dohtml doc/*
-}
-
-pkg_postinst() {
- python_mod_optimize
-}
-
-pkg_postrm() {
- python_mod_cleanup
-}