summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2012-02-23 21:32:39 +0000
committerDavide Pesavento <pesa@gentoo.org>2012-02-23 21:32:39 +0000
commit510350240ca09980262daee13bc149d7e4d7fd98 (patch)
tree3b44e3d12eedd45287c0ff21e4e6c704409da3ab /dev-python/sip
parentVersion bump (diff)
downloadgentoo-2-510350240ca09980262daee13bc149d7e4d7fd98.tar.gz
gentoo-2-510350240ca09980262daee13bc149d7e4d7fd98.tar.bz2
gentoo-2-510350240ca09980262daee13bc149d7e4d7fd98.zip
Revbump with EAPI 4 support.
(Portage version: 2.2.0_alpha89/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/sip')
-rw-r--r--dev-python/sip/ChangeLog8
-rw-r--r--dev-python/sip/sip-4.13.2-r1.ebuild (renamed from dev-python/sip/sip-4.13.2.ebuild)12
2 files changed, 13 insertions, 7 deletions
diff --git a/dev-python/sip/ChangeLog b/dev-python/sip/ChangeLog
index a450bec37c16..8ad270717af5 100644
--- a/dev-python/sip/ChangeLog
+++ b/dev-python/sip/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/sip
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/ChangeLog,v 1.209 2012/02/23 18:39:42 pesa Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/ChangeLog,v 1.210 2012/02/23 21:32:39 pesa Exp $
+
+*sip-4.13.2-r1 (23 Feb 2012)
+
+ 23 Feb 2012; Davide Pesavento <pesa@gentoo.org> +sip-4.13.2-r1.ebuild,
+ -sip-4.13.2.ebuild:
+ Revbump with EAPI 4 support.
23 Feb 2012; Davide Pesavento <pesa@gentoo.org> sip-4.13.2.ebuild:
Minor code cleanup.
diff --git a/dev-python/sip/sip-4.13.2.ebuild b/dev-python/sip/sip-4.13.2-r1.ebuild
index 391fa5ca7343..f5093d1b74dd 100644
--- a/dev-python/sip/sip-4.13.2.ebuild
+++ b/dev-python/sip/sip-4.13.2-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.13.2.ebuild,v 1.3 2012/02/23 18:39:42 pesa Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.13.2-r1.ebuild,v 1.1 2012/02/23 21:32:39 pesa Exp $
-EAPI="3"
+EAPI="4"
PYTHON_DEPEND="*"
PYTHON_EXPORT_PHASE_FUNCTIONS="1"
SUPPORT_PYTHON_ABIS="1"
@@ -26,7 +26,7 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-4.9.3-darwin.patch
sed -i -e 's/-O2//g' specs/* || die
- python_copy_sources
+ python_src_prepare
}
src_configure() {
@@ -34,8 +34,8 @@ src_configure() {
local myconf=("$(PYTHON)"
configure.py
--bindir="${EPREFIX}/usr/bin"
- --incdir="${EPREFIX}$(python_get_includedir)"
--destdir="${EPREFIX}$(python_get_sitedir)"
+ --incdir="${EPREFIX}$(python_get_includedir)"
--sipdir="${EPREFIX}/usr/share/sip"
$(use debug && echo --debug)
CC="$(tc-getCC)"
@@ -55,10 +55,10 @@ src_configure() {
src_install() {
python_src_install
- dodoc NEWS || die "dodoc failed"
+ dodoc NEWS
if use doc; then
- dohtml -r doc/html/* || die "dohtml failed"
+ dohtml -r doc/html/*
fi
}