summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2004-09-24 22:50:51 +0000
committerCarsten Lohrke <carlo@gentoo.org>2004-09-24 22:50:51 +0000
commit8b723450c9819c890c2a771cba5c7cbfaaf5fe44 (patch)
treed9c75892c9ca06d0f401e6775bf98404d4f4fc20 /dev-python/sip/sip-4.1.1.ebuild
parentppc stable profile update (Manifest recommit) (diff)
downloadgentoo-2-8b723450c9819c890c2a771cba5c7cbfaaf5fe44.tar.gz
gentoo-2-8b723450c9819c890c2a771cba5c7cbfaaf5fe44.tar.bz2
gentoo-2-8b723450c9819c890c2a771cba5c7cbfaaf5fe44.zip
version bump
Diffstat (limited to 'dev-python/sip/sip-4.1.1.ebuild')
-rw-r--r--dev-python/sip/sip-4.1.1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/sip/sip-4.1.1.ebuild b/dev-python/sip/sip-4.1.1.ebuild
new file mode 100644
index 000000000000..c1d6e056002d
--- /dev/null
+++ b/dev-python/sip/sip-4.1.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.1.1.ebuild,v 1.1 2004/09/24 22:50:51 carlo Exp $
+
+inherit distutils
+
+MY_P=${P/_/}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="SIP is a tool for generating bindings for C++ classes so that they can be used by Python."
+HOMEPAGE="http://www.riverbankcomputing.co.uk/sip/"
+SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~amd64"
+IUSE="doc"
+
+DEPEND="virtual/libc
+ x11-libs/qt
+ >=dev-lang/python-2.3"
+
+src_compile(){
+ distutils_python_version
+ python configure.py -l qt-mt \
+ -b /usr/bin \
+ -d /usr/lib/python${PYVER}/site-packages \
+ -e /usr/include/python${PYVER} \
+ "CXXFLAGS+=${CXXFLAGS}"
+ emake || die
+}
+
+src_install() {
+ einstall DESTDIR=${D} || die
+ dodoc ChangeLog LICENSE NEWS README THANKS TODO
+ if use doc ; then dohtml doc/* ; fi
+}
+
+pkg_postinst() {
+ einfo "Please note, that you have to emerge PyQt again, when upgrading from sip-3.x."
+}