summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-11-01 16:44:29 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-11-01 16:44:29 +0000
commit8eedba6da1d9c9db9ab4aabf2a70e72350fd52cf (patch)
tree08f7a9eea5366f3f0ebb8f92fb8b45857bb247d9 /dev-python/simplejson
parentRemove portage-2.2 from package.mask since we're now using a keywords mask in... (diff)
downloadgentoo-2-8eedba6da1d9c9db9ab4aabf2a70e72350fd52cf.tar.gz
gentoo-2-8eedba6da1d9c9db9ab4aabf2a70e72350fd52cf.tar.bz2
gentoo-2-8eedba6da1d9c9db9ab4aabf2a70e72350fd52cf.zip
Version bump.
(Portage version: 2.2.0_alpha3/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/simplejson')
-rw-r--r--dev-python/simplejson/ChangeLog8
-rw-r--r--dev-python/simplejson/simplejson-2.1.2.ebuild40
2 files changed, 47 insertions, 1 deletions
diff --git a/dev-python/simplejson/ChangeLog b/dev-python/simplejson/ChangeLog
index 4737f401557f..55af68d86583 100644
--- a/dev-python/simplejson/ChangeLog
+++ b/dev-python/simplejson/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/simplejson
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/simplejson/ChangeLog,v 1.28 2010/06/04 10:16:58 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/simplejson/ChangeLog,v 1.29 2010/11/01 16:44:29 arfrever Exp $
+
+*simplejson-2.1.2 (01 Nov 2010)
+
+ 01 Nov 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +simplejson-2.1.2.ebuild:
+ Version bump.
04 Jun 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
simplejson-2.1.1.ebuild:
diff --git a/dev-python/simplejson/simplejson-2.1.2.ebuild b/dev-python/simplejson/simplejson-2.1.2.ebuild
new file mode 100644
index 000000000000..1886019aa255
--- /dev/null
+++ b/dev-python/simplejson/simplejson-2.1.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/simplejson/simplejson-2.1.2.ebuild,v 1.1 2010/11/01 16:44:29 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+DESCRIPTION="Simple, fast, extensible JSON encoder/decoder for Python"
+HOMEPAGE="http://undefined.org/python/#simplejson http://pypi.python.org/pypi/simplejson"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc"
+
+DEPEND="dev-python/setuptools"
+RDEPEND=""
+
+PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
+
+src_test() {
+ testing() {
+ ln -fs ../$(ls -d build-${PYTHON_ABI}/lib*)/simplejson/_speedups.so simplejson/_speedups.so
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" simplejson/tests/__init__.py
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dohtml -r docs/* || die "dohtml failed"
+ fi
+}