summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-05-02 07:31:40 +0000
committerTim Harder <radhermit@gentoo.org>2013-05-02 07:31:40 +0000
commit3d204e1c3ba99fd16c2f8ecfcdf07b8f02fb091a (patch)
tree9d8014ab434b2d946eebd2330f3998a6007f1458 /dev-python/simplejson
parentVersion bump. (diff)
downloadgentoo-2-3d204e1c3ba99fd16c2f8ecfcdf07b8f02fb091a.tar.gz
gentoo-2-3d204e1c3ba99fd16c2f8ecfcdf07b8f02fb091a.tar.bz2
gentoo-2-3d204e1c3ba99fd16c2f8ecfcdf07b8f02fb091a.zip
Version bump.
(Portage version: 2.2.0_alpha173/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-python/simplejson')
-rw-r--r--dev-python/simplejson/ChangeLog7
-rw-r--r--dev-python/simplejson/simplejson-3.2.0.ebuild28
2 files changed, 34 insertions, 1 deletions
diff --git a/dev-python/simplejson/ChangeLog b/dev-python/simplejson/ChangeLog
index ed575fda9a33..2bb5dec6266d 100644
--- a/dev-python/simplejson/ChangeLog
+++ b/dev-python/simplejson/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/simplejson
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/simplejson/ChangeLog,v 1.93 2013/04/07 00:36:35 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/simplejson/ChangeLog,v 1.94 2013/05/02 07:31:40 radhermit Exp $
+
+*simplejson-3.2.0 (02 May 2013)
+
+ 02 May 2013; Tim Harder <radhermit@gentoo.org> +simplejson-3.2.0.ebuild:
+ Version bump.
*simplejson-3.1.3 (07 Apr 2013)
diff --git a/dev-python/simplejson/simplejson-3.2.0.ebuild b/dev-python/simplejson/simplejson-3.2.0.ebuild
new file mode 100644
index 000000000000..438b0751eb0e
--- /dev/null
+++ b/dev-python/simplejson/simplejson-3.2.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/simplejson/simplejson-3.2.0.ebuild,v 1.1 2013/05/02 07:31:40 radhermit Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_3} pypy{1_9,2_0} )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Simple, fast, extensible JSON encoder/decoder for Python"
+HOMEPAGE="http://undefined.org/python/#simplejson http://pypi.python.org/pypi/simplejson"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( MIT AFL-2.1 )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+python_compile() {
+ if [[ ${EPYTHON} == python2* ]]; then
+ local CFLAGS=${CFLAGS}
+ append-cflags -fno-strict-aliasing
+ fi
+ distutils-r1_python_compile
+}
+
+python_test() {
+ esetup.py test
+}