summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-01-09 02:19:50 +0000
committerTim Harder <radhermit@gentoo.org>2013-01-09 02:19:50 +0000
commit308998217dbe8b30b15d6909a0589b9466a004ed (patch)
tree1226e84a6cbc594436d8324e2d9079148a818a75 /dev-python/simplejson
parentRemove old. (diff)
downloadgentoo-2-308998217dbe8b30b15d6909a0589b9466a004ed.tar.gz
gentoo-2-308998217dbe8b30b15d6909a0589b9466a004ed.tar.bz2
gentoo-2-308998217dbe8b30b15d6909a0589b9466a004ed.zip
Version bump (bug #450562).
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-python/simplejson')
-rw-r--r--dev-python/simplejson/ChangeLog7
-rw-r--r--dev-python/simplejson/simplejson-3.0.5.ebuild29
2 files changed, 35 insertions, 1 deletions
diff --git a/dev-python/simplejson/ChangeLog b/dev-python/simplejson/ChangeLog
index e470e7febebf..b2da661381e8 100644
--- a/dev-python/simplejson/ChangeLog
+++ b/dev-python/simplejson/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/simplejson
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/simplejson/ChangeLog,v 1.84 2013/01/03 19:24:53 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/simplejson/ChangeLog,v 1.85 2013/01/09 02:19:50 radhermit Exp $
+
+*simplejson-3.0.5 (09 Jan 2013)
+
+ 09 Jan 2013; Tim Harder <radhermit@gentoo.org> +simplejson-3.0.5.ebuild:
+ Version bump (bug #450562).
*simplejson-3.0.4-r1 (03 Jan 2013)
diff --git a/dev-python/simplejson/simplejson-3.0.5.ebuild b/dev-python/simplejson/simplejson-3.0.5.ebuild
new file mode 100644
index 000000000000..e4e4fb1c599f
--- /dev/null
+++ b/dev-python/simplejson/simplejson-3.0.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/simplejson/simplejson-3.0.5.ebuild,v 1.1 2013/01/09 02:19:50 radhermit Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_3} pypy{1_9,2_0} )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Simple, fast, extensible JSON encoder/decoder for Python"
+HOMEPAGE="http://undefined.org/python/#simplejson http://pypi.python.org/pypi/simplejson"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+
+python_compile() {
+ if [[ ${EPYTHON} == python2* ]]; then
+ local CFLAGS=${CFLAGS}
+ append-cflags -fno-strict-aliasing
+ fi
+ distutils-r1_python_compile
+}
+
+python_test() {
+ esetup.py test
+}