summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-05-07 07:21:38 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-05-07 07:21:38 +0000
commitea66fc7cd757e1ec990457961e1d4f9439c6c09c (patch)
tree82b801a1b423af2e6739434d3ad1d014e2d242f5 /dev-python/shiboken
parenttypo in Changelog (diff)
downloadgentoo-2-ea66fc7cd757e1ec990457961e1d4f9439c6c09c.tar.gz
gentoo-2-ea66fc7cd757e1ec990457961e1d4f9439c6c09c.tar.bz2
gentoo-2-ea66fc7cd757e1ec990457961e1d4f9439c6c09c.zip
Bump
(Portage version: 2.2.10/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/shiboken')
-rw-r--r--dev-python/shiboken/ChangeLog7
-rw-r--r--dev-python/shiboken/shiboken-1.2.2.ebuild85
2 files changed, 91 insertions, 1 deletions
diff --git a/dev-python/shiboken/ChangeLog b/dev-python/shiboken/ChangeLog
index 4eda3456b151..b3f0bc372941 100644
--- a/dev-python/shiboken/ChangeLog
+++ b/dev-python/shiboken/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/shiboken
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/shiboken/ChangeLog,v 1.50 2014/02/24 01:19:01 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/shiboken/ChangeLog,v 1.51 2014/05/07 07:21:38 patrick Exp $
+
+*shiboken-1.2.2 (07 May 2014)
+
+ 07 May 2014; Patrick Lauer <patrick@gentoo.org> +shiboken-1.2.2.ebuild:
+ Bump
24 Feb 2014; Pawel Hajdan jr <phajdan.jr@gentoo.org>
shiboken-1.2.1-r1.ebuild:
diff --git a/dev-python/shiboken/shiboken-1.2.2.ebuild b/dev-python/shiboken/shiboken-1.2.2.ebuild
new file mode 100644
index 000000000000..60dd731296fd
--- /dev/null
+++ b/dev-python/shiboken/shiboken-1.2.2.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/shiboken/shiboken-1.2.2.ebuild,v 1.1 2014/05/07 07:21:38 patrick Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+
+inherit multilib cmake-utils python-r1
+
+DESCRIPTION="A tool for creating Python bindings for C++ libraries"
+HOMEPAGE="http://qt-project.org/wiki/PySide"
+SRC_URI="http://download.qt-project.org/official_releases/pyside/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ >=dev-libs/libxml2-2.6.32
+ >=dev-libs/libxslt-1.1.19
+ >=dev-qt/qtcore-4.7.0:4
+ >=dev-qt/qtxmlpatterns-4.7.0:4
+ !dev-python/apiextractor
+ !dev-python/generatorrunner
+"
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-qt/qtgui-4.7.0:4
+ >=dev-qt/qttest-4.7.0:4
+ )"
+
+DOCS=( AUTHORS ChangeLog )
+
+src_prepare() {
+ # Fix inconsistent naming of libshiboken.so and ShibokenConfig.cmake,
+ # caused by the usage of a different version suffix with python >= 3.2
+ sed -i -e "/get_config_var('SOABI')/d" \
+ cmake/Modules/FindPython3InterpWithDebug.cmake || die
+
+ if use prefix; then
+ cp "${FILESDIR}"/rpath.cmake . || die
+ sed -i -e '1iinclude(rpath.cmake)' CMakeLists.txt || die
+ fi
+}
+
+src_configure() {
+ configuration() {
+ local mycmakeargs=(
+ $(cmake-utils_use_build test TESTS)
+ -DPYTHON_EXECUTABLE="${PYTHON}"
+ -DPYTHON_SITE_PACKAGES="$(python_get_sitedir)"
+ -DPYTHON_SUFFIX="-${EPYTHON}"
+ )
+
+ if [[ ${EPYTHON} == python3* ]]; then
+ mycmakeargs+=(
+ -DUSE_PYTHON3=ON
+ -DPYTHON3_EXECUTABLE="${PYTHON}"
+ -DPYTHON3_INCLUDE_DIR="$(python_get_includedir)"
+ -DPYTHON3_LIBRARY="$(python_get_library_path)"
+ )
+ fi
+
+ cmake-utils_src_configure
+ }
+ python_foreach_impl configuration
+}
+
+src_compile() {
+ python_foreach_impl cmake-utils_src_make
+}
+
+src_test() {
+ python_foreach_impl cmake-utils_src_test
+}
+
+src_install() {
+ installation() {
+ cmake-utils_src_install
+ mv "${ED}"usr/$(get_libdir)/pkgconfig/${PN}{,-${EPYTHON}}.pc || die
+ }
+ python_foreach_impl installation
+}