summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2012-03-06 23:54:20 +0000
committerDavide Pesavento <pesa@gentoo.org>2012-03-06 23:54:20 +0000
commit5bd82492a3e01f103bec035c43c5a9e6e1dd657e (patch)
treed1df4b86391670f9ca5f358c5cf6c1661f6f8294 /dev-python/shiboken
parentMask rewritten dev-python/{shiboken,pyside}-1.1.0-r1 ebuilds. (diff)
downloadgentoo-2-5bd82492a3e01f103bec035c43c5a9e6e1dd657e.tar.gz
gentoo-2-5bd82492a3e01f103bec035c43c5a9e6e1dd657e.tar.bz2
gentoo-2-5bd82492a3e01f103bec035c43c5a9e6e1dd657e.zip
Revbump: ebuild rewritten to support multiple python ABIs (bug #401549 by Rafał Mużyło), thanks to Ian Delaney for initial testing.
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/shiboken')
-rw-r--r--dev-python/shiboken/ChangeLog9
-rw-r--r--dev-python/shiboken/metadata.xml5
-rw-r--r--dev-python/shiboken/shiboken-1.1.0-r1.ebuild80
3 files changed, 89 insertions, 5 deletions
diff --git a/dev-python/shiboken/ChangeLog b/dev-python/shiboken/ChangeLog
index 0299fb399cdc..47626bf5be5c 100644
--- a/dev-python/shiboken/ChangeLog
+++ b/dev-python/shiboken/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/shiboken
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/shiboken/ChangeLog,v 1.16 2012/01/15 11:23:11 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/shiboken/ChangeLog,v 1.17 2012/03/06 23:54:20 pesa Exp $
+
+*shiboken-1.1.0-r1 (06 Mar 2012)
+
+ 06 Mar 2012; Davide Pesavento <pesa@gentoo.org> +shiboken-1.1.0-r1.ebuild,
+ metadata.xml:
+ Revbump: ebuild rewritten to support multiple python ABIs (bug #401549 by
+ Rafał Mużyło), thanks to Ian Delaney for initial testing.
*shiboken-1.1.0 (15 Jan 2012)
diff --git a/dev-python/shiboken/metadata.xml b/dev-python/shiboken/metadata.xml
index 37b9640e6ce9..dc439f7e84f5 100644
--- a/dev-python/shiboken/metadata.xml
+++ b/dev-python/shiboken/metadata.xml
@@ -1,8 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>qt</herd>
- <longdescription lang="en">
- </longdescription>
+<herd>qt</herd>
</pkgmetadata>
-
diff --git a/dev-python/shiboken/shiboken-1.1.0-r1.ebuild b/dev-python/shiboken/shiboken-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..fe16742fde76
--- /dev/null
+++ b/dev-python/shiboken/shiboken-1.1.0-r1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/shiboken/shiboken-1.1.0-r1.ebuild,v 1.1 2012/03/06 23:54:20 pesa Exp $
+
+EAPI=4
+
+CMAKE_IN_SOURCE_BUILD="1"
+
+PYTHON_DEPEND="2:2.6 3:3.2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 2.5 3.1 *-jython 2.7-pypy-*"
+
+inherit multilib cmake-utils python
+
+DESCRIPTION="A tool for creating Python bindings for C++ libraries"
+HOMEPAGE="http://www.pyside.org/"
+SRC_URI="http://www.pyside.org/files/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND=">=dev-python/apiextractor-0.10.10
+ >=dev-python/generatorrunner-0.6.16
+ >=x11-libs/qt-core-4.7.0:4"
+RDEPEND="${DEPEND}
+ !dev-python/boostpythongenerator"
+
+DOCS=( ChangeLog )
+
+src_prepare() {
+ # Fix inconsistent naming of libshiboken.so and ShibokenConfig.cmake,
+ # caused by the usage of a different version suffix with python >= 3.2
+ sed -i -e "/get_config_var('SOABI')/d" \
+ cmake/Modules/FindPython3InterpWithDebug.cmake || die
+
+ python_src_prepare
+}
+
+src_configure() {
+ configuration() {
+ local mycmakeargs=(
+ $(cmake-utils_use_build test TESTS)
+ )
+
+ if [[ $(python_get_version -l --major) == 3 ]]; then
+ mycmakeargs+=(
+ -DUSE_PYTHON3=ON
+ -DPYTHON3_INCLUDE_DIR="$(python_get_includedir)"
+ -DPYTHON3_LIBRARY="$(python_get_library)"
+ )
+ fi
+
+ CMAKE_USE_DIR="${BUILDDIR}" cmake-utils_src_configure
+ }
+ python_execute_function -s configuration
+}
+
+src_compile() {
+ compilation() {
+ CMAKE_USE_DIR="${BUILDDIR}" cmake-utils_src_make
+ }
+ python_execute_function -s compilation
+}
+
+src_test() {
+ testing() {
+ CMAKE_USE_DIR="${BUILDDIR}" cmake-utils_src_test
+ }
+ python_execute_function -s testing
+}
+
+src_install() {
+ installation() {
+ CMAKE_USE_DIR="${BUILDDIR}" cmake-utils_src_install
+ mv "${ED}"usr/$(get_libdir)/pkgconfig/${PN}{,-python${PYTHON_ABI}}.pc || die
+ }
+ python_execute_function -s installation
+}