summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2013-01-24 01:48:27 +0000
committerPatrick McLean <chutzpah@gentoo.org>2013-01-24 01:48:27 +0000
commit0f6535c254e84f7f62a2e32f5e60b921d1eed8be (patch)
tree1ad82645da999c819c27b7e4c96e18814a65f849 /dev-python/sh
parentdrop USE="bootstrap build" as it does very little and the existing logic shou... (diff)
downloadgentoo-2-0f6535c254e84f7f62a2e32f5e60b921d1eed8be.tar.gz
gentoo-2-0f6535c254e84f7f62a2e32f5e60b921d1eed8be.tar.bz2
gentoo-2-0f6535c254e84f7f62a2e32f5e60b921d1eed8be.zip
New package. dev-python/sh another subprocess interface library.
(Portage version: 2.1.11.48/cvs/Linux x86_64, signed Manifest commit with key 0xE3F69979BB4B8928DA78E3D17CBF44EF)
Diffstat (limited to 'dev-python/sh')
-rw-r--r--dev-python/sh/ChangeLog9
-rw-r--r--dev-python/sh/metadata.xml17
-rw-r--r--dev-python/sh/sh-1.07.ebuild21
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/sh/ChangeLog b/dev-python/sh/ChangeLog
new file mode 100644
index 000000000000..a6bf8bfd52a1
--- /dev/null
+++ b/dev-python/sh/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-python/sh
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sh/ChangeLog,v 1.1 2013/01/24 01:48:27 chutzpah Exp $
+
+*sh-1.07 (24 Jan 2013)
+
+ 24 Jan 2013; Patrick McLean <chutzpah@gentoo.org> +metadata.xml,
+ +sh-1.07.ebuild:
+ New package. dev-python/sh another subprocess interface library.
diff --git a/dev-python/sh/metadata.xml b/dev-python/sh/metadata.xml
new file mode 100644
index 000000000000..5dd226e56cde
--- /dev/null
+++ b/dev-python/sh/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>chutzpah@gentoo.org</email>
+<name>Patrick McLean</name>
+</maintainer>
+<longdescription lang="en">
+sh (previously pbs) is a full-fledged subprocess interface for Python 2.6 - 3.2 that allows you to call any program as if it were a function:
+
+from sh import ifconfig
+print ifconfig("eth0")
+
+sh is not a collection of system commands implemented in Python.
+</longdescription>
+</pkgmetadata>
+
diff --git a/dev-python/sh/sh-1.07.ebuild b/dev-python/sh/sh-1.07.ebuild
new file mode 100644
index 000000000000..50210b059ae2
--- /dev/null
+++ b/dev-python/sh/sh-1.07.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sh/sh-1.07.ebuild,v 1.1 2013/01/24 01:48:27 chutzpah Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=(python{2_{6,7},3_{1,2,3}})
+inherit distutils-r1
+
+DESCRIPTION="Python subprocess interface"
+HOMEPAGE="https://github.com/amoffat/sh"
+SRC_URI="mirror://github/amoffat/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"