summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2012-12-12 18:39:51 +0000
committerMichał Górny <mgorny@gentoo.org>2012-12-12 18:39:51 +0000
commita0731254fe6617bd358c07e2f3beddc35fc1466b (patch)
treee334573db6add28b3257d748ad1c8fe5d1bcc937 /dev-python/setuptools
parentremoved myself from metadata.xml (diff)
downloadgentoo-2-a0731254fe6617bd358c07e2f3beddc35fc1466b.tar.gz
gentoo-2-a0731254fe6617bd358c07e2f3beddc35fc1466b.tar.bz2
gentoo-2-a0731254fe6617bd358c07e2f3beddc35fc1466b.zip
Fork unstable PYTHON_TARGETS to clear the way for stabilization.
(Portage version: 2.2.0_alpha148/cvs/Linux x86_64, signed Manifest commit with key 42B9401D)
Diffstat (limited to 'dev-python/setuptools')
-rw-r--r--dev-python/setuptools/ChangeLog8
-rw-r--r--dev-python/setuptools/setuptools-0.6.30-r1.ebuild4
-rw-r--r--dev-python/setuptools/setuptools-0.6.30-r2.ebuild52
3 files changed, 61 insertions, 3 deletions
diff --git a/dev-python/setuptools/ChangeLog b/dev-python/setuptools/ChangeLog
index 9dea23b7727a..f2bb30ff0f42 100644
--- a/dev-python/setuptools/ChangeLog
+++ b/dev-python/setuptools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/setuptools
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/setuptools/ChangeLog,v 1.166 2012/12/10 12:22:17 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/setuptools/ChangeLog,v 1.167 2012/12/12 18:39:51 mgorny Exp $
+
+*setuptools-0.6.30-r2 (12 Dec 2012)
+
+ 12 Dec 2012; Michał Górny <mgorny@gentoo.org> +setuptools-0.6.30-r2.ebuild,
+ setuptools-0.6.30-r1.ebuild:
+ Fork unstable PYTHON_TARGETS to clear the way for stabilization.
10 Dec 2012; Agostino Sarubbo <ago@gentoo.org> setuptools-0.6.30-r1.ebuild:
Stable for ppc64, wrt bug #446496
diff --git a/dev-python/setuptools/setuptools-0.6.30-r1.ebuild b/dev-python/setuptools/setuptools-0.6.30-r1.ebuild
index e772bd61d1c4..fcfa2505206e 100644
--- a/dev-python/setuptools/setuptools-0.6.30-r1.ebuild
+++ b/dev-python/setuptools/setuptools-0.6.30-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/setuptools/setuptools-0.6.30-r1.ebuild,v 1.5 2012/12/10 12:22:17 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/setuptools/setuptools-0.6.30-r1.ebuild,v 1.6 2012/12/12 18:39:51 mgorny Exp $
EAPI="4"
-PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2,3_3} pypy{1_8,1_9} jython2_5 )
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2} )
inherit distutils-r1 eutils
diff --git a/dev-python/setuptools/setuptools-0.6.30-r2.ebuild b/dev-python/setuptools/setuptools-0.6.30-r2.ebuild
new file mode 100644
index 000000000000..f7a6f98d54f7
--- /dev/null
+++ b/dev-python/setuptools/setuptools-0.6.30-r2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/setuptools/setuptools-0.6.30-r2.ebuild,v 1.1 2012/12/12 18:39:51 mgorny Exp $
+
+EAPI="4"
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2,3_3} pypy{1_8,1_9} jython2_5 )
+
+inherit distutils-r1 eutils
+
+MY_PN="distribute"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Distribute (fork of Setuptools) is a collection of extensions to Distutils"
+HOMEPAGE="http://pypi.python.org/pypi/distribute"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
+
+# The build system modifies sources.
+DISTUTILS_IN_SOURCE_BUILD=1
+
+DOCS=(
+ README.txt docs/{easy_install.txt,pkg_resources.txt,setuptools.txt}
+)
+
+python_prepare_all() {
+ local PATCHES=(
+ "${FILESDIR}/${PN}-0.6_rc7-noexe.patch"
+ "${FILESDIR}/distribute-0.6.16-fix_deprecation_warnings.patch"
+ )
+
+ # Disable tests requiring network connection.
+ rm -f setuptools/tests/test_packageindex.py
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # they fail with everything but py2.6 & 2.7
+ esetup.py test
+}
+
+python_install() {
+ DISTRIBUTE_DISABLE_VERSIONED_EASY_INSTALL_SCRIPT="1" \
+ DONT_PATCH_SETUPTOOLS="1" \
+ distutils-r1_python_install
+}