summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2011-12-27 04:53:54 +0000
committerPatrick Lauer <patrick@gentoo.org>2011-12-27 04:53:54 +0000
commit654e7a6c961157a5b829e941be59b92a875b9b3b (patch)
treebbd93741f59d0cfdea8ec3b32f28a02feb1a6328 /dev-python/setuptools
parentBump (diff)
downloadgentoo-2-654e7a6c961157a5b829e941be59b92a875b9b3b.tar.gz
gentoo-2-654e7a6c961157a5b829e941be59b92a875b9b3b.tar.bz2
gentoo-2-654e7a6c961157a5b829e941be59b92a875b9b3b.zip
Bump for #396123
(Portage version: 2.2.0_alpha81/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/setuptools')
-rw-r--r--dev-python/setuptools/ChangeLog7
-rw-r--r--dev-python/setuptools/setuptools-0.6.24.ebuild54
2 files changed, 60 insertions, 1 deletions
diff --git a/dev-python/setuptools/ChangeLog b/dev-python/setuptools/ChangeLog
index 1e5121d7ccf4..ee7886892f39 100644
--- a/dev-python/setuptools/ChangeLog
+++ b/dev-python/setuptools/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/setuptools
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/setuptools/ChangeLog,v 1.149 2011/11/16 19:06:55 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/setuptools/ChangeLog,v 1.150 2011/12/27 04:53:54 patrick Exp $
+
+*setuptools-0.6.24 (27 Dec 2011)
+
+ 27 Dec 2011; Patrick Lauer <patrick@gentoo.org> +setuptools-0.6.24.ebuild:
+ Bump for #396123
16 Nov 2011; Markos Chandras <hwoarang@gentoo.org> setuptools-0.6.14.ebuild,
setuptools-0.6.15.ebuild, setuptools-0.6.16.ebuild, setuptools-0.6.19.ebuild,
diff --git a/dev-python/setuptools/setuptools-0.6.24.ebuild b/dev-python/setuptools/setuptools-0.6.24.ebuild
new file mode 100644
index 000000000000..5edfc6536590
--- /dev/null
+++ b/dev-python/setuptools/setuptools-0.6.24.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/setuptools/setuptools-0.6.24.ebuild,v 1.1 2011/12/27 04:53:54 patrick Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+DISTUTILS_SRC_TEST="setup.py"
+
+inherit distutils eutils
+
+MY_PN="distribute"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Distribute (fork of Setuptools) is a collection of extensions to Distutils"
+HOMEPAGE="http://pypi.python.org/pypi/distribute"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="README.txt docs/easy_install.txt docs/pkg_resources.txt docs/setuptools.txt"
+PYTHON_MODNAME="easy_install.py pkg_resources.py setuptools site.py"
+
+src_prepare() {
+ distutils_src_prepare
+
+ epatch "${FILESDIR}/${PN}-0.6_rc7-noexe.patch"
+ epatch "${FILESDIR}/distribute-0.6.16-fix_deprecation_warnings.patch"
+
+ # Disable tests requiring network connection.
+ rm -f setuptools/tests/test_packageindex.py
+}
+
+src_test() {
+ # test_install_site_py fails with disabled byte-compiling in Python 2.7 / >=3.2.
+ python_enable_pyc
+
+ distutils_src_test
+
+ python_disable_pyc
+ find "(" -name "*.pyc" -o -name "*\$py.class" ")" -print0 | xargs -0 rm -f
+ find -name "__pycache__" -print0 | xargs -0 rmdir
+}
+
+src_install() {
+ DISTRIBUTE_DISABLE_VERSIONED_EASY_INSTALL_SCRIPT="1" DONT_PATCH_SETUPTOOLS="1" distutils_src_install
+}