summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-19 00:14:13 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-19 00:14:13 +0000
commitdf96e3dd5f4341fc51b4a98c3764f91cf5f1316a (patch)
treef06bd89ab4289f2528fc7643a9044898806a5a40 /dev-python/setproctitle
parentDelete older ebuild. (diff)
downloadgentoo-2-df96e3dd5f4341fc51b4a98c3764f91cf5f1316a.tar.gz
gentoo-2-df96e3dd5f4341fc51b4a98c3764f91cf5f1316a.tar.bz2
gentoo-2-df96e3dd5f4341fc51b4a98c3764f91cf5f1316a.zip
Version bump (bug #327919).
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/setproctitle')
-rw-r--r--dev-python/setproctitle/ChangeLog8
-rw-r--r--dev-python/setproctitle/setproctitle-1.1.ebuild50
2 files changed, 57 insertions, 1 deletions
diff --git a/dev-python/setproctitle/ChangeLog b/dev-python/setproctitle/ChangeLog
index 2cf5b5c809cd..31918a5b6d63 100644
--- a/dev-python/setproctitle/ChangeLog
+++ b/dev-python/setproctitle/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/setproctitle
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/setproctitle/ChangeLog,v 1.3 2010/06/05 21:21:53 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/setproctitle/ChangeLog,v 1.4 2010/07/19 00:14:13 arfrever Exp $
+
+*setproctitle-1.1 (19 Jul 2010)
+
+ 19 Jul 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -setproctitle-1.0.1.ebuild, +setproctitle-1.1.ebuild:
+ Version bump (bug #327919).
*setproctitle-1.0.1 (05 Jun 2010)
diff --git a/dev-python/setproctitle/setproctitle-1.1.ebuild b/dev-python/setproctitle/setproctitle-1.1.ebuild
new file mode 100644
index 000000000000..3700dec9ba37
--- /dev/null
+++ b/dev-python/setproctitle/setproctitle-1.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/setproctitle/setproctitle-1.1.ebuild,v 1.1 2010/07/19 00:14:13 arfrever Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils
+
+DESCRIPTION="Allow customization of the process title."
+HOMEPAGE="http://code.google.com/p/py-setproctitle/ http://pypi.python.org/pypi/setproctitle"
+SRC_URI="http://pypi.python.org/packages/source/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
+DOCS="HISTORY README"
+
+src_prepare() {
+ python_copy_sources
+
+ conversion() {
+ [[ "${PYTHON_ABI}" == 2.* ]] && return
+ 2to3-${PYTHON_ABI} -w --no-diffs tests > /dev/null
+ }
+ python_execute_function \
+ --action-message 'Applying patches for $(python_get_implementation) $(python_get_version)' \
+ --failure-message 'Applying patches for $(python_get_implementation) $(python_get_version) failed' \
+ -s conversion
+}
+
+src_test() {
+ testing() {
+ if [[ "${PYTHON_ABI}" == 2.* ]]; then
+ echo PYTHONPATH="$(ls -d build/lib.*)" nosetests
+ PYTHONPATH="$(ls -d build/lib.*)" nosetests || return 1
+ else
+ echo PYTHONPATH="$(ls -d build/lib.*)" "$(PYTHON)" tests/setproctitle_test.py
+ PYTHONPATH="$(ls -d build/lib.*)" "$(PYTHON)" tests/setproctitle_test.py || return 1
+ fi
+ }
+ python_execute_function -s testing
+}