summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2007-09-15 10:48:02 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2007-09-15 10:48:02 +0000
commitb3fbbb47cd64a0c0cd0dcbd1a01a22f2954a0f5b (patch)
tree9bbf1bc05fba6ed9c802ea7485d2f99fb242a9e1 /dev-python/scientificpython
parentqmail-mysql removal (diff)
downloadgentoo-2-b3fbbb47cd64a0c0cd0dcbd1a01a22f2954a0f5b.tar.gz
gentoo-2-b3fbbb47cd64a0c0cd0dcbd1a01a22f2954a0f5b.tar.bz2
gentoo-2-b3fbbb47cd64a0c0cd0dcbd1a01a22f2954a0f5b.zip
Add a src_test, fix mpi (bug #192443), longdescription, update numeric dep, and cleanup
(Portage version: 2.1.2.12)
Diffstat (limited to 'dev-python/scientificpython')
-rw-r--r--dev-python/scientificpython/ChangeLog9
-rw-r--r--dev-python/scientificpython/files/scientificpython-mpi.patch11
-rw-r--r--dev-python/scientificpython/metadata.xml10
-rw-r--r--dev-python/scientificpython/scientificpython-2.6.ebuild47
4 files changed, 62 insertions, 15 deletions
diff --git a/dev-python/scientificpython/ChangeLog b/dev-python/scientificpython/ChangeLog
index 939dc36ac3d3..f4d17b7f4a9f 100644
--- a/dev-python/scientificpython/ChangeLog
+++ b/dev-python/scientificpython/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/scientificpython
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/scientificpython/ChangeLog,v 1.13 2007/02/22 00:51:13 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/scientificpython/ChangeLog,v 1.14 2007/09/15 10:48:01 bicatali Exp $
+
+ 15 Sep 2007; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/scientificpython-mpi.patch, metadata.xml,
+ scientificpython-2.6.ebuild:
+ Add a src_test, fix mpi (bug #192443, thanks JTRiley
+ <justin.t.riley@gmail.com>), adde longdescription, updated numeric
+ dependency, and cleanup.
22 Feb 2007; Piotr Jaroszyński <peper@gentoo.org> ChangeLog:
Transition to Manifest2.
diff --git a/dev-python/scientificpython/files/scientificpython-mpi.patch b/dev-python/scientificpython/files/scientificpython-mpi.patch
new file mode 100644
index 000000000000..ee2e972f8f5d
--- /dev/null
+++ b/dev-python/scientificpython/files/scientificpython-mpi.patch
@@ -0,0 +1,11 @@
+--- Src/MPI/compile.py.orig 2007-09-15 11:11:53.739580548 +0100
++++ Src/MPI/compile.py 2007-09-15 11:12:49.798775179 +0100
+@@ -13,7 +13,7 @@
+ sources='mpipython.c Scientific_mpi.c'
+
+
+-cmd = '%s %s -o mpipython -I%s %s -L%s -lpython%s %s %s' % \
++cmd = '%s %s -o mpipython -I%s -I../../Include %s -L%s -lpython%s %s %s' % \
+ (mpicompiler,
+ cfgDict['LINKFORSHARED'],
+ cfgDict['INCLUDEPY'],
diff --git a/dev-python/scientificpython/metadata.xml b/dev-python/scientificpython/metadata.xml
index 4e87bf14976c..a531d91d7247 100644
--- a/dev-python/scientificpython/metadata.xml
+++ b/dev-python/scientificpython/metadata.xml
@@ -3,4 +3,14 @@
<pkgmetadata>
<herd>python</herd>
<herd>sci</herd>
+<longdescription lang="en">
+ScientificPython is a collection of Python modules that are useful for
+scientific computing. In this collection you will find modules that
+cover basic geometry (vectors, tensors, transformations, vector and
+tensor fields), quaternions, automatic derivatives, linear
+interpolation, polynomials, elementary statistics, nonlinear
+least-squares fits, unit calculations, Fortran-compatible text
+formatting, 3D visualization via VRML, and two Tk widgets for simple
+line plots and 3D wireframe models.
+</longdescription>
</pkgmetadata>
diff --git a/dev-python/scientificpython/scientificpython-2.6.ebuild b/dev-python/scientificpython/scientificpython-2.6.ebuild
index 9d13d3a4b64f..21158f67eadf 100644
--- a/dev-python/scientificpython/scientificpython-2.6.ebuild
+++ b/dev-python/scientificpython/scientificpython-2.6.ebuild
@@ -1,14 +1,12 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/scientificpython/scientificpython-2.6.ebuild,v 1.2 2006/10/17 04:14:04 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/scientificpython/scientificpython-2.6.ebuild,v 1.3 2007/09/15 10:48:01 bicatali Exp $
MY_P=${P/scientificpython/ScientificPython}
-S=${WORKDIR}/${MY_P}
DV=1034 # hardcoded download version
-inherit distutils
+inherit eutils distutils
-IUSE="mpi"
DESCRIPTION="Scientific Module for Python"
SRC_URI="http://sourcesup.cru.fr/frs/download.php/${DV}/${MY_P}.tar.gz"
HOMEPAGE="http://dirac.cnrs-orleans.fr/ScientificPython/"
@@ -16,25 +14,46 @@ SLOT="0"
LICENSE="CeCILL-2"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
-DEPEND="virtual/python
- >=dev-python/numeric-23.0
+IUSE="mpi doc"
+
+DEPEND=">=dev-python/numeric-23.8
>=sci-libs/netcdf-3.0
mpi? ( virtual/mpi )"
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-mpi.patch
+}
+
src_compile() {
distutils_src_compile
if use mpi; then
cd Src/MPI
- ${python} compile.py
- dobin mpipython || die "dobin failed"
+ "${python}" compile.py || die "compile mpi failed"
fi
}
+src_test() {
+ cd "${S}"/build/lib*
+ for t in "${S}"/Tests/*tests.py; do
+ PYTHONPATH=. "${python}" ${t} || die "test $(basename ${t}) failed"
+ done
+}
+
src_install() {
distutils_src_install
-
- dodoc MANIFEST.in README* Doc/CHANGELOG Doc/*.pdf
- dohtml Doc/Reference/*
- docinto Examples; dodoc Examples/*
- docinto Examples/BSP; dodoc Examples/BSP/*
+ # do not install bsp related stuff, since we don't compile the interface
+ dodoc README README.MPI Doc/CHANGELOG || die "dodoc failed"
+ insinto /usr/share/doc/${PF}
+ doins Examples/{demomodule.c,netcdf_demo.py} || die "doins examples failed"
+ if use mpi; then
+ dobin Src/MPI/mpipython || die "dobin failed"
+ doins Examples/mpi.py || die "doins mpi example failed failed"
+ fi
+ if use doc; then
+ dohtml Doc/Reference/* || die "dohtml failed"
+ fi
}