summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2007-10-17 11:27:51 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2007-10-17 11:27:51 +0000
commit88f6ec8af79c8257bcff7924463aa0002bd8e5d6 (patch)
treec6d31f66b8a980b5a64390326418563b2251542f /dev-python/scientificpython
parentAdd bugfix release 1.8.3 (diff)
downloadgentoo-2-88f6ec8af79c8257bcff7924463aa0002bd8e5d6.tar.gz
gentoo-2-88f6ec8af79c8257bcff7924463aa0002bd8e5d6.tar.bz2
gentoo-2-88f6ec8af79c8257bcff7924463aa0002bd8e5d6.zip
Version bump.
(Portage version: 2.1.3.12)
Diffstat (limited to 'dev-python/scientificpython')
-rw-r--r--dev-python/scientificpython/ChangeLog8
-rw-r--r--dev-python/scientificpython/files/digest-scientificpython-2.6.13
-rw-r--r--dev-python/scientificpython/scientificpython-2.6.1.ebuild59
3 files changed, 69 insertions, 1 deletions
diff --git a/dev-python/scientificpython/ChangeLog b/dev-python/scientificpython/ChangeLog
index f4d17b7f4a9f..c69bcf46c390 100644
--- a/dev-python/scientificpython/ChangeLog
+++ b/dev-python/scientificpython/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/scientificpython
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/scientificpython/ChangeLog,v 1.14 2007/09/15 10:48:01 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/scientificpython/ChangeLog,v 1.15 2007/10/17 11:27:51 bicatali Exp $
+
+*scientificpython-2.6.1 (17 Oct 2007)
+
+ 17 Oct 2007; Sébastien Fabbro <bicatali@gentoo.org>
+ +scientificpython-2.6.1.ebuild:
+ Version bump.
15 Sep 2007; Sébastien Fabbro <bicatali@gentoo.org>
+files/scientificpython-mpi.patch, metadata.xml,
diff --git a/dev-python/scientificpython/files/digest-scientificpython-2.6.1 b/dev-python/scientificpython/files/digest-scientificpython-2.6.1
new file mode 100644
index 000000000000..c6b03392c1b5
--- /dev/null
+++ b/dev-python/scientificpython/files/digest-scientificpython-2.6.1
@@ -0,0 +1,3 @@
+MD5 6ebd96fc8a4e015adab2c57826d52e9f ScientificPython-2.6.1.tar.gz 514044
+RMD160 5c9e8cba2373d722854cfe57e270803d7ed2bf2a ScientificPython-2.6.1.tar.gz 514044
+SHA256 cfa06b0e5bdadfdc79328bfd01843f9e7b0a08f7c19d1f32a7ecec498be72cc0 ScientificPython-2.6.1.tar.gz 514044
diff --git a/dev-python/scientificpython/scientificpython-2.6.1.ebuild b/dev-python/scientificpython/scientificpython-2.6.1.ebuild
new file mode 100644
index 000000000000..cdc535ffd2f0
--- /dev/null
+++ b/dev-python/scientificpython/scientificpython-2.6.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/scientificpython/scientificpython-2.6.1.ebuild,v 1.1 2007/10/17 11:27:51 bicatali Exp $
+
+MY_PN=ScientificPython
+DV=1034 # hardcoded download version
+
+inherit eutils distutils
+
+DESCRIPTION="Scientific Module for Python"
+SRC_URI="http://sourcesup.cru.fr/frs/download.php/${DV}/${MY_PN}-${PV}.tar.gz"
+HOMEPAGE="http://dirac.cnrs-orleans.fr/ScientificPython/"
+SLOT="0"
+LICENSE="CeCILL-2"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+
+IUSE="mpi doc"
+
+DEPEND=">=dev-python/numeric-23.8
+ >=sci-libs/netcdf-3.0
+ mpi? ( virtual/mpi )"
+
+S="${WORKDIR}/${MY_PN}-2.6"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-mpi.patch
+}
+
+src_compile() {
+ distutils_src_compile
+ if use mpi; then
+ cd Src/MPI
+ "${python}" compile.py || die "compile mpi failed"
+ fi
+}
+
+src_test() {
+ cd "${S}"/build/lib*
+ for t in "${S}"/Tests/*tests.py; do
+ PYTHONPATH=. "${python}" ${t} || die "test $(basename ${t}) failed"
+ done
+}
+
+src_install() {
+ distutils_src_install
+ # do not install bsp related stuff, since we don't compile the interface
+ dodoc README README.MPI Doc/CHANGELOG || die "dodoc failed"
+ insinto /usr/share/doc/${PF}
+ doins Examples/{demomodule.c,netcdf_demo.py} || die "doins examples failed"
+ if use mpi; then
+ dobin Src/MPI/mpipython || die "dobin failed"
+ doins Examples/mpi.py || die "doins mpi example failed failed"
+ fi
+ if use doc; then
+ dohtml Doc/Reference/* || die "dohtml failed"
+ fi
+}