summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-05-31 18:57:23 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-05-31 18:57:23 +0000
commitbe0c822ee13787ed2158390b2a6acef7f9dde37b (patch)
tree022b639e4c77830f6c1f5736143dd458f4dacefd /dev-python/rhpl
parentremove old versions (diff)
downloadgentoo-2-be0c822ee13787ed2158390b2a6acef7f9dde37b.tar.gz
gentoo-2-be0c822ee13787ed2158390b2a6acef7f9dde37b.tar.bz2
gentoo-2-be0c822ee13787ed2158390b2a6acef7f9dde37b.zip
Set SUPPORT_PYTHON_ABIS.
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/rhpl')
-rw-r--r--dev-python/rhpl/ChangeLog8
-rw-r--r--dev-python/rhpl/rhpl-0.213.ebuild63
2 files changed, 45 insertions, 26 deletions
diff --git a/dev-python/rhpl/ChangeLog b/dev-python/rhpl/ChangeLog
index 59ce4c3e4bea..af83261ce936 100644
--- a/dev-python/rhpl/ChangeLog
+++ b/dev-python/rhpl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/rhpl
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/rhpl/ChangeLog,v 1.14 2009/12/07 13:07:23 djc Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/rhpl/ChangeLog,v 1.15 2010/05/31 18:57:23 arfrever Exp $
+
+ 31 May 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ rhpl-0.213.ebuild:
+ Set SUPPORT_PYTHON_ABIS.
07 Dec 2009; Dirkjan Ochtman <djc@gentoo.org> rhpl-0.213.ebuild,
metadata.xml:
diff --git a/dev-python/rhpl/rhpl-0.213.ebuild b/dev-python/rhpl/rhpl-0.213.ebuild
index e8ba83f41a75..1e3454deab9f 100644
--- a/dev-python/rhpl/rhpl-0.213.ebuild
+++ b/dev-python/rhpl/rhpl-0.213.ebuild
@@ -1,8 +1,13 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/rhpl/rhpl-0.213.ebuild,v 1.6 2009/12/07 13:07:23 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/rhpl/rhpl-0.213.ebuild,v 1.7 2010/05/31 18:57:23 arfrever Exp $
-inherit eutils multilib python rpm toolchain-funcs distutils
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit multilib python rpm toolchain-funcs
# Revision of the RPM. Shouldn't affect us, as we're just grabbing the source
# tarball out of it
@@ -11,39 +16,49 @@ RPMREV="1"
DESCRIPTION="Library of python code used by Red Hat Linux programs"
HOMEPAGE="http://fedoraproject.org/wiki/SystemConfig"
SRC_URI="mirror://fedora-dev/development/source/SRPMS/${P}-${RPMREV}.src.rpm"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE=""
-RDEPEND="dev-lang/python
- !<sys-libs/libkudzu-1.2"
+
+RDEPEND="!<sys-libs/libkudzu-1.2"
DEPEND="${RDEPEND}
!s390? ( >=net-wireless/wireless-tools-28 )
sys-devel/gettext"
-src_unpack() {
- rpm_src_unpack
-# epatch "${FILESDIR}"/${PV}-use-raw-strings-for-gettext.diff
-
- sed -i \
- -e 's:gcc:$(CC):g' \
- "${S}"/src/Makefile
+src_prepare() {
+ sed -e '/compileall/d' -i Makefile || die "sed failed"
+ sed -e 's:gcc:$(CC):g' -i src/Makefile || die "sed failed"
+ python_src_prepare
}
src_compile() {
- python_version
- emake \
- PYTHON=python${PYVER} \
- LIBDIR=$(get_libdir) \
- ARCH=${ARCH} \
- CC=$(tc-getCC) \
- || die "emake failed"
+ building() {
+ emake \
+ PYTHON=$(PYTHON) \
+ LIBDIR=$(get_libdir) \
+ ARCH=${ARCH} \
+ CC=$(tc-getCC)
+ }
+ python_execute_function -s building
}
src_install() {
- emake \
- DESTDIR="${D}" \
- PYTHON=python${PYVER} \
- LIBDIR=$(get_libdir) \
- install || die "emake install failed"
+ installation() {
+ emake \
+ DESTDIR="${ED}" \
+ PYTHON=$(PYTHON) \
+ LIBDIR=$(get_libdir) \
+ install
+ }
+ python_execute_function -s installation
+}
+
+pkg_postinst() {
+ python_mod_optimize rhpl
+}
+
+pkg_postrm() {
+ python_mod_cleanup rhpl
}