summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-01-16 13:52:17 +0000
committerIan Delaney <idella4@gentoo.org>2015-01-16 13:52:17 +0000
commita3203a59f9be5162b63a6222348fb613bd13f324 (patch)
treeb809ff93a987f228a6c8394d769f028fbd8e48e8 /dev-python/restkit
parentStable for all wrt bug #535226 (diff)
downloadgentoo-2-a3203a59f9be5162b63a6222348fb613bd13f324.tar.gz
gentoo-2-a3203a59f9be5162b63a6222348fb613bd13f324.tar.bz2
gentoo-2-a3203a59f9be5162b63a6222348fb613bd13f324.zip
clean old impl, tidy deps, remove disused patch, add patch to prevent duplicate install of data files, rm old
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/restkit')
-rw-r--r--dev-python/restkit/ChangeLog10
-rw-r--r--dev-python/restkit/files/restkit-exclude-tests.patch25
-rw-r--r--dev-python/restkit/files/setup.patch23
-rw-r--r--dev-python/restkit/restkit-4.2.1-r1.ebuild55
-rw-r--r--dev-python/restkit/restkit-4.2.2.ebuild11
5 files changed, 38 insertions, 86 deletions
diff --git a/dev-python/restkit/ChangeLog b/dev-python/restkit/ChangeLog
index fd237580c82f..a4c447a33052 100644
--- a/dev-python/restkit/ChangeLog
+++ b/dev-python/restkit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/restkit
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/restkit/ChangeLog,v 1.18 2014/08/10 21:21:08 slyfox Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/restkit/ChangeLog,v 1.19 2015/01/16 13:52:17 idella4 Exp $
+
+ 16 Jan 2015; Ian Delaney <idella4@gentoo.org> +files/setup.patch,
+ -files/restkit-exclude-tests.patch, -restkit-4.2.1-r1.ebuild,
+ restkit-4.2.2.ebuild:
+ clean old impl, tidy deps, remove disused patch, add patch to prevent
+ duplicate install of data files, rm old
10 Aug 2014; Sergei Trofimovich <slyfox@gentoo.org> restkit-4.2.1-r1.ebuild,
restkit-4.2.2.ebuild:
diff --git a/dev-python/restkit/files/restkit-exclude-tests.patch b/dev-python/restkit/files/restkit-exclude-tests.patch
deleted file mode 100644
index 5347967f5d28..000000000000
--- a/dev-python/restkit/files/restkit-exclude-tests.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 62a02a962f8b6460a379156108bde09f003821af Mon Sep 17 00:00:00 2001
-From: Mike Gilbert <floppym@gentoo.org>
-Date: Tue, 26 Feb 2013 00:43:01 -0500
-Subject: [PATCH] Don't install tests.
-
----
- setup.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/setup.py b/setup.py
-index e6613c0..a6a5505 100755
---- a/setup.py
-+++ b/setup.py
-@@ -53,7 +53,7 @@ def main():
- license = 'MIT',
- url = 'http://benoitc.github.com/restkit',
- classifiers = CLASSIFIERS,
-- packages = find_packages(),
-+ packages = find_packages(exclude=['tests']),
- data_files = DATA_FILES,
- scripts = SCRIPTS,
- zip_safe = False,
---
-1.8.1.4
-
diff --git a/dev-python/restkit/files/setup.patch b/dev-python/restkit/files/setup.patch
new file mode 100644
index 000000000000..cfa8959539e1
--- /dev/null
+++ b/dev-python/restkit/files/setup.patch
@@ -0,0 +1,23 @@
+diff -ur restkit-4.2.2.org/setup.py restkit-4.2.2/setup.py
+--- setup.py 2013-08-30 23:07:36.000000000 +0800
++++ setup.py 2015-01-16 21:38:04.342084550 +0800
+@@ -38,11 +38,6 @@
+ with open(os.path.join(os.path.dirname(__file__), 'README.rst')) as f:
+ long_description = f.read()
+
+- DATA_FILES = [
+- ('restkit', ["LICENSE", "MANIFEST.in", "NOTICE", "README.rst",
+- "THANKS", "TODO.txt"])
+- ]
+-
+ options=dict(
+ name = 'restkit',
+ version = version.__version__,
+@@ -54,7 +49,6 @@
+ url = 'http://benoitc.github.com/restkit',
+ classifiers = CLASSIFIERS,
+ packages = find_packages(exclude=['tests']),
+- data_files = DATA_FILES,
+ scripts = SCRIPTS,
+ zip_safe = False,
+ entry_points = {
diff --git a/dev-python/restkit/restkit-4.2.1-r1.ebuild b/dev-python/restkit/restkit-4.2.1-r1.ebuild
deleted file mode 100644
index ff33bf1f3d82..000000000000
--- a/dev-python/restkit/restkit-4.2.1-r1.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/restkit/restkit-4.2.1-r1.ebuild,v 1.8 2014/08/10 21:21:08 slyfox Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7} pypy pypy2_0 )
-
-inherit distutils-r1
-
-DESCRIPTION="A HTTP ressource kit for Python"
-HOMEPAGE="http://github.com/benoitc/restkit http://benoitc.github.com/restkit/ http://pypi.python.org/pypi/restkit"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
-IUSE="+cli doc examples test"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx
- dev-python/epydoc )
- test? ( dev-python/webob
- >=dev-python/socketpool-0.5.0
- >=dev-python/http-parser-0.7.7 )"
-RDEPEND="cli? ( dev-python/ipython
- dev-python/setuptools[${PYTHON_USEDEP}] )
- dev-python/webob
- >=dev-python/socketpool-0.5.0
- >=dev-python/http-parser-0.7.7"
-
-PATCHES=( "${FILESDIR}/${PN}-exclude-tests.patch" )
-
-python_compile_all() {
- if use doc ; then
- pushd doc > /dev/null
- PYTHONPATH="${S}" emake html
- popd > /dev/null
- fi
-}
-
-python_test() {
- nosetests -v tests || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- use cli || rm "${ED}"/usr/bin/restcli*
-
- use doc && dohtml -r doc/_build/html/
- if use examples ; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
- distutils-r1_python_install_all
-}
diff --git a/dev-python/restkit/restkit-4.2.2.ebuild b/dev-python/restkit/restkit-4.2.2.ebuild
index 994920bb7e0d..9d53d9c7b99b 100644
--- a/dev-python/restkit/restkit-4.2.2.ebuild
+++ b/dev-python/restkit/restkit-4.2.2.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/restkit/restkit-4.2.2.ebuild,v 1.3 2014/08/10 21:21:08 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/restkit/restkit-4.2.2.ebuild,v 1.4 2015/01/16 13:52:17 idella4 Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7} pypy )
+PYTHON_COMPAT=( python2_7 pypy )
inherit distutils-r1
@@ -17,7 +17,7 @@ SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
IUSE="+cli doc examples test"
-PY27_USEDEP="$(python_gen_usedep 'python2*')"
+PY27_USEDEP="$(python_gen_usedep python2_7)"
RDEPEND="cli? ( dev-python/ipython[${PY27_USEDEP}] )
dev-python/webob[${PYTHON_USEDEP}]
>=dev-python/socketpool-0.5.3[${PYTHON_USEDEP}]
@@ -28,6 +28,9 @@ DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
test? ( ${RDEPEND}
dev-python/nose[${PYTHON_USEDEP}] )"
+# prevent duplicate install of data files
+PATCHES=( "${FILESDIR}"/setup.patch )
+
python_compile_all() {
if use doc ; then
pushd doc > /dev/null