summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2012-09-07 18:47:02 +0000
committerMike Gilbert <floppym@gentoo.org>2012-09-07 18:47:02 +0000
commit208cbe4f6480f9056c715111609ae24e3e0947dd (patch)
treef30124ce299b154c5e5e7a53fbc5c782c0be28f3 /dev-python/requests
parent[net-irc/inspircd] Cleanup of old versions (diff)
downloadgentoo-2-208cbe4f6480f9056c715111609ae24e3e0947dd.tar.gz
gentoo-2-208cbe4f6480f9056c715111609ae24e3e0947dd.tar.bz2
gentoo-2-208cbe4f6480f9056c715111609ae24e3e0947dd.zip
Version bump.
(Portage version: 2.2.0_alpha124/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/requests')
-rw-r--r--dev-python/requests/ChangeLog7
-rw-r--r--dev-python/requests/requests-0.14.0.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/dev-python/requests/ChangeLog b/dev-python/requests/ChangeLog
index e08a49c5a362..31b640ca025b 100644
--- a/dev-python/requests/ChangeLog
+++ b/dev-python/requests/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/requests
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/requests/ChangeLog,v 1.19 2012/09/02 20:16:40 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/requests/ChangeLog,v 1.20 2012/09/07 18:47:02 floppym Exp $
+
+*requests-0.14.0 (07 Sep 2012)
+
+ 07 Sep 2012; Mike Gilbert <floppym@gentoo.org> +requests-0.14.0.ebuild:
+ Version bump.
02 Sep 2012; Tim Harder <radhermit@gentoo.org> -requests-0.10.6.ebuild,
-requests-0.11.1.ebuild, -requests-0.12.1.ebuild, -requests-0.12.1-r1.ebuild:
diff --git a/dev-python/requests/requests-0.14.0.ebuild b/dev-python/requests/requests-0.14.0.ebuild
new file mode 100644
index 000000000000..462a1a8c6132
--- /dev/null
+++ b/dev-python/requests/requests-0.14.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/requests/requests-0.14.0.ebuild,v 1.1 2012/09/07 18:47:02 floppym Exp $
+
+EAPI="4"
+PYTHON_DEPEND="*:2.6"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 2.5"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils
+
+DESCRIPTION="HTTP library for human beings"
+HOMEPAGE="http://python-requests.org/ http://pypi.python.org/pypi/requests"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools"
+
+DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES=1
+
+src_prepare() {
+ # Different packages are installed depending on the python version.
+ # Need to remove stale egg-info data and build in separate directories.
+ rm -r requests.egg-info || die
+
+ distutils_src_prepare
+}
+
+src_test() {
+ echoit() { echo "$@"; "$@"; }
+ testing() {
+ echoit nosetests --verbosity=1 tests/*.py
+ }
+ python_execute_function testing
+}