summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-01-23 21:06:43 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-01-23 21:06:43 +0000
commitdac9d24e860f14201fd39bd813aea20679173e13 (patch)
treed459b933440608234122c6134e07b0fb1bc9f1e8 /dev-python/reportlab/reportlab-2.4.ebuild
parentrm (diff)
downloadgentoo-2-dac9d24e860f14201fd39bd813aea20679173e13.tar.gz
gentoo-2-dac9d24e860f14201fd39bd813aea20679173e13.tar.bz2
gentoo-2-dac9d24e860f14201fd39bd813aea20679173e13.zip
Version bump.
(Portage version: 15206-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/reportlab/reportlab-2.4.ebuild')
-rw-r--r--dev-python/reportlab/reportlab-2.4.ebuild76
1 files changed, 76 insertions, 0 deletions
diff --git a/dev-python/reportlab/reportlab-2.4.ebuild b/dev-python/reportlab/reportlab-2.4.ebuild
new file mode 100644
index 000000000000..20673869555f
--- /dev/null
+++ b/dev-python/reportlab/reportlab-2.4.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/reportlab/reportlab-2.4.ebuild,v 1.1 2010/01/23 21:06:43 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils versionator
+
+MY_PN="ReportLab"
+MY_PV="$(replace_all_version_separators _)"
+
+DESCRIPTION="Tools for generating printable PDF documents from any data source."
+HOMEPAGE="http://www.reportlab.org/ http://pypi.python.org/pypi/reportlab"
+SRC_URI="http://www.reportlab.org/ftp/${MY_PN}_${MY_PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc examples test"
+
+DEPEND="dev-python/imaging
+ media-fonts/ttf-bitstream-vera
+ media-libs/libart_lgpl
+ sys-libs/zlib"
+RDEPEND="${DEPEND}"
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}/${MY_PN}_${MY_PV}"
+
+src_prepare() {
+ sed -i \
+ -e 's|/usr/lib/X11/fonts/TrueType/|/usr/share/fonts/ttf-bitstream-vera/|' \
+ -e 's|/usr/local/Acrobat|/opt/Acrobat|g' \
+ -e 's|%(HOME)s/fonts|%(HOME)s/.fonts|g' \
+ src/reportlab/rl_config.py || die "sed failed"
+ epatch "${FILESDIR}/${PN}-2.2_qa_msg.patch"
+
+ rm -fr src/rl_addons/renderPM/libart_lgpl
+ epatch "${FILESDIR}/${P}-external_libart_lgpl.patch"
+}
+
+src_compile() {
+ distutils_src_compile
+
+ # One of tests already builds documentation.
+ if use doc && ! use test; then
+ cd docs
+ PYTHONPATH="$(ls -d ../build-$(PYTHON -f --ABI)/lib.*)" "$(PYTHON -f)" genAll.py || die "genAll.py failed"
+ fi
+}
+
+src_test() {
+ testing() {
+ "$(PYTHON)" setup.py tests-preinstall
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ # docs/reference/reportlab-reference.pdf is identical with docs/reportlab-reference.pdf
+ rm -f docs/reference/reportlab-reference.pdf
+
+ insinto /usr/share/doc/${PF}
+ doins -r docs/*
+ fi
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r demos
+ insinto /usr/share/doc/${PF}/tools/pythonpoint
+ doins -r tools/pythonpoint/demos
+ fi
+}