summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2015-02-28 07:35:47 +0000
committerPatrick Lauer <patrick@gentoo.org>2015-02-28 07:35:47 +0000
commitfe589991d67641129d1a8ec710b53caa9990c201 (patch)
tree4317faadbf34a7481079a9abce0ff840f630e528 /dev-python/rdflib
parentBump (diff)
downloadgentoo-2-fe589991d67641129d1a8ec710b53caa9990c201.tar.gz
gentoo-2-fe589991d67641129d1a8ec710b53caa9990c201.tar.bz2
gentoo-2-fe589991d67641129d1a8ec710b53caa9990c201.zip
Bump
(Portage version: 2.2.17/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/rdflib')
-rw-r--r--dev-python/rdflib/ChangeLog7
-rw-r--r--dev-python/rdflib/rdflib-4.2.0.ebuild62
2 files changed, 68 insertions, 1 deletions
diff --git a/dev-python/rdflib/ChangeLog b/dev-python/rdflib/ChangeLog
index 89e6e9fea930..863a682d9058 100644
--- a/dev-python/rdflib/ChangeLog
+++ b/dev-python/rdflib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/rdflib
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/rdflib/ChangeLog,v 1.51 2015/02/02 14:42:20 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/rdflib/ChangeLog,v 1.52 2015/02/28 07:35:47 patrick Exp $
+
+*rdflib-4.2.0 (28 Feb 2015)
+
+ 28 Feb 2015; Patrick Lauer <patrick@gentoo.org> +rdflib-4.2.0.ebuild:
+ Bump
02 Feb 2015; Manuel Rüger <mrueg@gentoo.org> -rdflib-3.2.3.ebuild:
Remove old.
diff --git a/dev-python/rdflib/rdflib-4.2.0.ebuild b/dev-python/rdflib/rdflib-4.2.0.ebuild
new file mode 100644
index 000000000000..f000bacba040
--- /dev/null
+++ b/dev-python/rdflib/rdflib-4.2.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/rdflib/rdflib-4.2.0.ebuild,v 1.1 2015/02/28 07:35:47 patrick Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE="sqlite?"
+DISTUTILS_NO_PARALLEL_BUILD=true
+# The usual required for tests
+DISTUTILS_IN_SOURCE_BUILD=1
+
+inherit distutils-r1
+
+DESCRIPTION="RDF library containing a triple store and parser/serializer"
+HOMEPAGE="https://github.com/RDFLib/rdflib http://pypi.python.org/pypi/rdflib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="berkdb examples mysql redland sqlite test"
+
+RDEPEND="
+ dev-python/isodate[${PYTHON_USEDEP}]
+ dev-python/html5lib[$(python_gen_usedep 'python2*')]
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+ berkdb? ( dev-python/bsddb3[${PYTHON_USEDEP}] )
+ mysql? ( dev-python/mysql-python[$(python_gen_usedep 'python2*')] )
+ redland? ( dev-libs/redland-bindings[python,$(python_gen_usedep 'python2*')] )"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/sparql-wrapper[${PYTHON_USEDEP}]
+ >=dev-python/nose-1.3.1-r1[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # Upstream manufactured .pyc files which promptly break distutils' src_test
+ find -name "*.py[oc~]" -delete || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ if python_is_python3; then
+ pushd "${BUILD_DIR}/src/" > /dev/null
+ if [[ "${EPYTHON}" == 'python3.4' ]]; then
+ sed -e 's:test_rdfpipe_bytes_vs_str:_&:' \
+ -e 's:test_rdfpipe_mdata_open:_&:' \
+ -i test/test_issue375.py || die
+ sed -e 's:testHTML:_&:' \
+ -i test/test_xmlliterals.py || die
+ fi
+ "${PYTHON}" ./run_tests.py || die "Tests failed under ${EPYTHON}"
+ popd > /dev/null
+ else
+ "${PYTHON}" ./run_tests.py || die "Tests failed under ${EPYTHON}"
+ fi
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}