summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-11-18 05:02:42 +0000
committerIan Delaney <idella4@gentoo.org>2014-11-18 05:02:42 +0000
commit0ee019b9d01a6c245f3195174810146fa42fff8a (patch)
tree87904a2118637d9186401b125d32c39f2b808299 /dev-python/rdflib
parentBump (diff)
downloadgentoo-2-0ee019b9d01a6c245f3195174810146fa42fff8a.tar.gz
gentoo-2-0ee019b9d01a6c245f3195174810146fa42fff8a.tar.bz2
gentoo-2-0ee019b9d01a6c245f3195174810146fa42fff8a.zip
drop py3.2, rm old
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/rdflib')
-rw-r--r--dev-python/rdflib/ChangeLog8
-rw-r--r--dev-python/rdflib/rdflib-3.1.0.ebuild47
-rw-r--r--dev-python/rdflib/rdflib-3.2.1.ebuild41
-rw-r--r--dev-python/rdflib/rdflib-3.2.2.ebuild41
-rw-r--r--dev-python/rdflib/rdflib-4.0.1.ebuild48
-rw-r--r--dev-python/rdflib/rdflib-4.0.ebuild48
-rw-r--r--dev-python/rdflib/rdflib-4.1.0.ebuild48
-rw-r--r--dev-python/rdflib/rdflib-4.1.1.ebuild55
-rw-r--r--dev-python/rdflib/rdflib-4.1.2.ebuild4
9 files changed, 9 insertions, 331 deletions
diff --git a/dev-python/rdflib/ChangeLog b/dev-python/rdflib/ChangeLog
index df7d9980bfee..d45f0032f600 100644
--- a/dev-python/rdflib/ChangeLog
+++ b/dev-python/rdflib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/rdflib
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/rdflib/ChangeLog,v 1.46 2014/08/13 17:47:38 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/rdflib/ChangeLog,v 1.47 2014/11/18 05:02:42 idella4 Exp $
+
+ 18 Nov 2014; Ian Delaney <idella4@gentoo.org> -rdflib-3.1.0.ebuild,
+ -rdflib-3.2.1.ebuild, -rdflib-3.2.2.ebuild, -rdflib-4.0.1.ebuild,
+ -rdflib-4.0.ebuild, -rdflib-4.1.0.ebuild, -rdflib-4.1.1.ebuild,
+ rdflib-4.1.2.ebuild:
+ drop py3.2, rm old
13 Aug 2014; Anthony G. Basile <blueness@gentoo.org> rdflib-4.0.1.ebuild,
rdflib-4.1.0.ebuild, rdflib-4.1.1.ebuild, rdflib-4.1.2.ebuild:
diff --git a/dev-python/rdflib/rdflib-3.1.0.ebuild b/dev-python/rdflib/rdflib-3.1.0.ebuild
deleted file mode 100644
index e43e3dc00702..000000000000
--- a/dev-python/rdflib/rdflib-3.1.0.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/rdflib/rdflib-3.1.0.ebuild,v 1.4 2012/10/07 00:46:43 floppym Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-pypy-*"
-
-inherit distutils eutils
-
-DESCRIPTION="RDF library containing a triple store and parser/serializer"
-HOMEPAGE="https://github.com/RDFLib/rdflib http://pypi.python.org/pypi/rdflib"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~x86-linux"
-IUSE="berkdb examples mysql redland sqlite test"
-
-RDEPEND="berkdb? ( dev-python/bsddb3 )
- mysql? ( dev-python/mysql-python )
- redland? ( dev-libs/redland-bindings[python] )
- sqlite? ( || ( dev-lang/python:2.7[sqlite] dev-lang/python:2.6[sqlite] dev-lang/python:2.5[sqlite] dev-python/pysqlite ) )"
-DEPEND="${RDEPEND}
- test? ( dev-python/nose )"
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-test.patch
- distutils_src_prepare
-}
-
-src_test() {
- testing() {
- PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib)" "$(PYTHON)" run_tests.py
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
-
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins -r examples/* || die "Installation of examples failed"
- fi
-}
diff --git a/dev-python/rdflib/rdflib-3.2.1.ebuild b/dev-python/rdflib/rdflib-3.2.1.ebuild
deleted file mode 100644
index e1b803e62989..000000000000
--- a/dev-python/rdflib/rdflib-3.2.1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/rdflib/rdflib-3.2.1.ebuild,v 1.2 2012/10/07 00:46:43 floppym Exp $
-
-EAPI=4
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="*-pypy-*"
-DISTUTILS_SRC_TEST=nosetests
-
-inherit distutils
-
-DESCRIPTION="RDF library containing a triple store and parser/serializer"
-HOMEPAGE="https://github.com/RDFLib/rdflib http://pypi.python.org/pypi/rdflib"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="berkdb examples mysql redland sqlite"
-
-RDEPEND="dev-python/isodate
- berkdb? ( dev-python/bsddb3 )
- mysql? ( dev-python/mysql-python )
- redland? ( dev-libs/redland-bindings[python] )
- sqlite? ( || ( dev-lang/python:2.7[sqlite] dev-lang/python:2.6[sqlite]
- dev-lang/python:2.5[sqlite] dev-python/pysqlite ) )"
-DEPEND="${RDEPEND}
- dev-python/setuptools"
-
-src_test() {
- distutils_src_test --py3where='build/src'
-}
-
-src_install() {
- distutils_src_install
-
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins -r examples/*
- fi
-}
diff --git a/dev-python/rdflib/rdflib-3.2.2.ebuild b/dev-python/rdflib/rdflib-3.2.2.ebuild
deleted file mode 100644
index 7db61a5882c6..000000000000
--- a/dev-python/rdflib/rdflib-3.2.2.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/rdflib/rdflib-3.2.2.ebuild,v 1.2 2012/10/07 00:46:43 floppym Exp $
-
-EAPI="4"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="*-pypy-*"
-DISTUTILS_SRC_TEST="nosetests"
-
-inherit distutils
-
-DESCRIPTION="RDF library containing a triple store and parser/serializer"
-HOMEPAGE="https://github.com/RDFLib/rdflib http://pypi.python.org/pypi/rdflib"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="berkdb examples mysql redland sqlite"
-
-RDEPEND="dev-python/isodate
- berkdb? ( dev-python/bsddb3 )
- mysql? ( dev-python/mysql-python )
- redland? ( dev-libs/redland-bindings[python] )
- sqlite? ( || ( dev-lang/python:2.7[sqlite] dev-lang/python:2.6[sqlite]
- dev-lang/python:2.5[sqlite] dev-python/pysqlite ) )"
-DEPEND="${RDEPEND}
- dev-python/setuptools"
-
-src_test() {
- distutils_src_test --py3where='build/src'
-}
-
-src_install() {
- distutils_src_install
-
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins -r examples/*
- fi
-}
diff --git a/dev-python/rdflib/rdflib-4.0.1.ebuild b/dev-python/rdflib/rdflib-4.0.1.ebuild
deleted file mode 100644
index f2c2b3de8d8a..000000000000
--- a/dev-python/rdflib/rdflib-4.0.1.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/rdflib/rdflib-4.0.1.ebuild,v 1.5 2014/08/13 17:47:38 blueness Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
-PYTHON_REQ_USE="sqlite?"
-DISTUTILS_NO_PARALLEL_BUILD=true
-
-inherit distutils-r1
-
-DESCRIPTION="RDF library containing a triple store and parser/serializer"
-HOMEPAGE="https://github.com/RDFLib/rdflib http://pypi.python.org/pypi/rdflib"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="berkdb examples mysql redland sqlite test"
-
-RDEPEND="
- dev-python/isodate[${PYTHON_USEDEP}]
- dev-python/html5lib[$(python_gen_usedep 'python2*')]
- dev-python/pyparsing[${PYTHON_USEDEP}]
- berkdb? ( dev-python/bsddb3[${PYTHON_USEDEP}] )
- mysql? ( dev-python/mysql-python[$(python_gen_usedep 'python2*')] )
- redland? ( dev-libs/redland-bindings[python] )"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/sparql-wrapper[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
- # Upstream manufactured .pyc files which promptly break distutils' src_test
- find -name "*.py[oc~]" -delete || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- https://github.com/RDFLib/rdflib/issues/306
- PYTHONPATH=. nosetests --verbosity=3 --py3where='build/src' || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use examples && local EXAMPLES=( examples/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/rdflib/rdflib-4.0.ebuild b/dev-python/rdflib/rdflib-4.0.ebuild
deleted file mode 100644
index d051d0a2ffd5..000000000000
--- a/dev-python/rdflib/rdflib-4.0.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/rdflib/rdflib-4.0.ebuild,v 1.2 2013/09/06 16:19:17 floppym Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
-PYTHON_USE_WITH="sqlite?"
-DISTUTILS_NO_PARALLEL_BUILD=true
-
-inherit distutils-r1
-
-DESCRIPTION="RDF library containing a triple store and parser/serializer"
-HOMEPAGE="https://github.com/RDFLib/rdflib http://pypi.python.org/pypi/rdflib"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE="berkdb examples mysql redland sqlite test"
-
-RDEPEND="
- dev-python/isodate[${PYTHON_USEDEP}]
- berkdb? ( dev-python/bsddb3 )
- mysql? ( dev-python/mysql-python[$(python_gen_usedep 'python2*')] )
- redland? ( dev-libs/redland-bindings[python] )"
-DEPEND="${RDEPEND}
- dev-python/setuptools
- test? ( dev-python/sparql-wrapper[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
- # Upstream manufactured .pyc files which promptly break distutils' src_test
- find -name "*.py[oc~]" -delete || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- nosetests --verbosity=3 --py3where='build/src' || die
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins -r examples/*
- fi
-}
diff --git a/dev-python/rdflib/rdflib-4.1.0.ebuild b/dev-python/rdflib/rdflib-4.1.0.ebuild
deleted file mode 100644
index 8792e55bfa3e..000000000000
--- a/dev-python/rdflib/rdflib-4.1.0.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/rdflib/rdflib-4.1.0.ebuild,v 1.2 2014/08/13 17:47:38 blueness Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
-PYTHON_REQ_USE="sqlite?"
-DISTUTILS_NO_PARALLEL_BUILD=true
-
-inherit distutils-r1
-
-DESCRIPTION="RDF library containing a triple store and parser/serializer"
-HOMEPAGE="https://github.com/RDFLib/rdflib http://pypi.python.org/pypi/rdflib"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="berkdb examples mysql redland sqlite test"
-
-RDEPEND="
- dev-python/isodate[${PYTHON_USEDEP}]
- dev-python/html5lib[$(python_gen_usedep 'python2*')]
- dev-python/pyparsing[${PYTHON_USEDEP}]
- berkdb? ( dev-python/bsddb3[${PYTHON_USEDEP}] )
- mysql? ( dev-python/mysql-python[$(python_gen_usedep 'python2*')] )
- redland? ( dev-libs/redland-bindings[python] )"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/sparql-wrapper[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
- # Upstream manufactured .pyc files which promptly break distutils' src_test
- find -name "*.py[oc~]" -delete || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- https://github.com/RDFLib/rdflib/issues/306
- PYTHONPATH=. nosetests --verbosity=3 --py3where='build/src' || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use examples && local EXAMPLES=( examples/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/rdflib/rdflib-4.1.1.ebuild b/dev-python/rdflib/rdflib-4.1.1.ebuild
deleted file mode 100644
index 21042dcdac10..000000000000
--- a/dev-python/rdflib/rdflib-4.1.1.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/rdflib/rdflib-4.1.1.ebuild,v 1.2 2014/08/13 17:47:38 blueness Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
-PYTHON_REQ_USE="sqlite?"
-DISTUTILS_NO_PARALLEL_BUILD=true
-# The usual required for tests
-DISTUTILS_IN_SOURCE_BUILD=1
-
-inherit distutils-r1
-
-DESCRIPTION="RDF library containing a triple store and parser/serializer"
-HOMEPAGE="https://github.com/RDFLib/rdflib http://pypi.python.org/pypi/rdflib"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="berkdb examples mysql redland sqlite test"
-
-RDEPEND="
- dev-python/isodate[${PYTHON_USEDEP}]
- dev-python/html5lib[$(python_gen_usedep 'python2*')]
- dev-python/pyparsing[${PYTHON_USEDEP}]
- berkdb? ( dev-python/bsddb3[${PYTHON_USEDEP}] )
- mysql? ( dev-python/mysql-python[$(python_gen_usedep 'python2*')] )
- redland? ( dev-libs/redland-bindings[python] )"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/sparql-wrapper[${PYTHON_USEDEP}]
- >=dev-python/nose-1.3.1-r1[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
- # Upstream manufactured .pyc files which promptly break distutils' src_test
- find -name "*.py[oc~]" -delete || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- if python_is_python3; then
- pushd "${BUILD_DIR}/src/" > /dev/null
- "${PYTHON}" ./run_tests.py || die "Tests failed under ${EPYTHON}"
- popd > /dev/null
- else
- "${PYTHON}" ./run_tests.py || die "Tests failed under ${EPYTHON}"
- fi
-}
-
-python_install_all() {
- use examples && local EXAMPLES=( examples/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/rdflib/rdflib-4.1.2.ebuild b/dev-python/rdflib/rdflib-4.1.2.ebuild
index 97b25373f26e..f8cfd7f71e0a 100644
--- a/dev-python/rdflib/rdflib-4.1.2.ebuild
+++ b/dev-python/rdflib/rdflib-4.1.2.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/rdflib/rdflib-4.1.2.ebuild,v 1.5 2014/08/13 17:47:38 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/rdflib/rdflib-4.1.2.ebuild,v 1.6 2014/11/18 05:02:42 idella4 Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} )
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
PYTHON_REQ_USE="sqlite?"
DISTUTILS_NO_PARALLEL_BUILD=true
# The usual required for tests