summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-02 05:32:25 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-02 05:32:25 +0000
commitc03ed28fe9b9270d3e664185997cff82e6d25697 (patch)
treed8b9a8045f44ab09d915bf1caa2928416efcb7ed /dev-python/qscintilla-python
parentFix typo. (diff)
downloadgentoo-2-c03ed28fe9b9270d3e664185997cff82e6d25697.tar.gz
gentoo-2-c03ed28fe9b9270d3e664185997cff82e6d25697.tar.bz2
gentoo-2-c03ed28fe9b9270d3e664185997cff82e6d25697.zip
Set SUPPORT_PYTHON_ABIS.
(Portage version: 13874-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/qscintilla-python')
-rw-r--r--dev-python/qscintilla-python/ChangeLog6
-rw-r--r--dev-python/qscintilla-python/qscintilla-python-2.4.ebuild37
2 files changed, 29 insertions, 14 deletions
diff --git a/dev-python/qscintilla-python/ChangeLog b/dev-python/qscintilla-python/ChangeLog
index 6be7df393161..e26de151259c 100644
--- a/dev-python/qscintilla-python/ChangeLog
+++ b/dev-python/qscintilla-python/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/qscintilla-python
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/qscintilla-python/ChangeLog,v 1.35 2009/07/02 20:31:43 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/qscintilla-python/ChangeLog,v 1.36 2009/08/02 05:32:25 arfrever Exp $
+
+ 02 Aug 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ qscintilla-python-2.4.ebuild:
+ Set SUPPORT_PYTHON_ABIS.
02 Jul 2009; Markus Meier <maekke@gentoo.org>
qscintilla-python-2.3.2-r2.ebuild:
diff --git a/dev-python/qscintilla-python/qscintilla-python-2.4.ebuild b/dev-python/qscintilla-python/qscintilla-python-2.4.ebuild
index 486c1caf7cdc..c141d64951f0 100644
--- a/dev-python/qscintilla-python/qscintilla-python-2.4.ebuild
+++ b/dev-python/qscintilla-python/qscintilla-python-2.4.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/qscintilla-python/qscintilla-python-2.4.ebuild,v 1.3 2009/06/26 22:09:59 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/qscintilla-python/qscintilla-python-2.4.ebuild,v 1.4 2009/08/02 05:32:25 arfrever Exp $
EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
inherit eutils multilib python toolchain-funcs
@@ -27,26 +28,36 @@ S="${WORKDIR}/${MY_P}/Python"
src_prepare() {
epatch "${FILESDIR}/${PN}-2.4-nostrip.patch"
+
+ python_copy_sources
}
src_configure() {
- python_version
-
- local myconf="${python} configure.py
- --destdir=$(python_get_sitedir)/PyQt$(use qt4 && echo 4)
- -n /usr/include
- -o /usr/$(get_libdir)
- -p $(use qt4 && echo 4 || echo 3)
- $(use debug && echo '--debug')"
- echo ${myconf}
- ${myconf} || die "configuration failed"
+ configure_package() {
+ local myconf="$(get_python) configure.py
+ --destdir=$(python_get_sitedir)/PyQt$(use qt4 && echo 4)
+ -n /usr/include
+ -o /usr/$(get_libdir)
+ -p $(use qt4 && echo 4 || echo 3)
+ $(use debug && echo '--debug')"
+ echo ${myconf}
+ ${myconf}
+ }
+ python_execute_function -s configure_package
}
src_compile() {
- emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" LINK="$(tc-getCXX)" || die "emake failed"
+ build_package() {
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" LINK="$(tc-getCXX)"
+ }
+ python_execute_function -s build_package
}
src_install() {
python_need_rebuild
- emake DESTDIR="${D}" install || die "emake install failed"
+
+ install_package() {
+ emake DESTDIR="${D}" install
+ }
+ python_execute_function -s install_package
}