summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2009-09-30 20:01:59 +0000
committerBen de Groot <yngwin@gentoo.org>2009-09-30 20:01:59 +0000
commit941847de7d626b6893c468afcc46b19a4c9e3367 (patch)
tree8ab24b8632345aac4b3863119cd3a453e22dd028 /dev-python/qscintilla-python
parentamd64 stable wrt #282290 (diff)
downloadgentoo-2-941847de7d626b6893c468afcc46b19a4c9e3367.tar.gz
gentoo-2-941847de7d626b6893c468afcc46b19a4c9e3367.tar.bz2
gentoo-2-941847de7d626b6893c468afcc46b19a4c9e3367.zip
Remove old
(Portage version: 2.2_rc42/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/qscintilla-python')
-rw-r--r--dev-python/qscintilla-python/ChangeLog6
-rw-r--r--dev-python/qscintilla-python/qscintilla-python-2.3.2-r1.ebuild52
-rw-r--r--dev-python/qscintilla-python/qscintilla-python-2.3.2.ebuild65
3 files changed, 5 insertions, 118 deletions
diff --git a/dev-python/qscintilla-python/ChangeLog b/dev-python/qscintilla-python/ChangeLog
index 41e5edd13e54..7fb67ddd2803 100644
--- a/dev-python/qscintilla-python/ChangeLog
+++ b/dev-python/qscintilla-python/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/qscintilla-python
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/qscintilla-python/ChangeLog,v 1.42 2009/09/27 18:27:32 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/qscintilla-python/ChangeLog,v 1.43 2009/09/30 20:01:59 yngwin Exp $
+
+ 30 Sep 2009; Ben de Groot <yngwin@gentoo.org>
+ -qscintilla-python-2.3.2.ebuild, -qscintilla-python-2.3.2-r1.ebuild:
+ Remove old
27 Sep 2009; nixnut <nixnut@gentoo.org> qscintilla-python-2.4.ebuild:
ppc stable #284707
diff --git a/dev-python/qscintilla-python/qscintilla-python-2.3.2-r1.ebuild b/dev-python/qscintilla-python/qscintilla-python-2.3.2-r1.ebuild
deleted file mode 100644
index 4a96ad7b8651..000000000000
--- a/dev-python/qscintilla-python/qscintilla-python-2.3.2-r1.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/qscintilla-python/qscintilla-python-2.3.2-r1.ebuild,v 1.4 2009/06/17 13:12:16 fauli Exp $
-
-EAPI="2"
-
-inherit eutils python
-
-MY_PN="qscintilla"
-MY_P="${MY_PN/qs/QS}-gpl-${PV}"
-
-DESCRIPTION="Python bindings for Qscintilla"
-HOMEPAGE="http://www.riverbankcomputing.co.uk/software/qscintilla/intro"
-SRC_URI="http://www.riverbankcomputing.com/static/Downloads/QScintilla2/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 hppa ~ia64 ~ppc ~ppc64 ~sparc x86 ~x86-fbsd"
-IUSE="qt4"
-
-DEPEND=">=dev-python/sip-4.4
- =x11-libs/qscintilla-${PV}*[qt4=]
- qt4? ( >=dev-python/PyQt4-4.4 )
- !qt4? ( >=dev-python/PyQt-3.17.6 )"
-RDEPEND="${DEPEND}"
-
-S=${WORKDIR}/${MY_P}/Python
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-2.2-nostrip.patch
-}
-
-src_configure() {
- local myconf="-o /usr/lib -n /usr/include"
- if use qt4; then
- myconf="${myconf} -p 4"
- else
- myconf="${myconf} -p 3"
- fi
-
- python_version
- ${python} configure.py ${myconf} || die "configure.py failed"
-}
-
-src_compile() {
- emake || die "emake failed"
-}
-
-src_install() {
- python_need_rebuild
- emake DESTDIR="${D}" install || die "emake install failed"
-}
diff --git a/dev-python/qscintilla-python/qscintilla-python-2.3.2.ebuild b/dev-python/qscintilla-python/qscintilla-python-2.3.2.ebuild
deleted file mode 100644
index 7777028e988f..000000000000
--- a/dev-python/qscintilla-python/qscintilla-python-2.3.2.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/qscintilla-python/qscintilla-python-2.3.2.ebuild,v 1.9 2009/02/20 17:53:11 jer Exp $
-
-inherit eutils python
-
-MY_PN="qscintilla"
-MY_P="${MY_PN/qs/QS}-gpl-${PV}"
-
-DESCRIPTION="Python bindings for Qscintilla"
-HOMEPAGE="http://www.riverbankcomputing.co.uk/software/qscintilla/intro"
-SRC_URI="http://www.riverbankcomputing.com/static/Downloads/QScintilla2/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="qt4"
-
-DEPEND=">=dev-python/sip-4.4
- =x11-libs/qscintilla-${PV}*
- qt4? ( >=dev-python/PyQt4-4.4 )
- !qt4? ( >=dev-python/PyQt-3.17.6 )"
-RDEPEND="${DEPEND}"
-
-S=${WORKDIR}/${MY_P}/Python
-
-pkg_setup() {
- # this package needs to have same qt flags with qscintilla.
- if use qt4; then
- if ! built_with_use 'x11-libs/qscintilla' 'qt4'; then
- eerror "Please build qscintilla with qt4 useflag."
- die "qscintilla built without qt4."
- fi
- else
- if built_with_use 'x11-libs/qscintilla' 'qt4'; then
- eerror "Please build qscintilla without qt4 useflag."
- die "qscintilla built with qt4"
- fi
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}"/${PN}-2.2-nostrip.patch
-}
-
-src_compile() {
- local myconf="-o /usr/lib -n /usr/include"
- if use qt4; then
- myconf="${myconf} -p 4"
- else
- myconf="${myconf} -p 3"
- fi
-
- python_version
- ${python} configure.py ${myconf} || die "configure.py failed"
- emake || die "emake failed"
-}
-
-src_install() {
- python_need_rebuild
- emake DESTDIR="${D}" install || die "emake install failed"
-}