summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2009-01-05 07:43:11 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2009-01-05 07:43:11 +0000
commitc4e6bfaa3e66a11a20c53d29b88bc3fabeb3a1f7 (patch)
treef1c82045b67ad58a3202c38db8191d3e02c10871 /dev-python/pyzor
parentftp://cudlug.cudenver.edu removal because it hasn't worked in a very long tim... (diff)
downloadgentoo-2-c4e6bfaa3e66a11a20c53d29b88bc3fabeb3a1f7.tar.gz
gentoo-2-c4e6bfaa3e66a11a20c53d29b88bc3fabeb3a1f7.tar.bz2
gentoo-2-c4e6bfaa3e66a11a20c53d29b88bc3fabeb3a1f7.zip
Switch to using the debian tarball and patchset, fixes the native Digest functionality of pyzor.
(Portage version: 2.2_rc20/cvs/Linux 2.6.26-hardened-r4 x86_64)
Diffstat (limited to 'dev-python/pyzor')
-rw-r--r--dev-python/pyzor/ChangeLog10
-rw-r--r--dev-python/pyzor/pyzor-0.4.0-r4.ebuild81
2 files changed, 89 insertions, 2 deletions
diff --git a/dev-python/pyzor/ChangeLog b/dev-python/pyzor/ChangeLog
index 6efce6456aa4..19db37305a7c 100644
--- a/dev-python/pyzor/ChangeLog
+++ b/dev-python/pyzor/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pyzor
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyzor/ChangeLog,v 1.40 2008/08/06 19:13:20 neurogeek Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyzor/ChangeLog,v 1.41 2009/01/05 07:43:11 robbat2 Exp $
+
+*pyzor-0.4.0-r4 (05 Jan 2009)
+
+ 05 Jan 2009; Robin H. Johnson <robbat2@gentoo.org> +pyzor-0.4.0-r4.ebuild:
+ Switch to using the debian tarball and patchset, fixes the native Digest
+ functionality of pyzor.
06 Aug 2008; Jesus Rivero <neurogeek@gentoo.org> metadata.xml:
add GLEP 56 USE flag desc from use.local.desc
diff --git a/dev-python/pyzor/pyzor-0.4.0-r4.ebuild b/dev-python/pyzor/pyzor-0.4.0-r4.ebuild
new file mode 100644
index 000000000000..d14b542e51bb
--- /dev/null
+++ b/dev-python/pyzor/pyzor-0.4.0-r4.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyzor/pyzor-0.4.0-r4.ebuild,v 1.1 2009/01/05 07:43:11 robbat2 Exp $
+
+inherit distutils eutils
+
+DESCRIPTION="A distributed, collaborative spam detection and filtering network"
+HOMEPAGE="http://pyzor.sourceforge.net/"
+
+MY_PV="${PV}+cvs20030201"
+MY_P="${PN}_${MY_PV}"
+DEBIAN_PATCH_VERSION="8"
+DEBIAN_PATCH="${MY_P}-${DEBIAN_PATCH_VERSION}.diff.gz"
+# Original:
+#SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+# Debian CVS snapshot
+SRC_URI="
+ mirror://debian/pool/main/p/${PN}/${MY_P}.orig.tar.gz
+ mirror://debian/pool/main/p/${PN}/${DEBIAN_PATCH}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="pyzord"
+
+DEPEND="dev-lang/python"
+
+S="${WORKDIR}/${MY_P//_/-}"
+
+pkg_setup() {
+ if use pyzord ; then
+ if ! built_with_use 'dev-lang/python' gdbm ; then
+ die "you need to rebuild python with gdbm support"
+ fi
+ fi
+}
+
+src_unpack() {
+ unpack ${MY_P}.orig.tar.gz
+ epatch "${DISTDIR}"/${DEBIAN_PATCH}
+ cd "${S}"
+ epatch "${S}"/debian/patches/*dpatch
+
+
+ # Same as Debian 08_define_mbox.dpatch
+ #epatch "${FILESDIR}/debian_mbox.patch"
+ # Same as Debian 07_handle_unknown_encodings.dpatch
+ #epatch "${FILESDIR}/handle_unknown_encodings.patch"
+
+ # Gentoo-unique
+ epatch "${FILESDIR}/pyzord_getopt.patch"
+ epatch "${FILESDIR}/unknown_type.patch"
+
+ # rfc822BodyCleanerTest doesn't work fine
+ # remove it until it's fixed
+ sed -i \
+ -e '/rfc822BodyCleanerTest/,/self\.assertEqual/d' \
+ unittests.py || die "sed in unittest.py failed"
+}
+
+src_install () {
+ DOCS="INSTALL THANKS UPGRADING"
+ distutils_src_install
+ dohtml docs/usage.html
+ rm -rf "${D}/usr/share/doc/pyzor"
+
+ if use pyzord ; then
+ dodir /usr/sbin
+ mv "${D}/usr/bin/pyzord" "${D}/usr/sbin/"
+ fi
+}
+
+pkg_postinst() {
+ if use pyzord ; then
+ ewarn "/usr/bin/pyzord has been moved to /usr/sbin"
+ fi
+}
+
+src_test() {
+ PYTHONPATH=build/lib/ "${python}" unittests.py || die "tests failed"
+}