summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2008-03-19 07:46:15 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2008-03-19 07:46:15 +0000
commitf241bd8b7af5ab30fa9ac24a34f892344be96101 (patch)
treef134ece2a36f868a72fa9a496379d995047f8aa0 /dev-python/pyxf86config/files
parentAdd longdescription to metadata. (diff)
downloadgentoo-2-f241bd8b7af5ab30fa9ac24a34f892344be96101.tar.gz
gentoo-2-f241bd8b7af5ab30fa9ac24a34f892344be96101.tar.bz2
gentoo-2-f241bd8b7af5ab30fa9ac24a34f892344be96101.zip
(#206989) Fix for amd64 by using rewritten Makefile.am (Dough Klima and me). Also fix for xorg-server 1.5 by removing knowledge of RgbPath.
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-python/pyxf86config/files')
-rw-r--r--dev-python/pyxf86config/files/0.3.34-remove-rgbpath.patch11
-rw-r--r--dev-python/pyxf86config/files/Makefile.am12
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/pyxf86config/files/0.3.34-remove-rgbpath.patch b/dev-python/pyxf86config/files/0.3.34-remove-rgbpath.patch
new file mode 100644
index 000000000000..f9e6a9e60ea3
--- /dev/null
+++ b/dev-python/pyxf86config/files/0.3.34-remove-rgbpath.patch
@@ -0,0 +1,11 @@
+diff -u pyxf86config-0.3.34.orig/pyxf86conf.c pyxf86config-0.3.34/pyxf86conf.c
+--- pyxf86config-0.3.34.orig/pyxf86conf.c 2008-03-19 00:13:41.000000000 -0700
++++ pyxf86config-0.3.34/pyxf86conf.c 2008-03-19 00:13:59.000000000 -0700
+@@ -1700,7 +1700,6 @@
+
+ WrapperAttribute files_attributes[] = {
+ { "logfile", offsetof(XF86ConfFilesRec,file_logfile), ATTRIBUTE_STRING},
+- { "rgbpath", offsetof(XF86ConfFilesRec,file_rgbpath), ATTRIBUTE_STRING},
+ { "module", offsetof(XF86ConfFilesRec,file_modulepath), ATTRIBUTE_STRING},
+ { "fontpath", offsetof(XF86ConfFilesRec,file_fontpath), ATTRIBUTE_STRING},
+ { "comment", offsetof(XF86ConfFilesRec,file_comment), ATTRIBUTE_STRING},
diff --git a/dev-python/pyxf86config/files/Makefile.am b/dev-python/pyxf86config/files/Makefile.am
new file mode 100644
index 000000000000..c405c444a02f
--- /dev/null
+++ b/dev-python/pyxf86config/files/Makefile.am
@@ -0,0 +1,12 @@
+AM_CFLAGS = -fvisibility=hidden
+
+INCLUDES = -I@PYTHON_INC@ @GLIB_CFLAGS@ @X_CFLAGS@ @XORG_SERVER_CFLAGS@
+
+pythondir = $(libdir)/python@PYTHON_VERSION@/site-packages
+
+python_LTLIBRARIES = ixf86configmodule.la
+dist_python_DATA = xf86config.py
+
+ixf86configmodule_la_SOURCES = pyxf86conf.h pyxf86conf.c xf86ParserExt.h xf86config_ext.c
+ixf86configmodule_la_LDFLAGS = -module -shared -avoid-version
+ixf86configmodule_la_LIBADD = @GOBJECT_LIBS@ -lxf86config