summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-03-10 16:47:58 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-03-10 16:47:58 +0000
commita23020dd9ff7e8b6d5d44d4853c517431f267cb8 (patch)
treebc0f4485c7111ff973c1ae8722bb8b9ed76b8bde /dev-python/pyxattr
parentapp-admin/webalizer-xtended: New package split off from webalizer (diff)
downloadgentoo-2-a23020dd9ff7e8b6d5d44d4853c517431f267cb8.tar.gz
gentoo-2-a23020dd9ff7e8b6d5d44d4853c517431f267cb8.tar.bz2
gentoo-2-a23020dd9ff7e8b6d5d44d4853c517431f267cb8.zip
Skip tests with Python 3.
(Portage version: 15816-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pyxattr')
-rw-r--r--dev-python/pyxattr/pyxattr-0.5.0.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/dev-python/pyxattr/pyxattr-0.5.0.ebuild b/dev-python/pyxattr/pyxattr-0.5.0.ebuild
index 87e0af32c325..af1d54147352 100644
--- a/dev-python/pyxattr/pyxattr-0.5.0.ebuild
+++ b/dev-python/pyxattr/pyxattr-0.5.0.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyxattr/pyxattr-0.5.0.ebuild,v 1.1 2010/03/10 00:08:49 sping Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyxattr/pyxattr-0.5.0.ebuild,v 1.2 2010/03/10 16:47:58 arfrever Exp $
-EAPI="2"
+EAPI="3"
SUPPORT_PYTHON_ABIS="1"
+#DISTUTILS_SRC_TEST="nosetests"
inherit distutils
@@ -18,11 +19,12 @@ IUSE="test"
RDEPEND="sys-apps/attr"
DEPEND="${RDEPEND}
- >=dev-python/setuptools-0.6_rc7-r1
+ dev-python/setuptools
test? ( dev-python/nose )"
src_test() {
testing() {
+ [[ "${PYTHON_ABI}" == 3.* ]] && return
PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib.*)" nosetests-${PYTHON_ABI}
}
python_execute_function testing