summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-05-14 02:18:08 +0000
committerIan Delaney <idella4@gentoo.org>2015-05-14 02:18:08 +0000
commit419e9184a9aa87ac3ebfab0ba0d032f6e7fc2b71 (patch)
treed0961035a76537314097c41b2d9e74d0a905cdeb /dev-python/pyxattr
parentadd missed ':' (diff)
downloadgentoo-2-419e9184a9aa87ac3ebfab0ba0d032f6e7fc2b71.tar.gz
gentoo-2-419e9184a9aa87ac3ebfab0ba0d032f6e7fc2b71.tar.bz2
gentoo-2-419e9184a9aa87ac3ebfab0ba0d032f6e7fc2b71.zip
bump
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/pyxattr')
-rw-r--r--dev-python/pyxattr/ChangeLog7
-rw-r--r--dev-python/pyxattr/pyxattr-0.5.5.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/dev-python/pyxattr/ChangeLog b/dev-python/pyxattr/ChangeLog
index 5beac8e156fe..fbbc95077e17 100644
--- a/dev-python/pyxattr/ChangeLog
+++ b/dev-python/pyxattr/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pyxattr
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyxattr/ChangeLog,v 1.75 2015/04/08 08:04:59 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyxattr/ChangeLog,v 1.76 2015/05/14 02:18:08 idella4 Exp $
+
+*pyxattr-0.5.5 (14 May 2015)
+
+ 14 May 2015; Ian Delaney <idella4@gentoo.org> +pyxattr-0.5.5.ebuild:
+ bump
08 Apr 2015; Michał Górny <mgorny@gentoo.org> pyxattr-0.5.3.ebuild,
pyxattr-9999.ebuild:
diff --git a/dev-python/pyxattr/pyxattr-0.5.5.ebuild b/dev-python/pyxattr/pyxattr-0.5.5.ebuild
new file mode 100644
index 000000000000..1064925e8f1f
--- /dev/null
+++ b/dev-python/pyxattr/pyxattr-0.5.5.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyxattr/pyxattr-0.5.5.ebuild,v 1.1 2015/05/14 02:18:08 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Python interface to xattr"
+HOMEPAGE="http://pyxattr.k1024.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
+ http://pyxattr.k1024.org/downloads/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="sys-apps/attr"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ sed -i -e 's:, "-Werror"::' setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake doc
+}
+
+src_test() {
+ # Perform the tests in /var/tmp; that location is more likely
+ # to have xattr support than /tmp which is often tmpfs.
+ export TESTDIR=/var/tmp
+
+ einfo 'Please note that the tests fail if xattrs are not supported'
+ einfo 'by the filesystem used for /var/tmp.'
+ distutils-r1_src_test
+}
+
+python_test() {
+ nosetests || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/html/. )
+ distutils-r1_python_install_all
+}