summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-10-29 08:42:33 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-10-29 08:42:33 +0000
commitd926df0c41cc3ee494bf552fa8075613f2d739c8 (patch)
treef3043a2d829429cdf3648aa86e42c4755d66d179 /dev-python/pyx
parentAdd ~amd64, wrt bug #439882 (diff)
downloadgentoo-2-d926df0c41cc3ee494bf552fa8075613f2d739c8.tar.gz
gentoo-2-d926df0c41cc3ee494bf552fa8075613f2d739c8.tar.bz2
gentoo-2-d926df0c41cc3ee494bf552fa8075613f2d739c8.zip
Bump
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/pyx')
-rw-r--r--dev-python/pyx/ChangeLog10
-rw-r--r--dev-python/pyx/pyx-0.12.ebuild50
2 files changed, 57 insertions, 3 deletions
diff --git a/dev-python/pyx/ChangeLog b/dev-python/pyx/ChangeLog
index 6d2a5867af18..67a8f2bad7e4 100644
--- a/dev-python/pyx/ChangeLog
+++ b/dev-python/pyx/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pyx
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyx/ChangeLog,v 1.28 2011/07/29 22:54:35 bicatali Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyx/ChangeLog,v 1.29 2012/10/29 08:42:33 patrick Exp $
+
+*pyx-0.12 (29 Oct 2012)
+
+ 29 Oct 2012; Patrick Lauer <patrick@gentoo.org> +pyx-0.12.ebuild:
+ Bump
*pyx-0.11.1 (29 Jul 2011)
@@ -115,4 +120,3 @@
10 May 2003; Alastair Tse <liquidx@gentoo.org> pyx-0.3.1.ebuild:
Initial ebuild. Submitted by Dan Bullok <dan.gentoo@bullok.com>.
-
diff --git a/dev-python/pyx/pyx-0.12.ebuild b/dev-python/pyx/pyx-0.12.ebuild
new file mode 100644
index 000000000000..73fec19c16bd
--- /dev/null
+++ b/dev-python/pyx/pyx-0.12.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyx/pyx-0.12.ebuild,v 1.1 2012/10/29 08:42:33 patrick Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+
+inherit distutils eutils
+
+MY_P="${P/pyx/PyX}"
+
+DESCRIPTION="Python package for the generation of encapsulated PostScript figures"
+HOMEPAGE="http://pyx.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pyx/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="doc"
+
+RDEPEND="virtual/tex-base"
+DEPEND="${RDEPEND}
+ doc? ( virtual/latex-base )"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="AUTHORS CHANGES"
+
+src_prepare() {
+ distutils_src_prepare
+ sed -i \
+ -e 's/^build_t1code=.*/build_t1code=1/' \
+ -e 's/^build_pykpathsea=.*/build_pykpathsea=1/' \
+ setup.cfg || die "setup.cfg fix failed"
+}
+
+src_compile() {
+ distutils_src_compile
+ if use doc; then
+ cd "${S}/faq"
+ VARTEXFONTS="${T}"/fonts make pdf
+ fi
+}
+
+src_install() {
+ distutils_src_install
+ use doc && dodoc faq/pyxfaq.pdf
+}