summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-06-13 22:30:31 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-06-13 22:30:31 +0000
commiteea058e6f2e3fbf18086474648a742a047a63513 (patch)
tree5b883e58d9f96a16485757172e6f0ef7d76557f7 /dev-python/pyvorbis
parentmove patching to src_unpack, conditional newstat patch apply, newrole tty rel... (diff)
downloadgentoo-2-eea058e6f2e3fbf18086474648a742a047a63513.tar.gz
gentoo-2-eea058e6f2e3fbf18086474648a742a047a63513.tar.bz2
gentoo-2-eea058e6f2e3fbf18086474648a742a047a63513.zip
moving media-libs/pyvorbis to dev-python
Diffstat (limited to 'dev-python/pyvorbis')
-rw-r--r--dev-python/pyvorbis/ChangeLog11
-rw-r--r--dev-python/pyvorbis/Manifest4
-rw-r--r--dev-python/pyvorbis/files/digest-pyvorbis-1.11
-rw-r--r--dev-python/pyvorbis/pyvorbis-1.1.ebuild25
4 files changed, 39 insertions, 2 deletions
diff --git a/dev-python/pyvorbis/ChangeLog b/dev-python/pyvorbis/ChangeLog
new file mode 100644
index 000000000000..16570415a2cb
--- /dev/null
+++ b/dev-python/pyvorbis/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for media-libs/pyvorbis
+# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyvorbis/ChangeLog,v 1.1 2003/06/13 22:30:21 liquidx Exp $
+
+*pyvorbis-1.1 (30 Nov 2002)
+
+ 30 Nov 2002; Matthew Kennedy <mkennedy@gentoo.org> ChangeLog,
+ pyvorbis-1.1.ebuild, files/digest-pyvorbis-1.1 :
+
+ Initial import. Ebuild submitted by Matthieu Sozeau
+ <mattam@netcourrier.com>.
diff --git a/dev-python/pyvorbis/Manifest b/dev-python/pyvorbis/Manifest
index e4e43ff790c3..e1c480aeda7e 100644
--- a/dev-python/pyvorbis/Manifest
+++ b/dev-python/pyvorbis/Manifest
@@ -1,3 +1,3 @@
-MD5 2634025d4c8ec9f8da35a0ba807a0645 ChangeLog 448
-MD5 9d1df2fef4d8a31ff34a2d081ff649b5 pyvorbis-1.1.ebuild 704
+MD5 9d19dc3cfcd232739237c77891fc0f44 ChangeLog 449
+MD5 a5f0735d14db5cfd541ec5ba8bcbd336 pyvorbis-1.1.ebuild 705
MD5 28ec3622a17a96ac8cc3ef8427ac3e45 files/digest-pyvorbis-1.1 63
diff --git a/dev-python/pyvorbis/files/digest-pyvorbis-1.1 b/dev-python/pyvorbis/files/digest-pyvorbis-1.1
new file mode 100644
index 000000000000..20aa6b864672
--- /dev/null
+++ b/dev-python/pyvorbis/files/digest-pyvorbis-1.1
@@ -0,0 +1 @@
+MD5 ea45cec8eb78364c381039b82c47e610 pyvorbis-1.1.tar.gz 36943
diff --git a/dev-python/pyvorbis/pyvorbis-1.1.ebuild b/dev-python/pyvorbis/pyvorbis-1.1.ebuild
new file mode 100644
index 000000000000..2eaffdb90161
--- /dev/null
+++ b/dev-python/pyvorbis/pyvorbis-1.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyvorbis/pyvorbis-1.1.ebuild,v 1.1 2003/06/13 22:30:21 liquidx Exp $
+
+DESCRIPTION="Python bindings for the ogg.vorbis library"
+HOMEPAGE="http://www.andrewchatham.com/pyogg/"
+SRC_URI="http://www.andrewchatham.com/pyogg/download/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc"
+
+DEPEND="dev-lang/python
+ media-libs/libogg
+ >=media-libs/pyogg-1.1"
+
+src_compile() {
+ ./config_unix.py || die
+ python setup.py build || die
+}
+
+src_install() {
+ python setup.py install --prefix ${D}/usr || die
+ dodoc AUTHORS COPYING ChangeLog NEWS README
+}