summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2011-12-21 11:23:47 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2011-12-21 11:23:47 +0000
commitc7a0becdc2438fa61f4dd0a75dc22c44a67933ef (patch)
tree750313822db9a6b6533a1c52e1d9556c3fba37fb /dev-python/python-yadis
parentVersion bump, drop old (diff)
downloadgentoo-2-c7a0becdc2438fa61f4dd0a75dc22c44a67933ef.tar.gz
gentoo-2-c7a0becdc2438fa61f4dd0a75dc22c44a67933ef.tar.bz2
gentoo-2-c7a0becdc2438fa61f4dd0a75dc22c44a67933ef.zip
Replaced test patch with new one by Ian Delaney, bug 297111
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/python-yadis')
-rw-r--r--dev-python/python-yadis/ChangeLog10
-rw-r--r--dev-python/python-yadis/files/python-yadis-1.1.0-gentoo-test.patch49
-rw-r--r--dev-python/python-yadis/python-yadis-1.1.0-r1.ebuild (renamed from dev-python/python-yadis/python-yadis-1.1.0.ebuild)7
3 files changed, 62 insertions, 4 deletions
diff --git a/dev-python/python-yadis/ChangeLog b/dev-python/python-yadis/ChangeLog
index 6fb7a3e76588..b05bfc2a3c74 100644
--- a/dev-python/python-yadis/ChangeLog
+++ b/dev-python/python-yadis/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/python-yadis
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-yadis/ChangeLog,v 1.3 2010/07/08 17:05:54 arfrever Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-yadis/ChangeLog,v 1.4 2011/12/21 11:23:47 maksbotan Exp $
+
+*python-yadis-1.1.0-r1 (21 Dec 2011)
+
+ 21 Dec 2011; Maxim Koltsov <maksbotan@gentoo.org> -python-yadis-1.1.0.ebuild,
+ +python-yadis-1.1.0-r1.ebuild, files/python-yadis-1.1.0-gentoo-test.patch:
+ Replaced test patch with new one by Ian Delaney, bug 297111
08 Jul 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
python-yadis-1.1.0.ebuild:
diff --git a/dev-python/python-yadis/files/python-yadis-1.1.0-gentoo-test.patch b/dev-python/python-yadis/files/python-yadis-1.1.0-gentoo-test.patch
index c073758fc3b6..bfb2463a6663 100644
--- a/dev-python/python-yadis/files/python-yadis-1.1.0-gentoo-test.patch
+++ b/dev-python/python-yadis/files/python-yadis-1.1.0-gentoo-test.patch
@@ -23,3 +23,52 @@
echo -n 'Running tests... '
if ! python ${YDIR}/yadis/test/runtests ; then
+diff -ur python-yadis-1.1.0.orig/yadis/test/test_xri.py python-yadis-1.1.0/yadis/test/test_xri.py
+--- yadis/test/test_xri.py 2006-12-09 06:17:12.000000000 +0900
++++ yadis/test/test_xri.py 2011-11-16 22:03:07.254992928 +0800
+@@ -45,7 +45,7 @@
+ expected = 'l%C2%A1m'
+ self.failUnlessEqual(xri.iriToURI(s), expected)
+ else:
+- def test_iri_to_url(self):
++ def test_iri_to_url2(self):
+ s = u'l\xa1m\U00101010n'
+ expected = 'l%C2%A1m%F4%81%80%90n'
+ self.failUnlessEqual(xri.iriToURI(s), expected)
+diff -ur /mnt/gen2/tmpdir/portage/dev-python/python-yadis-1.1.0/work/python-yadis-1.1.0.orig/yadis/etxrd.py /mnt/gen2/tmpdir/portage/dev-python/python-yadis-1.1.0/work/python-yadis-1.1.0/yadis/etxrd.py
+--- yadis/etxrd.py 2006-12-09 06:17:12.000000000 +0900
++++ yadis/etxrd.py 2011-11-16 22:26:21.386992510 +0800
+@@ -23,12 +23,12 @@
+ from elementtree.ElementTree import ElementTree
+
+ # Use expat if it's present. Otherwise, use xmllib
+-try:
+- from xml.parsers.expat import ExpatError as XMLError
+- from elementtree.ElementTree import XMLTreeBuilder
+-except ImportError:
+- from elementtree.SimpleXMLTreeBuilder import TreeBuilder as XMLTreeBuilder
+- from xmllib import Error as XMLError
++#try
++# from xml.parsers.expat import ExpatError as XMLError
++# from elementtree.ElementTree import XMLTreeBuilder
++#except ImportError:
++from elementtree.SimpleXMLTreeBuilder import TreeBuilder as XMLTreeBuilder
++from xmllib import Error as XMLError
+
+ from yadis import xri
+
+diff -ur /mnt/gen2/tmpdir/portage/dev-python/python-yadis-1.1.0/work/python-yadis-1.1.0.orig/yadis/test/test_etxrd.py /mnt/gen2/tmpdir/portage/dev-python/python-yadis-1.1.0/work/python-yadis-1.1.0/yadis/test/test_etxrd.py
+--- yadis/test/test_etxrd.py 2006-12-09 06:17:12.000000000 +0900
++++ yadis/test/test_etxrd.py 2011-11-16 22:29:00.896992462 +0800
+@@ -40,9 +40,9 @@
+ def _getServices(self, flt=None):
+ return list(services.applyFilter(self.yadis_url, self.xmldoc, flt))
+
+- def testParse(self):
++# def testParse(self):
+ """Make sure that parsing succeeds at all"""
+- services = self._getServices()
++# services = self._getServices()
+
+ def testParseOpenID(self):
+ """Parse for OpenID services with a transformer function"""
diff --git a/dev-python/python-yadis/python-yadis-1.1.0.ebuild b/dev-python/python-yadis/python-yadis-1.1.0-r1.ebuild
index 664809ca6de1..4f68d1ff6a6d 100644
--- a/dev-python/python-yadis/python-yadis-1.1.0.ebuild
+++ b/dev-python/python-yadis/python-yadis-1.1.0-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-yadis/python-yadis-1.1.0.ebuild,v 1.4 2010/07/08 17:05:54 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-yadis/python-yadis-1.1.0-r1.ebuild,v 1.1 2011/12/21 11:23:47 maksbotan Exp $
EAPI="3"
PYTHON_DEPEND="2"
@@ -33,6 +33,9 @@ src_prepare() {
src_test() {
testing() {
+ if [[ ${PYTHON_ABI} != "2.7" ]]; then
+ ewarn "Tests are known to fail on ${PYTHON_ABI}"
+ fi
./admin/runtests
}
python_execute_function testing