summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-08 16:08:43 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-08 16:08:43 +0000
commit6ffae05117af3fe012962bced492d12f14f00ed5 (patch)
tree251be9c1c7d64193a6c010488704c5a4ec498a5a /dev-python/python-urljr
parentnew default scripts patch (diff)
downloadgentoo-2-6ffae05117af3fe012962bced492d12f14f00ed5.tar.gz
gentoo-2-6ffae05117af3fe012962bced492d12f14f00ed5.tar.bz2
gentoo-2-6ffae05117af3fe012962bced492d12f14f00ed5.zip
Set SUPPORT_PYTHON_ABIS.
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/python-urljr')
-rw-r--r--dev-python/python-urljr/ChangeLog8
-rw-r--r--dev-python/python-urljr/python-urljr-1.0.1.ebuild34
2 files changed, 28 insertions, 14 deletions
diff --git a/dev-python/python-urljr/ChangeLog b/dev-python/python-urljr/ChangeLog
index 42e166ff100b..716ced5cd066 100644
--- a/dev-python/python-urljr/ChangeLog
+++ b/dev-python/python-urljr/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/python-urljr
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-urljr/ChangeLog,v 1.2 2007/05/31 20:56:01 lucass Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-urljr/ChangeLog,v 1.3 2010/07/08 16:08:43 arfrever Exp $
+
+ 08 Jul 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ python-urljr-1.0.1.ebuild:
+ Set SUPPORT_PYTHON_ABIS.
31 May 2007; Lukasz Strzygowski <lucass@gentoo.org>
python-urljr-1.0.1.ebuild:
diff --git a/dev-python/python-urljr/python-urljr-1.0.1.ebuild b/dev-python/python-urljr/python-urljr-1.0.1.ebuild
index e3c55668aa30..6a2781f10e1f 100644
--- a/dev-python/python-urljr/python-urljr-1.0.1.ebuild
+++ b/dev-python/python-urljr/python-urljr-1.0.1.ebuild
@@ -1,29 +1,39 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-urljr/python-urljr-1.0.1.ebuild,v 1.3 2007/07/11 06:19:47 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-urljr/python-urljr-1.0.1.ebuild,v 1.4 2010/07/08 16:08:43 arfrever Exp $
-NEED_PYTHON=2.3
-PYTHON_MODNAME="urljr"
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
inherit distutils eutils
DESCRIPTION="JanRain's URL Utilities"
HOMEPAGE="http://www.openidenabled.com/openid/libraries/python/"
SRC_URI="http://www.openidenabled.com/resources/downloads/python-openid/${P}.tar.gz"
+
LICENSE="LGPL-2.1"
-KEYWORDS="~amd64 ~x86"
SLOT="0"
+KEYWORDS="~amd64 ~x86"
IUSE="curl test"
-RDEPEND="curl? ( >=dev-python/pycurl-7.15.1 )
+
+RDEPEND="curl? ( >=dev-python/pycurl-7.15.1 )"
+DEPEND="${RDEPEND}
test? ( >=dev-python/pycurl-7.15.1 )"
-src_unpack() {
- unpack ${A}
- cd ${S}
- #Test fails if it finds 'localhost' instead of '127.0.0.1'
- epatch ${FILESDIR}/${P}-gentoo-test_fetchers.patch
+PYTHON_MODNAME="urljr"
+
+src_prepare() {
+ distutils_src_prepare
+
+ # Test fails if it finds 'localhost' instead of '127.0.0.1'.
+ epatch "${FILESDIR}/${P}-gentoo-test_fetchers.patch"
}
src_test() {
- PYTHONPATH=. "${python}" admin/runtests || die "tests failed"
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" admin/runtests
+ }
+ python_execute_function testing
}