summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-08-11 02:10:45 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-08-11 02:10:45 +0000
commitbaba95c266b15f2b73ca06f4b0914aeed3230611 (patch)
tree91691b83fb7c20562f60e1aaa1ba44a1e17078de /dev-python/python-swiftclient
parentBump (diff)
downloadgentoo-2-baba95c266b15f2b73ca06f4b0914aeed3230611.tar.gz
gentoo-2-baba95c266b15f2b73ca06f4b0914aeed3230611.tar.bz2
gentoo-2-baba95c266b15f2b73ca06f4b0914aeed3230611.zip
updating swiftclient to 1.5.0
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'dev-python/python-swiftclient')
-rw-r--r--dev-python/python-swiftclient/ChangeLog9
-rw-r--r--dev-python/python-swiftclient/python-swiftclient-1.2.0-r1.ebuild21
-rw-r--r--dev-python/python-swiftclient/python-swiftclient-1.5.0.ebuild38
3 files changed, 45 insertions, 23 deletions
diff --git a/dev-python/python-swiftclient/ChangeLog b/dev-python/python-swiftclient/ChangeLog
index 1c4a959faeb2..afecf38729db 100644
--- a/dev-python/python-swiftclient/ChangeLog
+++ b/dev-python/python-swiftclient/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/python-swiftclient
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-swiftclient/ChangeLog,v 1.3 2013/03/11 02:27:19 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-swiftclient/ChangeLog,v 1.4 2013/08/11 02:10:45 prometheanfire Exp $
+
+*python-swiftclient-1.5.0 (11 Aug 2013)
+
+ 11 Aug 2013; Matthew Thode <prometheanfire@gentoo.org>
+ +python-swiftclient-1.5.0.ebuild, -python-swiftclient-1.2.0-r1.ebuild:
+ updating swiftclient to 1.5.0
*python-swiftclient-1.3.0 (11 Mar 2013)
@@ -20,4 +26,3 @@
+python-swiftclient-1.2.0.ebuild, +metadata.xml:
initial commit of dev-python/python-swiftclient for soon to exist
sys-cluster/swift
-
diff --git a/dev-python/python-swiftclient/python-swiftclient-1.2.0-r1.ebuild b/dev-python/python-swiftclient/python-swiftclient-1.2.0-r1.ebuild
deleted file mode 100644
index 7c1ec863898b..000000000000
--- a/dev-python/python-swiftclient/python-swiftclient-1.2.0-r1.ebuild
+++ /dev/null
@@ -1,21 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-swiftclient/python-swiftclient-1.2.0-r1.ebuild,v 1.1 2013/01/11 22:22:18 prometheanfire Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python2_5 python2_6 python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="Python bindings to the OpenStack Object Storage API"
-HOMEPAGE="http://docs.openstack.org/developer/python-swiftclient"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/simplejson[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
diff --git a/dev-python/python-swiftclient/python-swiftclient-1.5.0.ebuild b/dev-python/python-swiftclient/python-swiftclient-1.5.0.ebuild
new file mode 100644
index 000000000000..aeab42e03486
--- /dev/null
+++ b/dev-python/python-swiftclient/python-swiftclient-1.5.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-swiftclient/python-swiftclient-1.5.0.ebuild,v 1.1 2013/08/11 02:10:45 prometheanfire Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+#restricted due to packages missing and bad depends in the test ==webob-1.0.8
+RESTRICT="test"
+inherit distutils-r1
+
+DESCRIPTION="Python bindings to the OpenStack Object Storage API"
+HOMEPAGE="http://docs.openstack.org/developer/python-swiftclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ~dev-python/pep8-1.4.5[${PYTHON_USEDEP}]
+ ~dev-python/pyflakes-0.7.2[${PYTHON_USEDEP}]
+ ~dev-python/flake8-2.0[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/python-keystoneclient[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ >=dev-python/testtools-0.9.22[${PYTHON_USEDEP}] )"
+
+RDEPEND=">=dev-python/simplejson-2.0.9[${PYTHON_USEDEP}]
+ >=dev-python/pbr-0.5[${PYTHON_USEDEP}]
+ <dev-python/pbr-0.6[${PYTHON_USEDEP}]
+ >=dev-python/d2to1-0.2.10[${PYTHON_USEDEP}]
+ <dev-python/d2to1-0.3[${PYTHON_USEDEP}]"
+
+python_test() {
+ sh run_tests.sh | die
+}