summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-03-11 02:27:19 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-03-11 02:27:19 +0000
commitb5f24ba6784faf8716fa60800e47eb2ae7b2cdd5 (patch)
treed466d493fa60ae62076bc354adf77d035b0831d8 /dev-python/python-swiftclient
parentversion bump 19.x for security bug 460818, remove old (diff)
downloadgentoo-2-b5f24ba6784faf8716fa60800e47eb2ae7b2cdd5.tar.gz
gentoo-2-b5f24ba6784faf8716fa60800e47eb2ae7b2cdd5.tar.bz2
gentoo-2-b5f24ba6784faf8716fa60800e47eb2ae7b2cdd5.zip
just a bump of python-swiftclient to 1.3.0
(Portage version: 2.1.11.52/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'dev-python/python-swiftclient')
-rw-r--r--dev-python/python-swiftclient/ChangeLog8
-rw-r--r--dev-python/python-swiftclient/python-swiftclient-1.3.0.ebuild36
2 files changed, 43 insertions, 1 deletions
diff --git a/dev-python/python-swiftclient/ChangeLog b/dev-python/python-swiftclient/ChangeLog
index c67c8351b8da..1c4a959faeb2 100644
--- a/dev-python/python-swiftclient/ChangeLog
+++ b/dev-python/python-swiftclient/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/python-swiftclient
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-swiftclient/ChangeLog,v 1.2 2013/01/11 22:22:18 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-swiftclient/ChangeLog,v 1.3 2013/03/11 02:27:19 prometheanfire Exp $
+
+*python-swiftclient-1.3.0 (11 Mar 2013)
+
+ 11 Mar 2013; Matthew Thode <prometheanfire@gentoo.org>
+ +python-swiftclient-1.3.0.ebuild:
+ just a bump of python-swiftclient to 1.3.0
*python-swiftclient-1.2.0-r1 (11 Jan 2013)
diff --git a/dev-python/python-swiftclient/python-swiftclient-1.3.0.ebuild b/dev-python/python-swiftclient/python-swiftclient-1.3.0.ebuild
new file mode 100644
index 000000000000..021e20306db6
--- /dev/null
+++ b/dev-python/python-swiftclient/python-swiftclient-1.3.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-swiftclient/python-swiftclient-1.3.0.ebuild,v 1.1 2013/03/11 02:27:19 prometheanfire Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+#restricted due to packages missing and bad depends in the test ==webob-1.0.8
+RESTRICT="test"
+inherit distutils-r1
+
+DESCRIPTION="Python bindings to the OpenStack Object Storage API"
+HOMEPAGE="http://docs.openstack.org/developer/python-swiftclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/eventlet[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/nose-exclude[${PYTHON_USEDEP}]
+ dev-python/nosehtmloutput[${PYTHON_USEDEP}]
+ dev-python/nosexcover
+ dev-python/openstack-nose-plugin[${PYTHON_USEDEP}]
+ =dev-python/pep8-1.3.3
+ dev-python/python-keystoneclient[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ >=dev-python/testtools-0.9.22[${PYTHON_USEDEP}] )"
+RDEPEND="dev-python/simplejson[${PYTHON_USEDEP}]"
+
+python_test() {
+ sh run_tests.sh | die
+}