summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2014-02-17 17:46:34 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2014-02-17 17:46:34 +0000
commit43e0a9f8385f5fab9191d4174a31982e2cc9989b (patch)
tree3ab4b1e7a04aeccf2890838d06beb7040887bc85 /dev-python/python-swiftclient
parentfix for a dep of a cve (diff)
downloadgentoo-2-43e0a9f8385f5fab9191d4174a31982e2cc9989b.tar.gz
gentoo-2-43e0a9f8385f5fab9191d4174a31982e2cc9989b.tar.bz2
gentoo-2-43e0a9f8385f5fab9191d4174a31982e2cc9989b.zip
fix for CVE-2013-6396 (still needs to be backported to pre 2 (for grizzly support)
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'dev-python/python-swiftclient')
-rw-r--r--dev-python/python-swiftclient/ChangeLog11
-rw-r--r--dev-python/python-swiftclient/python-swiftclient-2.0.2.ebuild56
2 files changed, 65 insertions, 2 deletions
diff --git a/dev-python/python-swiftclient/ChangeLog b/dev-python/python-swiftclient/ChangeLog
index 21ad12d1ddca..abffbb4b74e8 100644
--- a/dev-python/python-swiftclient/ChangeLog
+++ b/dev-python/python-swiftclient/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/python-swiftclient
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-swiftclient/ChangeLog,v 1.8 2013/11/28 06:32:32 idella4 Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-swiftclient/ChangeLog,v 1.9 2014/02/17 17:46:34 prometheanfire Exp $
+
+*python-swiftclient-2.0.2 (17 Feb 2014)
+
+ 17 Feb 2014; Matthew Thode <prometheanfire@gentoo.org>
+ +python-swiftclient-2.0.2.ebuild:
+ fix for CVE-2013-6396 (still needs to be backported to pre 2 (for grizzly
+ support)
28 Nov 2013; Ian Delaney <idella4@gentoo.org> python-swiftclient-1.8.0.ebuild:
update test phase
diff --git a/dev-python/python-swiftclient/python-swiftclient-2.0.2.ebuild b/dev-python/python-swiftclient/python-swiftclient-2.0.2.ebuild
new file mode 100644
index 000000000000..2fd274ea686b
--- /dev/null
+++ b/dev-python/python-swiftclient/python-swiftclient-2.0.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-swiftclient/python-swiftclient-2.0.2.ebuild,v 1.1 2014/02/17 17:46:34 prometheanfire Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings to the OpenStack Object Storage API"
+HOMEPAGE="https://launchpad.net/python-swiftclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0[${PYTHON_USEDEP}]
+ >=dev-python/python-keystoneclient-0.4.2[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.17[${PYTHON_USEDEP}]
+ >=dev-python/testtools-0.9.32[${PYTHON_USEDEP}]
+ >=dev-python/hacking-0.8.0[${PYTHON_USEDEP}]
+ <dev-python/hacking-0.9[${PYTHON_USEDEP}]
+ doc? ( >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.2[${PYTHON_USEDEP}] ) )"
+RDEPEND=">=dev-python/simplejson-2.0.9[${PYTHON_USEDEP}]
+ >=dev-python/pbr-0.5[${PYTHON_USEDEP}]
+ <dev-python/pbr-0.6[${PYTHON_USEDEP}]
+ >=dev-python/requests-1.1[${PYTHON_USEDEP}]"
+
+#PATCHES=( "${FILESDIR}/CVE-2013-6396.patch" )
+
+python_prepare() {
+ sed -i '/discover/d' "${S}/test-requirements.txt" || die "sed failed"
+ distutils-r1_python_prepare
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ testr init
+ testr run || die "tests failed under python2_7"
+ flake8 tests && einfo "run of tests folder by flake8 passed"
+ flake8 bin/swift && einfo "run of ./bin/swift by flake8 passed"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( ../${P}-python2_7/doc/build/html/. )
+ distutils-r1_python_install_all
+}