summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris PeBenito <pebenito@gentoo.org>2006-02-17 03:08:15 +0000
committerChris PeBenito <pebenito@gentoo.org>2006-02-17 03:08:15 +0000
commit6e9dfa407fa75c9dbd4b82281affe06e2ce98e07 (patch)
tree0aee571ae295574d5656e8f6e2e2ad82aec3c4e9 /dev-python/python-selinux
parentFixed build errors, but making src_compile empty. This is a binary package, so (diff)
downloadgentoo-2-6e9dfa407fa75c9dbd4b82281affe06e2ce98e07.tar.gz
gentoo-2-6e9dfa407fa75c9dbd4b82281affe06e2ce98e07.tar.bz2
gentoo-2-6e9dfa407fa75c9dbd4b82281affe06e2ce98e07.zip
mark stable
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'dev-python/python-selinux')
-rw-r--r--dev-python/python-selinux/ChangeLog6
-rw-r--r--dev-python/python-selinux/files/digest-python-selinux-2.163
-rw-r--r--dev-python/python-selinux/python-selinux-2.16-r1.ebuild5
-rw-r--r--dev-python/python-selinux/python-selinux-2.16.ebuild38
4 files changed, 7 insertions, 45 deletions
diff --git a/dev-python/python-selinux/ChangeLog b/dev-python/python-selinux/ChangeLog
index 615994a06195..8e48012ff41f 100644
--- a/dev-python/python-selinux/ChangeLog
+++ b/dev-python/python-selinux/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/python-selinux
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-selinux/ChangeLog,v 1.30 2006/02/12 01:58:57 pebenito Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-selinux/ChangeLog,v 1.31 2006/02/17 03:08:11 pebenito Exp $
+
+ 17 Feb 2006; Chris PeBenito <pebenito@gentoo.org>
+ -python-selinux-2.16.ebuild, python-selinux-2.16-r1.ebuild:
+ Mark stable.
*python-selinux-2.16-r1 (12 Feb 2006)
diff --git a/dev-python/python-selinux/files/digest-python-selinux-2.16 b/dev-python/python-selinux/files/digest-python-selinux-2.16
deleted file mode 100644
index 28546a89b7e8..000000000000
--- a/dev-python/python-selinux/files/digest-python-selinux-2.16
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 d5dc9417a58fe239af4d9e126be2ceff python-selinux-2.16.c.bz2 8500
-RMD160 f98aac72c759c37a167ca8589c5544438c9ebcd5 python-selinux-2.16.c.bz2 8500
-SHA256 3bcf586902b74c124a8c953ba51bb193ba7732629760f465c41559011bbff1e1 python-selinux-2.16.c.bz2 8500
diff --git a/dev-python/python-selinux/python-selinux-2.16-r1.ebuild b/dev-python/python-selinux/python-selinux-2.16-r1.ebuild
index 3360b945e251..c9848a97958f 100644
--- a/dev-python/python-selinux/python-selinux-2.16-r1.ebuild
+++ b/dev-python/python-selinux/python-selinux-2.16-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-selinux/python-selinux-2.16-r1.ebuild,v 1.1 2006/02/12 01:58:57 pebenito Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-selinux/python-selinux-2.16-r1.ebuild,v 1.2 2006/02/17 03:08:11 pebenito Exp $
inherit python
@@ -10,8 +10,7 @@ LICENSE="GPL-2"
SLOT="0"
SRC_URI="mirror://gentoo/${P}.tar.bz2"
-#KEYWORDS="alpha amd64 mips ppc sparc x86"
-KEYWORDS="~alpha ~amd64 ~mips ~ppc ~sparc ~x86"
+KEYWORDS="~alpha amd64 ~mips ppc sparc x86"
IUSE=""
DEPEND="dev-lang/python
diff --git a/dev-python/python-selinux/python-selinux-2.16.ebuild b/dev-python/python-selinux/python-selinux-2.16.ebuild
deleted file mode 100644
index de0fcdb31077..000000000000
--- a/dev-python/python-selinux/python-selinux-2.16.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-selinux/python-selinux-2.16.ebuild,v 1.5 2006/02/09 00:27:40 pebenito Exp $
-
-inherit python
-
-DESCRIPTION="Python bindings for SELinux functions"
-HOMEPAGE="http://www.gentoo.org/proj/en/hardened/selinux/"
-LICENSE="GPL-2"
-SLOT="0"
-SRC_URI="mirror://gentoo/${P}.c.bz2"
-
-KEYWORDS="~alpha amd64 mips ppc sparc x86"
-#KEYWORDS="~x86 ~ppc ~sparc ~amd64 ~mips"
-IUSE=""
-
-DEPEND="dev-lang/python
- sys-libs/libselinux"
-
-S=${WORKDIR}/${PN}
-
-src_unpack() {
- mkdir -p ${S}
- bzcat ${DISTDIR}/${A} > ${S}/selinux.c || die
-}
-
-src_compile() {
- cd ${S}
- python_version
- einfo "Compiling selinux.so for python ${PYVER}"
- gcc -fPIC -shared -o selinux.so -I /usr/include/python${PYVER}/ selinux.c -lselinux || die
-}
-
-src_install() {
- python_version
- insinto /usr/lib/python${PYVER}/site-packages
- doins selinux.so
-}