summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-02-08 17:47:41 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-02-08 17:47:41 +0000
commit151940721fd97682091f219ac7a5d0542edaa94f (patch)
tree98979e36bde310dbabc2d5d28f2c841ef3126689 /dev-python/python-selinux
parentx86 stable per bug 343929 (diff)
downloadgentoo-2-151940721fd97682091f219ac7a5d0542edaa94f.tar.gz
gentoo-2-151940721fd97682091f219ac7a5d0542edaa94f.tar.bz2
gentoo-2-151940721fd97682091f219ac7a5d0542edaa94f.zip
Use Python 2 (bug #345547).
(Portage version: 2.2.0_alpha22_p4/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/python-selinux')
-rw-r--r--dev-python/python-selinux/ChangeLog8
-rw-r--r--dev-python/python-selinux/python-selinux-2.16-r2.ebuild18
2 files changed, 18 insertions, 8 deletions
diff --git a/dev-python/python-selinux/ChangeLog b/dev-python/python-selinux/ChangeLog
index 41d582348a5a..f042f21e7d64 100644
--- a/dev-python/python-selinux/ChangeLog
+++ b/dev-python/python-selinux/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/python-selinux
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-selinux/ChangeLog,v 1.38 2010/04/16 19:44:03 arfrever Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-selinux/ChangeLog,v 1.39 2011/02/08 17:47:41 arfrever Exp $
+
+ 08 Feb 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ python-selinux-2.16-r2.ebuild:
+ Use Python 2 (bug #345547).
16 Apr 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
python-selinux-2.16-r2.ebuild:
diff --git a/dev-python/python-selinux/python-selinux-2.16-r2.ebuild b/dev-python/python-selinux/python-selinux-2.16-r2.ebuild
index cabf08a0d676..2d39c46088dd 100644
--- a/dev-python/python-selinux/python-selinux-2.16-r2.ebuild
+++ b/dev-python/python-selinux/python-selinux-2.16-r2.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-selinux/python-selinux-2.16-r2.ebuild,v 1.4 2010/04/16 19:44:03 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-selinux/python-selinux-2.16-r2.ebuild,v 1.5 2011/02/08 17:47:41 arfrever Exp $
+
+PYTHON_DEPEND="2"
inherit python
@@ -13,17 +15,21 @@ SRC_URI="mirror://gentoo/${P}-1.tar.bz2"
KEYWORDS="amd64 x86"
IUSE=""
-DEPEND="dev-lang/python
- >=sys-libs/libselinux-1.28-r1"
+DEPEND=">=sys-libs/libselinux-1.28-r1"
RDEPEND="${DEPEND}"
S=${WORKDIR}/${PN}
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
src_compile() {
- emake PYVER="$(python_get_version)"
+ emake PYVER="$(python_get_version)" || die
}
src_install() {
python_need_rebuild
- make DESTDIR="${D}" PYVER="$(python_get_version)" install
+ make DESTDIR="${D}" PYVER="$(python_get_version)" install || die
}