summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarien Zwart <marienz@gentoo.org>2012-02-28 21:41:58 +0000
committerMarien Zwart <marienz@gentoo.org>2012-02-28 21:41:58 +0000
commitfaceb14fa62473d7cecdf4b25fdd9abd1c630ef5 (patch)
tree845d53768867c084e4405b38daf518445e728f05 /dev-python/python-poppler
parentMarking roundcube-0.7.1 ppc for bug 403711 (diff)
downloadgentoo-2-faceb14fa62473d7cecdf4b25fdd9abd1c630ef5.tar.gz
gentoo-2-faceb14fa62473d7cecdf4b25fdd9abd1c630ef5.tar.bz2
gentoo-2-faceb14fa62473d7cecdf4b25fdd9abd1c630ef5.zip
Add patch from Fedora so we do not wrap nonexistant API, gentoo bug #377063.
(Portage version: 2.2.0_alpha89/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/python-poppler')
-rw-r--r--dev-python/python-poppler/ChangeLog10
-rw-r--r--dev-python/python-poppler/files/python-poppler-0.12.1-poppler-0.18.0-minimal-fix.patch65
-rw-r--r--dev-python/python-poppler/python-poppler-0.12.1-r1.ebuild3
-rw-r--r--dev-python/python-poppler/python-poppler-0.12.1-r2.ebuild3
-rw-r--r--dev-python/python-poppler/python-poppler-0.12.1-r3.ebuild52
5 files changed, 130 insertions, 3 deletions
diff --git a/dev-python/python-poppler/ChangeLog b/dev-python/python-poppler/ChangeLog
index 3669f84e2335..6f178e2860fb 100644
--- a/dev-python/python-poppler/ChangeLog
+++ b/dev-python/python-poppler/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-python/python-poppler
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-poppler/ChangeLog,v 1.18 2012/02/24 08:08:11 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-poppler/ChangeLog,v 1.19 2012/02/28 21:41:58 marienz Exp $
+
+*python-poppler-0.12.1-r3 (28 Feb 2012)
+
+ 28 Feb 2012; Marien Zwart <marienz@gentoo.org>
+ +files/python-poppler-0.12.1-poppler-0.18.0-minimal-fix.patch,
+ +python-poppler-0.12.1-r3.ebuild, python-poppler-0.12.1-r1.ebuild,
+ python-poppler-0.12.1-r2.ebuild:
+ Add patch from Fedora so we do not wrap nonexistant API, gentoo bug #377063.
24 Feb 2012; Patrick Lauer <patrick@gentoo.org>
python-poppler-0.12.1-r1.ebuild, python-poppler-0.12.1-r2.ebuild:
diff --git a/dev-python/python-poppler/files/python-poppler-0.12.1-poppler-0.18.0-minimal-fix.patch b/dev-python/python-poppler/files/python-poppler-0.12.1-poppler-0.18.0-minimal-fix.patch
new file mode 100644
index 000000000000..2099e0af11f8
--- /dev/null
+++ b/dev-python/python-poppler/files/python-poppler-0.12.1-poppler-0.18.0-minimal-fix.patch
@@ -0,0 +1,65 @@
+--- pypoppler-0.12.1/poppler.defs 2011-10-24 11:57:35.000000000 +0200
++++ pypoppler-0.12.1/poppler.defs 2011-10-24 12:01:28.000000000 +0200
+@@ -1646,62 +1646,6 @@
+ (return-type "GType")
+ )
+
+-(define-method render_to_pixbuf
+- (of-object "PopplerPage")
+- (c-name "poppler_page_render_to_pixbuf")
+- (return-type "none")
+- (unblock-threads #t)
+- (parameters
+- '("int" "src_x")
+- '("int" "src_y")
+- '("int" "src_width")
+- '("int" "src_height")
+- '("double" "scale")
+- '("int" "rotation")
+- '("GdkPixbuf*" "pixbuf")
+- )
+-)
+-
+-(define-method render_to_pixbuf_for_printing
+- (of-object "PopplerPage")
+- (c-name "poppler_page_render_to_pixbuf_for_printing")
+- (return-type "none")
+- (unblock-threads #t)
+- (parameters
+- '("int" "src_x")
+- '("int" "src_y")
+- '("int" "src_width")
+- '("int" "src_height")
+- '("double" "scale")
+- '("int" "rotation")
+- '("GdkPixbuf*" "pixbuf")
+- )
+-)
+-
+-(define-method get_thumbnail_pixbuf
+- (of-object "PopplerPage")
+- (c-name "poppler_page_get_thumbnail_pixbuf")
+- (return-type "GdkPixbuf*")
+- (unblock-threads #t)
+-)
+-
+-(define-method render_selection_to_pixbuf
+- (of-object "PopplerPage")
+- (c-name "poppler_page_render_selection_to_pixbuf")
+- (return-type "none")
+- (unblock-threads #t)
+- (parameters
+- '("gdouble" "scale")
+- '("int" "rotation")
+- '("GdkPixbuf*" "pixbuf")
+- '("PopplerRectangle*" "selection")
+- '("PopplerRectangle*" "old_selection")
+- '("PopplerSelectionStyle" "style")
+- '("GdkColor*" "glyph_color")
+- '("GdkColor*" "background_color")
+- )
+-)
+-
+ (define-method render
+ (of-object "PopplerPage")
+ (c-name "poppler_page_render")
diff --git a/dev-python/python-poppler/python-poppler-0.12.1-r1.ebuild b/dev-python/python-poppler/python-poppler-0.12.1-r1.ebuild
index b015c5456b85..3f695f78f98d 100644
--- a/dev-python/python-poppler/python-poppler-0.12.1-r1.ebuild
+++ b/dev-python/python-poppler/python-poppler-0.12.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-poppler/python-poppler-0.12.1-r1.ebuild,v 1.6 2012/02/24 08:08:11 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-poppler/python-poppler-0.12.1-r1.ebuild,v 1.7 2012/02/28 21:41:58 marienz Exp $
EAPI="3"
PYTHON_DEPEND="2:2.6"
@@ -22,6 +22,7 @@ IUSE="examples"
S=${WORKDIR}/pypoppler-${PV}
RDEPEND=">=app-text/poppler-0.15.0[cairo]
+ <app-text/poppler-0.18
>=dev-python/pycairo-1.8.4
dev-python/pygobject:2
dev-python/pygtk:2"
diff --git a/dev-python/python-poppler/python-poppler-0.12.1-r2.ebuild b/dev-python/python-poppler/python-poppler-0.12.1-r2.ebuild
index 91d71324799f..d9bd996b4b80 100644
--- a/dev-python/python-poppler/python-poppler-0.12.1-r2.ebuild
+++ b/dev-python/python-poppler/python-poppler-0.12.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-poppler/python-poppler-0.12.1-r2.ebuild,v 1.2 2012/02/24 08:08:11 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-poppler/python-poppler-0.12.1-r2.ebuild,v 1.3 2012/02/28 21:41:58 marienz Exp $
EAPI="3"
PYTHON_DEPEND="2:2.6"
@@ -22,6 +22,7 @@ IUSE="examples"
S=${WORKDIR}/pypoppler-${PV}
RDEPEND=">=app-text/poppler-0.15.0[cairo]
+ <app-text/poppler-0.18
>=dev-python/pycairo-1.8.4
dev-python/pygobject:2
dev-python/pygtk:2"
diff --git a/dev-python/python-poppler/python-poppler-0.12.1-r3.ebuild b/dev-python/python-poppler/python-poppler-0.12.1-r3.ebuild
new file mode 100644
index 000000000000..3f42f67fa5ff
--- /dev/null
+++ b/dev-python/python-poppler/python-poppler-0.12.1-r3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-poppler/python-poppler-0.12.1-r3.ebuild,v 1.1 2012/02/28 21:41:58 marienz Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.6"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 2.5 3.* *-jython 2.7-pypy-*"
+PYTHON_EXPORT_PHASE_FUNCTIONS="1"
+
+inherit eutils libtool python
+
+DESCRIPTION="Python bindings to the Poppler PDF library"
+HOMEPAGE="http://launchpad.net/poppler-python"
+SRC_URI="http://launchpad.net/poppler-python/trunk/development/+download/pypoppler-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="examples"
+
+S=${WORKDIR}/pypoppler-${PV}
+
+RDEPEND=">=app-text/poppler-0.15.0[cairo]
+ >=dev-python/pycairo-1.8.4
+ dev-python/pygobject:2
+ dev-python/pygtk:2"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ # http://pkgs.fedoraproject.org/gitweb/?p=pypoppler.git;a=tree
+ epatch \
+ "${FILESDIR}"/${P}-75_74.diff \
+ "${FILESDIR}"/${P}-79_78.diff \
+ "${FILESDIR}"/${P}-poppler0.15.0-changes.patch \
+ "${FILESDIR}"/${P}-poppler-0.18.0-minimal-fix.patch
+
+ elibtoolize
+ python_copy_sources
+}
+
+src_install() {
+ python_src_install
+ python_clean_installation_image
+
+ dodoc NEWS || die
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins demo/demo-poppler.py || die
+ fi
+}